Fullscreen games lose "fullscreen" after an Alt+Tab

Bug #1725649 reported by draxil on 2017-10-21
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Medium
mutter (Ubuntu)
Medium
Unassigned
Artful
Medium
Unassigned

Bug Description

Impact
======
Using Alt-Tab to leave a fullscreen game and then return breaks the game by offsetting the display by the size of the GNOME Shell top bar.

Test Case
=========
1. Run a game full screen.

I installed Steam and used Team Fortress 2 because it's free (but a very large download)

2. Press Alt-Tab to switch to another window and then press Alt-Tab to switch back to the game.

The game should display and function normally.

Regression Potential
====================
This is fixed in mutter 3.26.2 (LP: #1730097)

These patches also fix LP: #1725821 but I was having trouble coming up with a specific test case for that issue that I could reproduce with my Intel graphics card.

The upstream bug mentions that this may re-introduce tearing with full-screen videos with Firefox because Firefox disables hardware graphics acceleration on Linux. Personally, I feel that is a Firefox bug and shouldn't block this fix. (The workaround for that is to visit about:config in Firefox and set layers.acceleration.force-enabled to true and restart Firefox.)

The issue of poor performance with full-screen games with GNOME 3.26 (a regression from GNOME 3.24) is a popular complaint in forums and should be fixed by these patches.

Other Info
==========
This bug is for the Xorg session. For the Wayland session, see LP: #1732245

Original Bug Report
===================
When playing a steam game in "fullscreen" (in this case stellaris) if I alt-tab out and then back the game is no longer full screen and a portion the size of the menu bar at the top is reserved, not showing the menu just a portion of the background colour. Also after this happens all mouse clicks are offset by that same margin.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-shell 3.26.1-0ubuntu4
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sat Oct 21 12:16:27 2017
DisplayManager: gdm3
GsettingsChanges:
 b'org.gnome.shell' b'command-history' b"['ubuntu-bug']"
 b'org.gnome.shell' b'favorite-apps' b"['firefox.desktop', 'terminator.desktop', 'emacs25.desktop', 'quodlibet.desktop', 'org.gnome.Nautilus.desktop', 'org.gnome.Software.desktop', 'gnome-control-center.desktop', 'thunderbird.desktop']"
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
InstallationDate: Installed on 2017-10-13 (7 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to artful on 2017-10-21 (0 days ago)

draxil (draxil) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Dražen Matešić (crazylemon) wrote :

Have the same issue.
Also using Ubuntu 17.10 with nvidia 384.90 driver.

Happens for me in Day of Infamy and Insurgency. I need to go to video settings and set to windowed or borderless and back to fullscreen in order to play the game in full screen again. Or just quit and relaunch it.

tags: added: nvidia
summary: - Fullscreen games loose "fullscreen" after an alt+tab
+ [nvidia] Fullscreen games lose "fullscreen" after an Alt+Tab

Sorry if this is stating the obvious, but I've switched back from gnome to unity and that is definitely not affected in the same manner; so it's definitely gnome-shell specific.

Changed in mutter (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2017-10-26
description: updated
summary: - [nvidia] Fullscreen games lose "fullscreen" after an Alt+Tab
+ Fullscreen games lose "fullscreen" after an Alt+Tab
affects: gnome-shell (Ubuntu) → mutter
Changed in mutter:
importance: Undecided → Unknown
status: Confirmed → Unknown
Changed in mutter (Ubuntu):
status: Confirmed → Fix Committed
Changed in mutter (Ubuntu Artful):
status: New → In Progress
Changed in mutter (Ubuntu):
importance: Undecided → Medium
Changed in mutter (Ubuntu Artful):
importance: Undecided → Medium
Changed in mutter:
importance: Unknown → Medium
status: Unknown → Fix Released
Jeremy Bicha (jbicha) on 2017-10-26
description: updated
Jeremy Bicha (jbicha) on 2017-10-27
Changed in mutter (Ubuntu):
status: Fix Committed → Fix Released
Luis Alvarado (luisalvarado) wrote :

Thank you Jeremy. Will be testing this out with several Steam games and provide feedback.

Luis Alvarado (luisalvarado) wrote :

So this are the results using the latest Mutter (3.26.1) from todays update plus Nvidia 387.22 with an Nvidia GTX 1080 - https://imgur.com/a/3stwv

With Dying Light both border issues showed.
With Mad Max one showed and after doing a 2nd ALT-TAB both showed.
With Shadow of Mordor both showed.

Marc Iulian (vibelinux) wrote :

Same behaviour here with latest Mutter (3.26.1), Nidia driver 384.90, and the Nvidia GTX 1050 Ti.
Tested on Counter-Strike 1.6, Counter-Strike:Global Offensive, Dota2, Insurgency.

Ads20000 (ads20000) wrote :

Are people able to reproduce the bug in the upstream fix and, if so, could they report to them that it's not working? Or what's the problem here? :) https://bugzilla.gnome.org/show_bug.cgi?id=788493

Jeremy Bicha (jbicha) on 2017-11-04
description: updated
Jeremy Bicha (jbicha) wrote :

Ads20000, I was able to reproduce the issue (and added a test case to the bug description). I have uploaded a new version of mutter to the artful queue where it will need to be manually approved by a member of the Stable Release Update team before it will be available as a -proposed update. If there are no regressions and the update seems to work, it will be released to all Ubuntu 17.10 users a week or so after that.

The bug status says "Fix Released" for Ubuntu because it's fixed in the development version of Ubuntu. It's still "In Progress" for Ubuntu 17.10.

Luis Alvarado (luisalvarado) wrote :

Thank you Jeremy, that cleared my confusion (And also understanding the flow of development). Think positive buddy.

Hello draxil, or anyone else affected,

Accepted mutter into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.26.2-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mutter (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
Steve Barcomb (linuxpng) wrote :

Quick question. If we enable the proposed PPA, how do we go back to getting stable updates? Just remove the PPA and keep apt updating like normal?

Dražen Matešić (crazylemon) wrote :

So mutter (and gir*-mutter) from proposed work for me. No more alt tab issue. There is one small issue left tho - when you use volume control for a few moments (2s maybe?) the top bar is visible like so https://i.imgur.com/oqhpxX0.jpg

Jeremy Bicha (jbicha) wrote :

Dražen, could you file a new bug for that issue?

Steve, -proposed updates isn't actually a PPA. You can enable it in the Software & Updates app on the Developer Options tab. I recommend installing just the specific -proposed updates you want to test. And then disable -proposed updates again. You'll still regular updates then.

vitus (drcurda) wrote :

Proposed package worked for me as well. Tested on CS:GO from steam, nvidia gtx 1050 with default nvidia driver from repository

Jeremy Bicha (jbicha) wrote :

I can verify that mutter 3.26.2-0ubuntu0.1 fixes the bug for the Ubuntu on Xorg session on Ubuntu 17.10. I opened LP: #1732245 for the similar unfixed issue with the Ubuntu on Wayland session.

tags: added: verification-done verification-done-artful
removed: verification-needed verification-needed-artful
Jeremy Bicha (jbicha) on 2017-11-14
description: updated

The verification of the Stable Release Update for mutter has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.26.2-0ubuntu0.1

---------------
mutter (3.26.2-0ubuntu0.1) artful; urgency=medium

  * New upstream release (LP: #1730097):
    - Fix unredirecting full-screen windows and fix returning to
      full-screen after Alt-Tab (LP: #1725649)
    - Allow HiDPI scaling even when non-HiDPI displays are connected
      (LP: #1724024)
    - Fix Epiphany URL bar (LP: #1719043) (Closes: #875826)
  * Drop cherry-picked patches

 -- Jeremy Bicha <email address hidden> Sat, 04 Nov 2017 14:07:59 -0400

Changed in mutter (Ubuntu Artful):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.