Failed to start Spark cluster

Bug #1544511 reported by Sergey Reshetnyak on 2016-02-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mirantis OpenStack
High
Sergey Reshetnyak
7.0.x
High
MOS Sahara
8.0.x
High
MOS Sahara
9.x
High
Sergey Reshetnyak

Bug Description

ENV: MOS 7.0

Upstream bug: https://bugs.launchpad.net/sahara/+bug/1544509

Launch of Spark cluster failed with the following error:

Creating cluster failed for the following reason(s): RemoteCommandException: Error during command execution: "sudo -u hdfs hdfs dfs -mkdir -p /user/$USER/"
Return code: 1

This bug affects the customer.

description: updated
tags: added: customer-found
description: updated
tags: added: area-sahara
tags: added: 8.0 release-notes-done

Fix proposed to branch: openstack-ci/fuel-8.0/liberty
Change author: Sergey Reshetnyak <email address hidden>
Review: https://review.fuel-infra.org/17904

Fix proposed to branch: openstack-ci/fuel-7.0/2015.1.0
Change author: Sergey Reshetnyak <email address hidden>
Review: https://review.fuel-infra.org/17905

Evgeny Sikachev (esikachev) wrote :

verified on 172 iso

Ekaterina Shutova (eshutova) wrote :

Verified on MOS 7.0 + mu6 updates.

Configuration:
MOS 7.0 + Sahara
Issue was not reproduced because customer has environment with some problems with file system(iops), on regular env there was no such issue, but with fix Spark cluster was created successfully without any problems or errors.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers