Playing files from "Devices & Shares" fails if they are not indexed in the DB

Bug #436562 reported by Olivier Tilloy
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Moovida
Fix Released
Critical
Olivier Tilloy

Bug Description

This is a regression introduced by revision 1530 in trunk (http://bazaar.launchpad.net/~elisa-developers/elisa/relook/revision/1530, was a "fix" for bug #257241).

Steps to reproduce:

1) Start Moovida, go to "DEVICES & SHARES" / "This Computer" / "Home"
2) Enter any folder that's not a permanent media source (not indexed in the DB)
3) Try to play any media file from there

Expected result: the files play.

Current result: the files don't play at all, no user feedback.

Tags: fix-verified

Related branches

Olivier Tilloy (osomon)
Changed in elisa:
importance: Undecided → High
milestone: none → 1.0.8
status: New → Confirmed
Olivier Tilloy (osomon)
summary: - Playing local files from "This Computer" fails if they are not indexed
- in the DB
+ Playing files from "Devices & Shares" fails if they are not indexed in
+ the DB
Changed in elisa:
importance: High → Critical
status: Confirmed → Fix Committed
assignee: nobody → Olivier Tilloy (osomon)
Revision history for this message
Sudesh (sudeshc-deactivatedaccount) wrote :

Unable to reproduce it on Moovida 1.0.7.I can play music files from folder which are not part of permanent sources.

Revision history for this message
Olivier Tilloy (osomon) wrote :

Luckily enough, this regression hadn't been released yet, it only affected the development version.

Revision history for this message
laura burbaite (lburbaite) wrote :

Verified in Windows Vista, moovida version 1.0.8
the local files seem to play fine.

tags: added: fix-verified
Olivier Tilloy (osomon)
Changed in moovida:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers