Waveform 2.0 randomly freezes

Bug #979925 reported by Gerion Entrup on 2012-04-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Critical
Thomas Vincent
1.11
Critical
Thomas Vincent

Bug Description

The waveforms of latest Mixxx Trunk are not shown or freezes after x seconds.

When I start mixxx, the waveform loads sometimes, but then freezes randomly. Very often it not even loads.
I tried to reproduce it, but don't see anything. In the debug messages I see no conspicuous one.
When I minimize mixxx (with running tracks) and then redo it, the waveform has updated but is still freezed.

I use Gentoo 64bit. My Qt version is 4.7.4. OpenGL is available throw free radeon driver.

If you need more Information, please say.

Thomas Vincent (vrince) wrote :

Could be nice to know if your are running any GL composite manager.
I experimented strange behavior with last ubuntu 11.04 + unity3d + compiz ...

RJ Ryan (rryan) on 2012-04-12
Changed in mixxx:
importance: Undecided → Critical
assignee: nobody → Thomas Vincent (vrince)
Gerion Entrup (gerion-entrup) wrote :

I use KDE 4.8. Effects are enabled.

Can you disable compositing / effects and confirm that the crash happens
without them turned on?

On Thu, Apr 12, 2012 at 11:05 AM, Gerion Entrup
<email address hidden>wrote:

> I use KDE 4.8. Effects are enabled.
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/979925
>
> Title:
> Waveform 2.0 randomly freezes
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/979925/+subscriptions
>

Gerion Entrup (gerion-entrup) wrote :

Disabled effects has no effects ;).

Minimizing is by the way not necessary, loose and get again the focus also works or when I move a window over mixxx (probably everytime when kwin renders the window).

Gerion Entrup (gerion-entrup) wrote :

Hmm, the focus and move thing only works with disabled effects.

Thomas Vincent (vrince) wrote :

Ok can you try to "suspend compositing" with Ctr-Shift-F12.

See this blog (http://blog.martin-graesslin.com/blog/2011/04/turning-compositing-off-in-the-right-way/) for more info about composite manager and GL contexts.

Thomas Vincent (vrince) wrote :

Seems to be Alt+Shift+F12 nowadays ... anyway try one of those cause disabling effect does not turn composting off.

Gerion Entrup (gerion-entrup) wrote :

I used already Alt+Shift+F12 to disable the effects. This is the shortcut which is enabled by default in the GUI. Using this shortcut has the effects described above.

I also started mixxx in a raw X-Server (xinit /usr/bin/mixxx -- :1) and the same error occured.

Thomas Vincent (vrince) wrote :

Ok then I need to test it on kwin ...
We really don't do extraordinary stuff for the moment so I don't see how such a thing can append.
Does the 1.10 work well with this configuration ?

jus (jus) wrote :

I have made a similar observation on MacOSX 10.6.8 maybe they are related.
If i select Filtered (GL) as display type, the waveform is displayed as static ( see picture), if i choose Filtered (GLSL) the waveform shows up blank with some error messages in log:
Warning [Main]: QGLShader: Unable to open file "./src/waveform/shaders/passthrough.vert"
Warning [Main]: QGLShader: Unable to open file "./src/waveform/shaders/computemaxsignal.frag"
Warning [Main]: QGLShader: Unable to open file "./src/waveform/shaders/passthrough.vert"
Warning [Main]: QGLShader: Unable to open file "./src/waveform/shaders/filteredsignal.frag"

Sometimes there is even a crash, especially when Mixxx just started up and i drag`n drop a track from the library to a main waveform. Backtrace just as the crash happens again: http://pastebin.com/QqLQQZhq

Thomas Vincent (vrince) wrote :

For the shader files I guess they are not deployed. Since those file are compile at run-time they need to be deployed in mixxx packages.

For the crash it looks like the update of your db failed and something wrong appended at saving time. It looks like mixxx is trying to allocate a huge array to store waveform data in memory !

"Mixxx(38796,0x7fff70ea7cc0) malloc: *** mmap(size=18446744071562072064) failed (error code=12)"

I'am talking with RJ about some other issues in this area, this need to be fixed for 1.11, I guess it deserve it's own but report !

It could be related to the static waveform you see, if waveform meta data is corrupted (dataSize, blablabla), the waveform display will be corrupted too.

Gerion Entrup (gerion-entrup) wrote :

Before the new Waveforms all worked fine, also in trunk (never tried the official 1.10 release).

Gerion Entrup (gerion-entrup) wrote :

Try the same :): http://pastebin.com/EV93YpDP
but don't know wether it is useful.

Thomas Vincent (vrince) wrote :

Any update on this bug ?

Can anyone can clarify if the freezing was an actual freeze (waveform do not move anymore) or if it is the spread-ed waveform (like in the screen shot).

The spread-ed one is related to waveform meta data (computed or retrieve form per-computed one) and major change have been made there.

Gerion Entrup (gerion-entrup) wrote :

No, I compiled mixxx from today trunk again an the only difference is that you can't reactivate the waveform once it is freezed. Before you are able to reactive, when you change the GL settings.

Gerion Entrup (gerion-entrup) wrote :

I compiled mixxx again and with "Filtered QT (GL)" it works fine. With "Filtered GL" it seems to work, too. The Waveform is then more detailed.

RJ Ryan (rryan) on 2015-12-31
Changed in mixxx:
status: New → Won't Fix
status: Won't Fix → Incomplete
tags: removed: 2.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers