Tracks File Path

Bug #773423 reported by KWhat on 2011-04-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
jus

Bug Description

I would be nice to have the ability to get the file path of a track in the library. I am imagining a read-only filed (that i can copy paste from) under the track information dialog.

RJ Skerry-Ryan (rryan) on 2011-04-29
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Wishlist

What? The Library used to have a column for Location that gave the full file path. Isn't it still available?

Owen Williams (ywwg) wrote :

I think he wants to be able to copy and paste it from the properties window, which isn't possible right now

Yea, that feature used to be there but I think I took it out of the
properties dialog in 1.8.0 (because I rewrote it and forgot to add it back
in).

On Fri, Apr 29, 2011 at 1:47 PM, Owen Williams <email address hidden> wrote:

> I think he wants to be able to copy and paste it from the properties
> window, which isn't possible right now
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/773423
>
> Title:
> Tracks File Path
>

jus (jus) wrote :

This patch against latest lp:mixxx adds a selectable Tracks File Path display in the track editor dialog.

More changes:
* Use tabs in Track editor like elsewhere in Mixxx
* Track name displayed in window title to save space
* Separates between editable and non-editable fields
* Add some more fields to the track information
* Non-editable fileds now selectable by mouse & keyboard
* Fix button order to follow common standards
* Fix alignments

Limitation (cause i could not figure it out):
* Missing Rating editor. I tried to put the editable Rating field beside the Key field
* Clicking "Accept" still closes the track editor (see lp:913255)
* Some track properties still missing ( e.g. played counter, sample rate...).

Still think it is an improvement compared to the current track editor.

Note:
Patch changes the Shortcut fro "New crate" from CTRL+C to CTRL+STRG+N. Imo it is more logical since the shortcut for "New playlist" is CTRL+N. It can now be used for e.g. copying the Tracks File Path. CTRL+C is a standard system shortcut and Mixxx should not block it.

jus (jus) wrote :
jus (jus) wrote :

Updated patch against lp:mixxx r3000

Also fixes lp:996246

jus (jus) wrote :

sry, should read "Updated patch against lp:mixxx r3100" ( the current one)

RJ Skerry-Ryan (rryan) wrote :

Patch looks good to me -- commit to trunk?

On Tue, May 8, 2012 at 8:56 AM, jus <email address hidden> wrote:

> sry, should read "Updated patch against lp:mixxx r3100" ( the current
> one)
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/773423
>
> Title:
> Tracks File Path
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/773423/+subscriptions
>

jus (jus) on 2012-05-08
Changed in mixxx:
assignee: nobody → jus (jus)
milestone: none → 1.11.0
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers