Support Banshee Integration

Bug #678173 reported by RJ Skerry-Ryan on 2010-11-21
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Daniel Schürmann

Bug Description

Since Banshee will be the new default music player in Ubuntu, we might want to consider integration the Banshee library as we did with Rhythmbox.

Related branches

RJ Skerry-Ryan (rryan) on 2010-11-21
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Low
importance: Low → Wishlist
TV (thomasv) wrote :

I look forward this feature too :)
Thanks.

Daniel Schürmann (daschuer) wrote :

Banshee aims to be a media platform, not just a player. See: http://download.banshee.fm/documents/banshee-gcds-09.pdf

Banshee has a very advanced track meta data editor, cover download and ...
It would be a hard work to catch up Banshee with Mixxx in library functionality.

Banshee is cleanly separated into core and client. So why not letting Mixxx be client in terms of banshee?

I had just a brief look into Banshee source, so I cannot estimate if this would be the right way.
Maybe someone of the Banshee experts can give us hints.

What do you think?

Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
Changed in mixxx:
status: Confirmed → In Progress
Daniel Schürmann (daschuer) wrote :

Due to the fact, banshee is based on GTK#, I will connect directly to the sqlite database of banshee using Qt.

n3rd (n3rd) wrote :

Any news on this?

Daniel Schürmann (daschuer) wrote :

Hi Reset,

have a working branch long ready for testing.

You will find builds on http://builds.mixxx.org/builds/experimental-daschuers_trunk/r3043/

Please Note: These experimental builds are only for testing propose. They are based on 1.11.0-alpha with an updated database schema. So its a good Idea to backup your "~/.mixxx" folder first.

It would be nice if you could comment your results and your ideas for improvements at
https://code.launchpad.net/~daschuer/mixxx/features_banshee/+merge/90381

Thank you,

Daniel

n3rd (n3rd) wrote :

Any plans to get this into Mixxx 11? I am eagerly waiting for this feature...

Daniel Schürmann (daschuer) wrote :

Sorry, we will not release it with Mixxx 1.11.
But I have just merged the lp:~daschuer/mixxx/features_banshee branch.
It is now head up with Mixxx 1.11.

n3rd (n3rd) wrote :

Is there a reason why the integration is not pushed any further?

RJ Skerry-Ryan (rryan) wrote :

Hi Reset -- we are past feature freeze for 1.11 so we can't introduce new features now -- we have to fix all the bugs and get the release out the door. It will be released in a future version.

Daniel Schürmann (daschuer) wrote :

The features_banshee branch reads directly from the banshee database. This is very performing on one hand but we have no guarantee from the banshee team that this will work without changes on each banshee update.

See https://mail.gnome.org/archives/banshee-list/2011-dicembre/msg00048.html

So there are objections in our team to have this in the Mixxx trunk.

I do not share these objections, because I have seen this working since I have made it without adaption to specific banshee versions.

The branch has to be ported to the baseexternal classes and I think your valid issues from the review have to be fixed an than IMO it is ready for trunk version.

Any comments from someone else?

jus (jus) wrote :

Merged to master, but has some some issues.
https://github.com/mixxxdj/mixxx/pull/101

Leaving as "In progress" for the time being.

Changed in mixxx:
milestone: none → 1.12.0
tags: added: library
RJ Skerry-Ryan (rryan) on 2014-01-03
Changed in mixxx:
status: In Progress → Fix Committed
JPi (juha-pitkanen) wrote :

I'd like the banshee playlists (i have dozens of them) to be displayed in Mixxx in alphabetical order.

Otherwise the library integration seems to work well in my current configuration:
Ubuntu 14.04, Banshee 2.6.2, Mixxx 1.12.0-alpha x64 (build master r4449)

Max Linke (max-linke) wrote :

I just tried it with some test playlists in banshee. Mixxx sorts the playlists alphabetical using the current master version?

Do you see non alphabetical ordering of the playlists?

JPi (juha-pitkanen) wrote :

I just tried with r4737, the newest in /builds/master -directory, but the order was still wrong. The playlists seem to appear in Mixxx in the creation order, ie the order in which the playlists are created in Banshee. Which versions of banshee and mixxx did you try?

JPi (juha-pitkanen) wrote :

Case closed. I fixed it by changing the source code and compiling the software myself.

Added "ORDER BY name" to the end of query: "SELECT PlaylistID, Name FROM CorePlaylists" in file bansheedbconnection.cpp.

Hope to see that in future builds.

Juha
------

Daniel Schürmann (daschuer) wrote :

Hi JPi

Thank you very much!
I am happy that it is fixed and I would like to include the fix in Mixxx 1.12
Please do the following:
* Sign the Contributor Agreement: https://docs.google.com/a/mixxx.org/spreadsheet/viewform?formkey=dEpYN2NkVEFnWWQzbkFfM0ZYYUZ5X2c6MQ
and comment her when done.
* Provide a patch against the current Mixxx master
* It is best to do it as a GitHub pull request. You find a guide here:
http://www.mixxx.org/wiki/doku.php/bugfix_workflow
* Once it is merge, your name will be listed in the Mixxx about box.
* Since this bug is already in the "Fix committed" state it would be nice, if you file a new one and assign it to yourself.
this way we are able to list the change in a change log for 1.12.

(Sorry for throwing such extra work at you. MIxxx development is based on it ;-) )

Kind regards,

Daniel

It would be nice if you did this. Then are you officially in our logs and we can
thank you appropriately in the about page.

On Sat, 08 Nov 2014 10:57:14 -0000
Daniel Schürmann <email address hidden> wrote:

> Hi JPi
>
> Thank you very much!
> I am happy that it is fixed and I would like to include the fix in Mixxx 1.12
> Please do the following:
> * Sign the Contributor Agreement:
> https://docs.google.com/a/mixxx.org/spreadsheet/viewform?formkey=dEpYN2NkVEFnWWQzbkFfM0ZYYUZ5X2c6MQ
> and comment her when done.
> * Provide a patch against the current Mixxx master
> * It is best to do it as a GitHub pull request. You find a guide here:
> http://www.mixxx.org/wiki/doku.php/bugfix_workflow
> * Once it is merge, your name will be listed in the Mixxx about box.
> * Since this bug is already in the "Fix committed" state it would be nice, if
> you file a new one and assign it to yourself. this way we are able to list
> the change in a change log for 1.12.
>
> (Sorry for throwing such extra work at you. MIxxx development is based
> on it ;-) )
>
> Kind regards,
>
> Daniel
>

JPi (juha-pitkanen) wrote :

I tried to do my best with very little competence.

I created account JuhaPitkanen to github and pulled the request.

I also tried to create the bug, but howto assign it to myself?

Juha
------

Daniel Schürmann (daschuer) wrote :

You did it. Thank you.
I am looking forward to you next contribution ;-)

RJ Skerry-Ryan (rryan) on 2015-12-30
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers