Fullscreen not working anymore

Bug #583303 reported by jus on 2010-05-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Medium
RJ Skerry-Ryan

Bug Description

Mixxx 1.8.0~beta2-pre "(bzr r2401; built on: May 20 2010; flags: hifieq vinylcontrol midiscript optimize=1 qdebug)
Tested on Mac OSX 10.5.8 & 10.6.3

Fresh Mixxx installation , all values on default

1. Start Mixxx
2. 30 pixel thick extra space appears below library
3. Switch to Fullscreen with F11, interface moves to the top-left corner , but no fullscreen at all
4 The extra space is now divided into 2 parts : 15 pixel on top / 15 pixel below

See screenshot...

You can make the extra space go away with changing skin ( not color scheme) , but fullscreen wont work either.

As of Mixxx Mixxx 1.8.0~beta2-pre (bzr r2373) - the last version i tested - Fullscreen with ESC works just fine.

There are some similar report:
https://bugs.launchpad.net/mixxx/+bug/200313
https://bugs.launchpad.net/mixxx/+bug/509235
https://bugs.launchpad.net/mixxx/+bug/581325

jus (jus) wrote :
jus (jus) wrote :

One thing i noticed later on:

All skins which uses CSS for positioning have now shifted positions for the playing position text.
This alignment bug only occurred when switching skins before, now it is right from the start.

See screenshot

RJ Skerry-Ryan (rryan) wrote :

The same happens for me on Linux.

Changed in mixxx:
milestone: none → 1.8.0
status: New → Confirmed
importance: Undecided → Medium
RJ Skerry-Ryan (rryan) wrote :

Just pushed a potential fix, could you try out the 1.8 branch? I can't reproduce exactly what was happening to me before.

Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
jus (jus) wrote :

Nice, fullscreen is working again.
As long as you don`t change a skin, see https://bugs.launchpad.net/mixxx/+bug/200313.

Small regression after patch:
If you change the skin and a track is loaded, the values for playing position / duration are nulled.

Tested Mixxx Trunk bzr r2493 built on: Jul 31 2010 on Mac OS 10.5 & 10.6

RJ Skerry-Ryan (rryan) wrote :

Fixed the regression. I think I'm going to mark this one fixed, since Bug #200313 is open for the problem of fullscreen after changing skins.

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers