Fullscreen breaks if you change the skin

Bug #200313 reported by Nick on 2008-03-09
2
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Unassigned
1.8
Medium
Albert Santoni

Bug Description

1) Start Mixxx (on OS X)
2) Change the skin
3) Go into fullscreen. It won't actually go into fullscreen.

Alternatively:

*Start Mixxx
*Goto fullscreen->works as expected
*Change skin
*Goto fullscreen->skin goes to 0,0 position & hides taskbar , but fullscreen does not work

Nick (kousu) wrote :

Oh sorry, I missed something. It only happens if you change the skin that Mixxx is using.

Nick (kousu) wrote :

*poke* this seems to have been forgotten. Here,
1) Start Mixxx (on OS X)
2) Change the skin
3) Go into fullscreen. It won't actually go into fullscreen.

Does this happen/not happen on linux?

Albert Santoni (gamegod) wrote :

I can confirm that this doesn't happen on Linux. Also, on Leopard at least, the waveform views just totally screw up if you go into fullscreen mode, and they don't come back when you go back to windowed mode. Fullscreen mode has lots of bugs, and it's really hard for us to fix the ones that are platform specific...

Albert Santoni (gamegod) on 2008-05-29
Changed in mixxx:
importance: Undecided → Low
status: New → Triaged
RJ Skerry-Ryan (rryan) on 2010-07-31
Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
RJ Skerry-Ryan (rryan) wrote :

Cannot reproduce on latest revision of 1.8.0 beta2 on Linux. The bug description of this bug is that fullscreen does not work after the first successful fullscreen attempt. It does not say anything about changing the skin.

Changed in mixxx:
assignee: RJ Ryan (rryan) → nobody
jus (jus) wrote :

Bug still stands similar as described in comment#2 on 2008-05-04

Tested Mixxx Trunk bzr r2493 built on: Jul 31 2010 on Mac OS 10.5 & 10.6

*Start Mixxx
*Goto fullscreen->works as expected
*Change skin
*Goto fullscreen->skin goes to 0,0 position & hides taskbar , but fullscreen does not work

RJ Skerry-Ryan (rryan) wrote :

Updating bug description and title to match comments #2 and #5. I can't reproduce on Linux, can someone with OSX take a whack at it?

summary: - Fullscreen doesn't fill screen after first use
+ Fullscreen breaks if you change the skin
description: updated
RJ Skerry-Ryan (rryan) on 2010-09-14
Changed in mixxx:
importance: Low → Medium
Albert Santoni (gamegod) wrote :

There was a workaround already in place for Linux, I changed the code to apply it to OS X as well. Seems to fix the problem.
Committed in r2580.

Changed in mixxx:
status: Triaged → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
jus (jus) wrote :

Bug kinda re-surfaced as of current Trunk (at least on OSX). Fullscreen fills the screen with background color/hides the taskbar band skin moves to upper left (0,0) position.

jus (jus) wrote :

Geez, not band - read "taskbar BUT skin".
Why can`t we edit comments again?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers