Jog wheel seeking much slower in in 1.8.0beta1 than 1.7.1

Reported by Anders Gunnarsson on 2010-03-01
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mixxx
High
Unassigned
1.8
High
Unassigned

Bug Description

Jog wheel seeking is considerably slower in 1.8.0beta1 than 1.7.1. On my RMX set to "normal" rate 1s equals to ~15
revolutions. System is Ubuntu 9.10.

I also see this on the SCS.3d. It's worse when the track is stopped.

Changed in mixxx:
status: New → Confirmed
Gabo (gabo-toimii) wrote :

I have Hercules DJ control mp3 on ubuntu 10.04 alpha. Mixxx trunk r2356 (not sure, i'm familar with bzr). Jog wheel seeking was too slow for me. I added 10x multiplier to mixxx/src/engine/ratecontrol.cpp. Now it feels better.

diff mixxx/src/engine/ratecontrol.cpp mixxx/src/engine/ratecontrol.cpp.orig
363c363
< rate = scratchFactor - 1.0f + jogFactor * 10 + wheelFactor/10.;
---
> rate = scratchFactor - 1.0f + jogFactor + wheelFactor/10.;

Changed in mixxx:
milestone: none → 1.8.0
importance: Undecided → Medium
assignee: nobody → Gabo (gabo-toimii)

It currently (trunk r2384) seems too sensitive now at 10ms latency.

Changed in mixxx:
assignee: Gabo (gabo-toimii) → RJ Ryan (rryan)
summary: - Jog wheel seeking much slower in in 1.8.0beta1 than 1.7.1
+ Jog wheel seeking much slower in in 1.8.0beta1 (too fast in current
+ trunk) than 1.7.1
summary: - Jog wheel seeking much slower in in 1.8.0beta1 (too fast in current
- trunk) than 1.7.1
+ Jog wheel seeking much slower in in 1.8.0beta1 than 1.7.1
Changed in mixxx:
status: Confirmed → Fix Committed

Mine's a separate issue. Marking fixed.

Albert Santoni (gamegod) wrote :

There are people still affected by this problem with Beta 2: http://mixxx.org/forums/viewtopic.php?f=3&t=1527

Two questions I need answered:
1) Does this problem affect all users with jog wheels?
2) If not, is the correct solution just updating the Hercules javascripts?

Thanks,
Albert

Changed in mixxx:
assignee: RJ Ryan (rryan) → nobody
importance: Medium → High
status: Fix Committed → Incomplete
Albert Santoni (gamegod) wrote :

DJ Thread confirms this is a problem on the RMX. So far we know it affects the Herc MP3 and the RMX.

Changed in mixxx:
status: Incomplete → Confirmed

These controllers are using "jog" and anders was saying he needed to multiply by a factor of 10, which suggests that line 391 in ratecontrol.cpp needs to have the division by 10 removed.

Changed in mixxx:
milestone: 1.8.0 → none

FWIW, the SCS.3d uses "jog" in vinyl1 (red) mode and I recall it too moving the track a lot less than in 1.7.x.

Sentenza (sentenzux) wrote :

My SCS.3d seems also far slower in 1.8b1 and b2

thread (thethread) wrote :

I just hacked my ratecontrol.cpp more like this, and now I have much better control when I beatmatch, when I seek locally, or spin back the outbound track (tune is stopped or playing). Actually, the beatmatching sensitivity (when playing) is lesser, and the seeking sensitivity (when stopped) is greater. And I like it this way.

Now that I have this sorted, I think I'm about to have a whole lot of fun with mixxx 1.8.0 beta 2 !

$ diff ratecontrol.cpp.orig ratecontrol.cpp
366c366
< else rate = oldScratchFactor + jogFactor + wheelFactor/10.; // Just remove oldScratchFactor in future
---
> else rate = oldScratchFactor + jogFactor * 18 + wheelFactor/10.; // Just remove oldScratchFactor in future
377c377
< rate += wheelFactor/10.;
---
> rate += wheelFactor * 10;

thread (thethread) wrote :

Whoops, I meant to say that the the beatmatching sensitivity (when playing) is lesser, and the seeking sensitivity (when stopped) is greater now VERSUS THE 1.7.3-pre VERSION I was using prior.

Albert Santoni (gamegod) wrote :

thread: I applied your patch in r2492 in the 1.8 branch.

I've tested it with the SCS.3d, but if anyone else could please test their controller's jog wheels to make sure they're behaving now, it would be greatly appreciated.

Thanks!
Albert

Anders Gunnarsson (d00guan) wrote :

With "jog" control, it seem to be fixed for stopped tracks but not for playing. Maybe jog for stopped tracks are a bit faster than in 1.7.2, as stated by thread.

gimmeapill (gimmeapill) wrote :

I can confirm on an RMX: The wheels are still completely unresponsive when a track is playing in lp:mixxx/1.8 R2512.
Behavior is more or less OK when tracks are stopped
Sratch mode doesn't scratch anything, but it does moves forward and backward (it used to work a bit better)

RJ Ryan (rryan) wrote :

The 'jog' control was being divided by 10 for playing decks. I've removed that now at Guy Martin's suggestion (in the dupe bug) and it seems to fix the issue. Anders and gimmeapill, could you try the latest revision of the 1.8 branch?

Thanks,
RJ

Anders Gunnarsson (d00guan) wrote :

I upgraded now and it works fine. All multipliers are now removed from my script.

Thanks for solving this!

RJ Ryan (rryan) on 2010-09-12
Changed in mixxx:
status: Confirmed → Fix Committed
gimmeapill (gimmeapill) wrote :

Wheel responsiveness problem fixed as of 1.8 trunk R2845

However, the commit 2560 (new RMX mappings) broke the wheels again: now it looks lime they are always in scratch mode,
But I guess a new bug should be opened for this, as other things are screwed up - please don't release with those mappings!

Are the old mappings releasable?
> Wheel responsiveness problem fixed as of 1.8 trunk R2845
>
> However, the commit 2560 (new RMX mappings) broke the wheels again: now it
looks lime they are always in scratch mode,
> But I guess a new bug should be opened for this, as other things are
screwed up - please don't release with those mappings!
>
> --
> Jog wheel seeking much slower in in 1.8.0beta1 than 1.7.1
> https://bugs.launchpad.net/bugs/529945
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.

gimmeapill (gimmeapill) wrote :

Yes, the base functionality of the old mappings was fine (for me at least)
The new ones still deserve some serious tweaking/testing, and they are certainly not functional out of the box...

RJ Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers