AutoDJ skipping scheduled tracks

Bug #1941989 reported by Uwe Klotz
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
High
Daniel Schürmann
Uwe Klotz (uklotzde)
description: updated
summary: - AutoDJ skips scheduled tracks
+ AutoDJ: Crashing due to memory leak and skipping scheduled tracks
Changed in mixxx:
importance: High → Critical
Revision history for this message
Be (be.ing) wrote :

Memory leaks could be from anything and probably have nothing to do with AutoDJ.

summary: - AutoDJ: Crashing due to memory leak and skipping scheduled tracks
+ AutoDJ skipping scheduled tracks
Revision history for this message
Daniel Schürmann (daschuer) wrote :

I can confirm this with the "Full Track Mode" and a slow spinning USB HDD.

Changed in mixxx:
status: New → In Progress
assignee: nobody → Daniel Schürmann (daschuer)
milestone: none → 2.3.2
Revision history for this message
Daniel Schürmann (daschuer) wrote :
Revision history for this message
Darren Smithson (darrenitu) wrote : Re: [Bug 1941989] Re: AutoDJ skipping scheduled tracks

Hi Daniel, is this for the crashing or the skipping? We do have a USB drive
attached as a library overflow drive on the main server, but the Mixxx
library points only to the internal drive. Plus on the show computer in a
different location, we don't have a drive attached, and the same thing
occurs (both crash wise and skip wise).

If we detach the drive and change from full track from the main server,
will that decrease the number of crashes until a proper fix is released?

Thanks
D

On Tue, 21 Sept 2021 at 23:30, Daniel Schürmann <email address hidden>
wrote:

> I can confirm this with the "Full Track Mode" and a slow spinning USB
> HDD.
>
> ** Changed in: mixxx
> Status: New => In Progress
>
> ** Changed in: mixxx
> Assignee: (unassigned) => Daniel Schürmann (daschuer)
>
> ** Changed in: mixxx
> Milestone: None => 2.3.2
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1942782).
> https://bugs.launchpad.net/bugs/1941989
>
> Title:
> AutoDJ skipping scheduled tracks
>
> Status in Mixxx:
> In Progress
>
> Bug description:
> There are multiple reports about skipped tracks in AutoDJ:
>
> https://mixxx.discourse.group/t/auto-dj-loosing-tracks/20014
>
> https://mixxx.discourse.group/t/tracks-skipped-in-auto-dj-mode-and-eventually-mixxx-crashes/22899
> https://mixxx.discourse.group/t/tracks-dropped-in-autodj-mode/22925
>
> https://mixxx.discourse.group/t/linux-mixxx-2-3-0-crashing-on-autodj-mode/22951
>
> Maybe related, but probably a separate issue:
> https://bugs.launchpad.net/mixxx/+bug/1941743
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/1941989/+subscriptions
>
>

Revision history for this message
Daniel Schürmann (daschuer) wrote :

This was for the skipping. However, I can no longer reproduce the issue even without the linked pull request, so I am not able to verify if may changes are actually the fix.

Which AutoDJ fade mode and fade time did you originally use?
On which OS are you.

It would be very helpful if you can test the linked Pull Request.
Here is described how: https://github.com/mixxxdj/mixxx/wiki/testing

Thank you.

Revision history for this message
Daniel Schürmann (daschuer) wrote :

I have filed https://bugs.launchpad.net/mixxx/+bug/1944512 for the crasher.
@Darren, please attache your mixxx.log file after a crash there.
https://github.com/mixxxdj/mixxx/wiki/Finding-The-Mixxx.Log-File

Revision history for this message
Darren Smithson (darrenitu) wrote :

Hi Daniel- it's Ubuntu 20.04.

I'll give the link you sent a try this weekend, I am going to soak retest
everything on Sunday!

PS I've always used full track and 3 seconds, except when in my live shows
and I do a live playout of 3 tracks with a 5 second crossfade.

On Wed, 22 Sept 2021 at 07:35, Daniel Schürmann <email address hidden>
wrote:

> This was for the skipping. However, I can no longer reproduce the issue
> even without the linked pull request, so I am not able to verify if may
> changes are actually the fix.
>
> Which AutoDJ fade mode and fade time did you originally use?
> On which OS are you.
>
>
> It would be very helpful if you can test the linked Pull Request.
> Here is described how: https://github.com/mixxxdj/mixxx/wiki/testing
>
> Thank you.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1942782).
> https://bugs.launchpad.net/bugs/1941989
>
> Title:
> AutoDJ skipping scheduled tracks
>
> Status in Mixxx:
> In Progress
>
> Bug description:
> There are multiple reports about skipped tracks in AutoDJ:
>
> https://mixxx.discourse.group/t/auto-dj-loosing-tracks/20014
>
> https://mixxx.discourse.group/t/tracks-skipped-in-auto-dj-mode-and-eventually-mixxx-crashes/22899
> https://mixxx.discourse.group/t/tracks-dropped-in-autodj-mode/22925
>
> https://mixxx.discourse.group/t/linux-mixxx-2-3-0-crashing-on-autodj-mode/22951
>
> Maybe related, but probably a separate issue:
> https://bugs.launchpad.net/mixxx/+bug/1941743
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/1941989/+subscriptions
>
>

Uwe Klotz (uklotzde)
Changed in mixxx:
status: In Progress → Fix Committed
importance: Critical → High
Revision history for this message
Darren Smithson (darrenitu) wrote :

Hi Uwe, I'll restart the server when I get to Studio B tomorrow and will
attach the log file as soon as it crashes! Fingers crossed it's as simple
to fix as the crash after a couple of days in v2x was all those years ago.
D

On Thu, 23 Sep 2021, 09:35 Uwe Klotz, <email address hidden> wrote:

> ** Changed in: mixxx
> Status: In Progress => Fix Committed
>
> ** Changed in: mixxx
> Importance: Critical => High
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1942782).
> https://bugs.launchpad.net/bugs/1941989
>
> Title:
> AutoDJ skipping scheduled tracks
>
> Status in Mixxx:
> Fix Committed
>
> Bug description:
> There are multiple reports about skipped tracks in AutoDJ:
>
> https://mixxx.discourse.group/t/auto-dj-loosing-tracks/20014
>
> https://mixxx.discourse.group/t/tracks-skipped-in-auto-dj-mode-and-eventually-mixxx-crashes/22899
> https://mixxx.discourse.group/t/tracks-dropped-in-autodj-mode/22925
>
> https://mixxx.discourse.group/t/linux-mixxx-2-3-0-crashing-on-autodj-mode/22951
>
> Maybe related, but probably a separate issue:
> https://bugs.launchpad.net/mixxx/+bug/1941743
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/1941989/+subscriptions
>
>

Revision history for this message
Darren Smithson (darrenitu) wrote :
  • mixxx.log Edit (1.1 MiB, application/octet-stream; name="mixxx.log")

Hi Uwe, here is the log file from the latest crash (after less than 7 hours
of autoplay).
D

On Thu, 23 Sept 2021 at 14:49, Darren Smithson <email address hidden> wrote:

> Hi Uwe, I'll restart the server when I get to Studio B tomorrow and will
> attach the log file as soon as it crashes! Fingers crossed it's as simple
> to fix as the crash after a couple of days in v2x was all those years ago.
> D
>
>
> On Thu, 23 Sep 2021, 09:35 Uwe Klotz, <email address hidden> wrote:
>
>> ** Changed in: mixxx
>> Status: In Progress => Fix Committed
>>
>> ** Changed in: mixxx
>> Importance: Critical => High
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (1942782).
>> https://bugs.launchpad.net/bugs/1941989
>>
>> Title:
>> AutoDJ skipping scheduled tracks
>>
>> Status in Mixxx:
>> Fix Committed
>>
>> Bug description:
>> There are multiple reports about skipped tracks in AutoDJ:
>>
>> https://mixxx.discourse.group/t/auto-dj-loosing-tracks/20014
>>
>> https://mixxx.discourse.group/t/tracks-skipped-in-auto-dj-mode-and-eventually-mixxx-crashes/22899
>> https://mixxx.discourse.group/t/tracks-dropped-in-autodj-mode/22925
>>
>> https://mixxx.discourse.group/t/linux-mixxx-2-3-0-crashing-on-autodj-mode/22951
>>
>> Maybe related, but probably a separate issue:
>> https://bugs.launchpad.net/mixxx/+bug/1941743
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/mixxx/+bug/1941989/+subscriptions
>>
>>

Revision history for this message
Uwe Klotz (uklotzde) wrote :

Thanks for providing a log file. The recurring warnings

Warning [Main]: CachingReader - Loading a new track while loading a track may lead to inconsistent states
Debug [CachingReaderWorker 2]: SoundSourceMp3 - MP3 frame header | layer: 0 mode: 0 #channels: 1 #samples: 36 bitrate: 0 samplerate: 0 flags: "0x0000"
Warning [Main]: Skip track with 0 Duration "/home/revolutionone/Music/Revolution Radio Music/Compilations/Classic Rock Presents One Nation Under A/04 Burn.mp3"

should already be fixed by https://github.com/mixxxdj/mixxx/pull/4319 and will be officially released with 2.3.2.

Please test the 2.3.x beta releases https://launchpad.net/~mixxx/+archive/ubuntu/mixxxbetas instead of 2.3.0 and report if this prevents the crash, which is now tracked in another bug: https://bugs.launchpad.net/mixxx/+bug/1944512

Revision history for this message
Darren Smithson (darrenitu) wrote :

Awesome, thank you I will set that up and let you know the outcome.

On Sun, 26 Sep 2021, 13:40 Uwe Klotz, <email address hidden> wrote:

> Thanks for providing a log file. The recurring warnings
>
> Warning [Main]: CachingReader - Loading a new track while loading a track
> may lead to inconsistent states
> Debug [CachingReaderWorker 2]: SoundSourceMp3 - MP3 frame header | layer:
> 0 mode: 0 #channels: 1 #samples: 36 bitrate: 0 samplerate: 0 flags: "0x0000"
> Warning [Main]: Skip track with 0 Duration
> "/home/revolutionone/Music/Revolution Radio Music/Compilations/Classic Rock
> Presents One Nation Under A/04 Burn.mp3"
>
> should already be fixed by https://github.com/mixxxdj/mixxx/pull/4319
> and will be officially released with 2.3.2.
>
> Please test the 2.3.x beta releases
> https://launchpad.net/~mixxx/+archive/ubuntu/mixxxbetas instead of 2.3.0
> and report if this prevents the crash, which is now tracked in another
> bug: https://bugs.launchpad.net/mixxx/+bug/1944512
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1942782).
> https://bugs.launchpad.net/bugs/1941989
>
> Title:
> AutoDJ skipping scheduled tracks
>
> Status in Mixxx:
> Fix Committed
>
> Bug description:
> There are multiple reports about skipped tracks in AutoDJ:
>
> https://mixxx.discourse.group/t/auto-dj-loosing-tracks/20014
>
> https://mixxx.discourse.group/t/tracks-skipped-in-auto-dj-mode-and-eventually-mixxx-crashes/22899
> https://mixxx.discourse.group/t/tracks-dropped-in-autodj-mode/22925
>
> https://mixxx.discourse.group/t/linux-mixxx-2-3-0-crashing-on-autodj-mode/22951
>
> Maybe related, but probably a separate issue:
> https://bugs.launchpad.net/mixxx/+bug/1941743
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/1941989/+subscriptions
>
>

Revision history for this message
Darren Smithson (darrenitu) wrote :
  • mixxx.log.1 Edit (492.8 KiB, application/octet-stream; name="mixxx.log.1")

Hi Uwe, it certainly looks like the track skipping is fixed, but Mixxx
still crashed after just 5 hours or so of autoplay. I've attached the
latest log file.

I have a live show Wednesday night from a Ubuntu 20 and Mixxx 2.3 computer
in a different location. Once that show is over, I will download the beta
to that and let that run AutoDJ overnight and until I leave on Friday PM,
just to make sure it is a common problem and not just this server. However,
I did a similar test on the second computer two weeks ago and that also
skipped tracks and crashed about about 8 hours of AutoDJ use, so I am
pretty sure it is a generic problem. Both computers are different
manufacturers and configurations, the only thing they have in common is
Mixxx 2.3 and Ubuntu 20.04.

Anyhow, here's the log. Good luck!
D

On Sun, 26 Sept 2021 at 23:09, Darren Smithson <email address hidden> wrote:

> Awesome, thank you I will set that up and let you know the outcome.
>
> On Sun, 26 Sep 2021, 13:40 Uwe Klotz, <email address hidden> wrote:
>
>> Thanks for providing a log file. The recurring warnings
>>
>> Warning [Main]: CachingReader - Loading a new track while loading a track
>> may lead to inconsistent states
>> Debug [CachingReaderWorker 2]: SoundSourceMp3 - MP3 frame header | layer:
>> 0 mode: 0 #channels: 1 #samples: 36 bitrate: 0 samplerate: 0 flags: "0x0000"
>> Warning [Main]: Skip track with 0 Duration
>> "/home/revolutionone/Music/Revolution Radio Music/Compilations/Classic Rock
>> Presents One Nation Under A/04 Burn.mp3"
>>
>> should already be fixed by https://github.com/mixxxdj/mixxx/pull/4319
>> and will be officially released with 2.3.2.
>>
>> Please test the 2.3.x beta releases
>> https://launchpad.net/~mixxx/+archive/ubuntu/mixxxbetas instead of 2.3.0
>> and report if this prevents the crash, which is now tracked in another
>> bug: https://bugs.launchpad.net/mixxx/+bug/1944512
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (1942782).
>> https://bugs.launchpad.net/bugs/1941989
>>
>> Title:
>> AutoDJ skipping scheduled tracks
>>
>> Status in Mixxx:
>> Fix Committed
>>
>> Bug description:
>> There are multiple reports about skipped tracks in AutoDJ:
>>
>> https://mixxx.discourse.group/t/auto-dj-loosing-tracks/20014
>>
>> https://mixxx.discourse.group/t/tracks-skipped-in-auto-dj-mode-and-eventually-mixxx-crashes/22899
>> https://mixxx.discourse.group/t/tracks-dropped-in-autodj-mode/22925
>>
>> https://mixxx.discourse.group/t/linux-mixxx-2-3-0-crashing-on-autodj-mode/22951
>>
>> Maybe related, but probably a separate issue:
>> https://bugs.launchpad.net/mixxx/+bug/1941743
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/mixxx/+bug/1941989/+subscriptions
>>
>>

Revision history for this message
Daniel Schürmann (daschuer) wrote :

Thank you for confirming the thread.
Please let's discuss the crasher here:
https://bugs.launchpad.net/mixxx/+bug/1944512

Revision history for this message
Be (be.ing) wrote :

Thank you for reporting your test results and attaching the log. Let's continue discussion about the crash on a new bug report: https://bugs.launchpad.net/mixxx/+bug/1945337

From the log it seems the crash is due to Mixxx saving metadata in a specific file, 04 - Stormy .mp3. Please test loading that specific file. If that crashes again, I do not think you will need to run AutoDJ for hours to reproduce the crash.

Then we need a backtrace to identify where the bug is. Refer to https://github.com/mixxxdj/mixxx/wiki/Creating-Backtraces#linux--mac-os-x-with-xcode-4x for instructions how to make a backtrace and please attach the backtrace as a file on the new bug report https://bugs.launchpad.net/mixxx/+bug/1945337

Changed in mixxx:
milestone: 2.3.2 → 2.3.1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers