Search for a quoted sentence does not work

Bug #1784141 reported by Daniel Schürmann on 2018-07-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Daniel Schürmann

Bug Description

Search for:
My Love
Finds all tracks with My or Love -> correct

Search for:
"My Love"
Finds the same like the unquoted text -> wrong, it should match only tracks with the exact phrase.

Workaround:
title:"My Love"
It Finds "My Love" and "My Love (Air Mix)" -> OK

It finds also "My Lover is Gone" -> unsure, we can argue about it

Search for:
title:"My Love "
Finds "My Lover is Gone" -> wrong, the tailing Space is not part of the title.
Unsure, if this shall also match "My Love"

Uwe Klotz (uklotzde) wrote :

I have made a different observation:

title:"My Love"
Finds all titles containing the sub-string "my love" (case insensitive) -> CORRECT

"My Love"
Finds nothing -> WRONG

Uwe Klotz (uklotzde) wrote :

Isn't this bug a duplicate of https://bugs.launchpad.net/mixxx/+bug/1784090 which has been created earlier?

Daniel Schürmann (daschuer) wrote :

I think it is not duplicate. #1784090 is about a single quote as apostrophe.
This here is a follow-up that was delivered during testing the first issue.

Be (be.ing) wrote :

If someone is motivated to fix this now, I think we should target it for 2.1.5.

Be (be.ing) on 2018-09-17
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 2.1.5
Changed in mixxx:
milestone: 2.1.5 → 2.1.6
Changed in mixxx:
assignee: nobody → Daniel Schürmann (daschuer)
status: Confirmed → In Progress
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers