search doesn't work with single quotes (apostrophes)

Bug #1784090 reported by nik.martin
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Daniel Schürmann

Bug Description

I just fetched master and built and now search doesn't work if the track/artist has an apostrophe. Example:

Search for "That's What I Like" - nothing.

Search "That What I like" works.

The workaround is simple, but this is pretty critical bug when you are busy and need to find a track

Revision history for this message
nik.martin (nik-martin) wrote :
Revision history for this message
Daniel Schürmann (daschuer) wrote :

Workaround:
Search for
title:"That's What I Like"

related:
https://bugs.launchpad.net/mixxx/+bug/1784141

Changed in mixxx:
status: New → Confirmed
importance: Undecided → High
milestone: none → 2.1.2
Revision history for this message
Daniel Schürmann (daschuer) wrote :

Can you you confirm the workaround?

I am trying to hunt it down, but I cannot reproduce it on my Ubuntu Trusty development machine using
libsqlite3-0 3.8.2-1ubuntu2.1 Qt4.8 and Qt5.2

I can reproduce it on my Ubuntu Xenial machine using libsqlite3-0 3.11.0-1ubuntu1 and Qt5.5.1

Interestingly ' does not work, but '' finds (7'' mix)

Can you confirm that?

Revision history for this message
Daniel Schürmann (daschuer) wrote :

On the Xenial system,

SELECT title from Library where title LIKE '%''%'

using http://sqlitebrowser.org/ with the same software stack works as it should.

Revision history for this message
Daniel Schürmann (daschuer) wrote :

Got it. It is a regression from https://github.com/mixxxdj/mixxx/pull/1388

Changed in mixxx:
status: Confirmed → In Progress
milestone: 2.1.2 → 2.2.0
assignee: nobody → Daniel Schürmann (daschuer)
Revision history for this message
Daniel Schürmann (daschuer) wrote :
Revision history for this message
nik.martin (nik-martin) wrote :

Can confirm the workaround works until the pull is merged into master

Revision history for this message
Daniel Schürmann (daschuer) wrote :
Be (be.ing)
Changed in mixxx:
importance: High → Medium
Revision history for this message
Uwe Klotz (uklotzde) wrote :

I have made a different observation:

That's What I Like
Find all tracks containing all of the (case-insensitive) strings in any order: "that's", "what" "i", "like"

title:"That's What I Like"
Finds all tracks containing the (case insensitive) sub-string "that's what i like" in the title -> CORRECT

"That's What I Like"
Finds nothing -> WRONG

Handling of quotations seems to be wrong without a preceding field selector. If it is a simple bug we should provide a fix for 2.1 and not only for 2.2.

Revision history for this message
Uwe Klotz (uklotzde) wrote :

The quotation bug I just mentioned has not been fixed by https://github.com/mixxxdj/mixxx/pull/1797. Should we create new issue or rename and reuse this issue for tracking?

Revision history for this message
Daniel Schürmann (daschuer) wrote :

I think we should set this to fix committed an use https://bugs.launchpad.net/bugs/1784141 for the general issue.

Be (be.ing)
Changed in mixxx:
status: In Progress → Fix Committed
milestone: 2.2.0 → 2.1.5
RJ Skerry-Ryan (rryan)
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers