Comment 6 for bug 1327614

Revision history for this message
Lee Matos (lbot) wrote :

I'm wondering if getIcon() should be abstracted a level up so that it doesn't have to be defined for each feature but instead you pass in the icon name and it works that way:

Psuedo-code
------------------

class feature:

method getIcon(icon_name):
  do stuff

recording_feature = new feature();

recording_feature.getIcon("recording_icon.svg");

analysis_feature = new feature();

analysis_feature.getIcon("analysis_icon.svg");

etc.

Seems like a cleaner solution I'm just not sure if there is a reason that stopping it from being done that way. Thoughts?