Mir

nouveau: Graphics tearing and abnormally high FPS with nouveau (no vsync)

Bug #1195811 reported by NickTh  on 2013-06-28
76
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Mir
High
Unassigned
linux (Ubuntu)
High
Maarten Lankhorst

Bug Description

I installed Ubuntu 13.10 (yesterday) in order to test Xmir and Mir natively (examples-clients). Xmirg worked flawlessly. The only "problem" was the duplicate mouse cursor(s).
But I noticed an abnormally high FPS in some clients demo when I tested Mir natively per these instructions
http://unity.ubuntu.com/mir/using_mir_on_pc.html

I recorded the test case using external camera. Apologies for the quality but you will see the values.
http://www.youtube.com/watch?v=zil-lRNlaks

I attached an apport.log just for more info if are needed.

I'm not a technical guy and I filled this report prompted by @duflu in IRC #ubuntu-mir
You can read the mini conversation here.
http://irclogs.ubuntu.com/2013/06/28/%23ubuntu-mir.html

This test had the same results either if X only was running in VT7 (Video) or Xmir.
I hope I helped... in something.

Regards
 NikTh

NickTh  (nick-athens30) wrote :
description: updated
description: updated
description: updated
description: updated
Daniel van Vugt (vanvugt) wrote :

What kind of monitor are you using? What's the vertical refresh rate?

Also, it is nouveau you're using, with an Nvidia GPU right?

summary: - Abnormally high FPS on natively mir testing demo-clients. Ubuntu 13.10
+ Abnormally high FPS (no vsync) on natively mir testing demo-clients.
+ Ubuntu 13.10

Yes, nouveau on Nvidia GPU.
The monitor is Samsung Syncmaster. Model: 2053BW. Native resolution: 1608x1050. Cable connection: HDMI to DVI. Refresh Rate: 60HZ

Daniel van Vugt (vanvugt) wrote :

The failure to wait for vsync is possibly a problem Mir has specifically on nouveau. I haven't tested nouveau+Mir yet.

kevin gunn (kgunn72) on 2013-07-10
Changed in mir:
importance: Undecided → Critical
Changed in mir:
status: New → Triaged
Doug McMahon (mc3man) wrote :

Tearing clearly seen here in all 3 common areas, Desktop, scrolling, videos. (tear test vid avail.
On nividia 8400m with nouveau. Card is supported for vsync in nouveau so auto enabled.
(though did try enabling in xorg.conf to no diff

Toby Scott (tobsco) wrote :

I also get screen tearing when using an nvidia 9400 GT. Vertical when moving windows around, and horizontal when scrolling, the horizontal tears are always in the same place near the middle of the screen. The monitor is a Samsung HDTV connected with DVI/HDMI , 1920x1080 @60Hz.

Confirmed on an Nvidia GeForce 210. Mir clients are not throttled to vsync. This is most obvious in the simple mir_demo_client_egltriangle:

Connected to display: resolution (1920x1200), position(0x0), supports 2 pixel formats
Using pixel format #3
libEGL warning: unsupported platform (null)
1 FPS
320 FPS
327 FPS
324 FPS
333 FPS
331 FPS
333 FPS
339 FPS

summary: - Abnormally high FPS (no vsync) on natively mir testing demo-clients.
- Ubuntu 13.10
+ nouveau: Abnormally high FPS (no vsync) on natively mir testing demo-
+ clients.
tags: added: nouveau
Daniel van Vugt (vanvugt) wrote :

I'm not sure how good nouveau's vblank timing is right now, but apparently big improvements are coming around kernel 3.12-ish...
http://lists.freedesktop.org/archives/dri-devel/2013-August/043407.html

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
affects: mesa (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
assignee: nobody → Maarten Lankhorst (mlankhorst)
status: New → In Progress
Daniel van Vugt (vanvugt) wrote :

Confirmed the following two kernel patches together fix the problem perfectly for Mir:
http://lists.freedesktop.org/archives/dri-devel/2013-August/043406.html
http://lists.freedesktop.org/archives/dri-devel/2013-August/043407.html

Now Mir under nouveau is always 60Hz with no tearing.

Unfortunately the patches make legacy X/Compiz much worse... only about 30Hz.

Jono Bacon (jonobacon) on 2013-08-15
tags: added: flavormirbug
Daniel van Vugt (vanvugt) wrote :

I will leave this triaged in Mir, even though it should be invalid for Mir, just so other Mir users can find the bug for now.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1195811

tags: added: package-qa-testing
summary: - nouveau: Abnormally high FPS (no vsync) on natively mir testing demo-
- clients.
+ nouveau: Abnormally high FPS and tearing (no vsync) on natively mir
+ testing demo-clients.

While the 2 commits do eliminate tearing here with nv50 that was brought back when using xmir/u-s-c, considering the current state of bug fixing it would be good not to create yet another bug in compiz
For 13.10 not using u-s-c is probably the best choice for users concerned about tearing & who have none with the current X, mesa, compiz & unity

Also to note that the commits did a decent job of eliminating tearing in gnomeshell/clutter, 100% gone with xmir/u-s-c, not quite 100% with just the commits (no xmir, u-s-c
Though Gs users can eliminate tearing completely with a simple env for clutter

If those commits are going to be applied it would be useful to provide a testing ppa to see how they do with other nvidia hardware & if they create any further issues other than noted previously with compiz.

Daniel van Vugt (vanvugt) wrote :

I think it's clear that nouveau at a kernel-level has problems which will cause tearing. So it would be a misdirection of effort to continue trying to fix various compositors while it's still failing to sync to vblank in the kernel.

To avoid confusing ourselves, we should probably wait until the kernel side is fixed. And then see what else might need work after that...

kevin gunn (kgunn72) on 2013-08-21
summary: - nouveau: Abnormally high FPS and tearing (no vsync) on natively mir
- testing demo-clients.
+ nouveau: Abnormally high FPS and tearing (no vsync) on native mir demo-
+ clients. (root caused nv kernel)
kevin gunn (kgunn72) on 2013-08-30
Changed in linux (Ubuntu):
importance: Undecided → Critical
summary: - nouveau: Abnormally high FPS and tearing (no vsync) on native mir demo-
- clients. (root caused nv kernel)
+ nouveau: Abnormally high FPS and tearing (no vsync) with nouveau

I don't think this bug is critical. Possibly not even high. The system is still quite usable. But High is a good compromise.

Changed in mir:
importance: Critical → High
Changed in linux (Ubuntu):
importance: Critical → High
Piotr Stefanczyk (sashx) wrote :

I have the same problem in my system (Ubuntu 13.10 daily 9-7-2013), but only in Xmir (in glxgears approx. 300 fps). Almost all native demos work perfectly except eglplasma demo (approx. 300 fps).

Daniel van Vugt (vanvugt) wrote :

OK, the Mir project is now collecting too many bugs which are not bugs in the Mir code. This one included.

Changed in mir:
status: Triaged → Invalid
Changed in mir:
status: Invalid → Opinion
status: Opinion → Invalid
summary: - nouveau: Abnormally high FPS and tearing (no vsync) with nouveau
+ nouveau: Graphics tearing and abnormally high FPS with nouveau (no
+ vsync)
Daniel van Vugt (vanvugt) wrote :

Seems to have been fixed in trusty at some point these past few months. Now working in kernel:
3.13.0-17-generic

NVIDIA Corporation GT218GL [Quadro FX 380 LP]

Changed in linux (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments