Midori: Webkit Web browser

Copy/Paste doesn't work

Reported by Michael Moroni on 2011-01-26
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Midori
Undecided
Christian Dywan

Bug Description

Hello!
I'm here to report that Cut/Copy/Pase functions a completely broken in Midori 0.2.9.
Previously I thought that it is just shortcut customazing feature what is broken (see my bug 707040), but it turned out that I cannot copy/paste even using a mouse (right-clicking and choosing "Copy" or "Pase" in the context menu).
Using a web-browser without working Ctrl+C/Ctrl+V functions is nearly impossible (at least it is very very inconvenient).

Please, do something to fix this. :'(

Moved from FS: http://www.twotoasts.de/bugs/index.php?do=details&task_id=1031

Michael Moroni (airon90) wrote :

works here, fedora 11 on olpc, gnome, midori 0.2.9
maybe related to it, though: printing (into pdf, no other printer/driver installd) gives me a screenshot instead of the whole page. that was on a site with download-disabled fotos. next i tried to print a forum thread. only the first site was printed. link-copying or text copying works per rightclick ctrl+c etc. copy paste of pics doesnt work, disbled downloads or not, maybe because abiword doesnt take it.
printing worked in midori 0.2.8, if i changed other things isnt clear to me. cups2pdf i didnt change, thats sure.
ps installing isnt possible because authors file isnt recognized by the installer (title changes from AUTHORS to authors in fedora)
im not sure if some of that is related to midori-bugs.

canin

Michael Moroni (airon90) wrote :

I have to add some information on this problem.
The Copy/Cut functions work in the address field and search fiels in the toolbar. But they do not work in the web-page area. I cannot copy any text from the web page.
When I try to "Cut" the text, it vanishes from the place it had been, but never gets into the clipboard (or copy/paste buffer), so I cannot paste it anywhere.

This is strange, since like I said, Copy/Cut works fine for the search and address fields, and this is the same appliction. I'm not sure, but could it be a Webkit-related bug or not?

v_2e

v_2e (v-2e) wrote :

  Hello!
  I just wanted to report that the problem still remains for Midori 0.3.0 on my machine.

Michael Moroni (airon90) on 2011-02-08
tags: added: copypasting

I've encountered this bug since 0.2.6. The problem is just as Michael Moroni describes it, copy/paste in the web page area doesn't work, but location bar is fine.

Changed in midori:
assignee: nobody → Christian Dywan (kalikiana)
status: New → Triaged
Christian Dywan (kalikiana) wrote :

This is a WebKitGTK+ bug, I filed https://bugs.webkit.org/show_bug.cgi?id=55843 .

To mitigate the pain I implemented a workaround in Midori.

Changed in midori:
status: Triaged → Fix Committed
Changed in midori:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.