Move to building with CMake

Bug #1211909 reported by Christian Dywan
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Midori Web Browser
Fix Released
High
Christian Dywan

Bug Description

We have a few motivations these days making a move to CMake attractive:
Debian considers Waf problematic due to being binary-distributed
On Windows its pkg-config handling leaves to be desired, see bug 1188587
Due to Python encoding enforcement bug 1211906 we'd need to upgrade Waf - or move away from it
Install writes files, see bug 1210358

Related branches

Changed in midori:
importance: Undecided → High
status: New → Confirmed
milestone: none → 0.5.6
description: updated
Changed in midori:
assignee: nobody → Christian Dywan (kalikiana)
Changed in midori:
status: Confirmed → In Progress
Changed in midori:
status: In Progress → Fix Committed
Changed in midori:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers