lhapdf 6 issues with 2.2.3

Bug #1424752 reported by Luca
This bug report is a duplicate of:  Bug #1421642: LHAPDF6 and aMC@NLO. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MadGraph5_aMC@NLO
Undecided
marco zaro

Bug Description

I downloaded the last version of MG5_aMC. When I try to use lhapdf 6.1.5 I get the following errors

INFO: Using LHAPDF v6.1.5 interface for PDFs
INFO: Compiling source...
INFO: ...done, continuing with P* directories
INFO: Compiling directories...
INFO: Compiling on 8 cores
INFO: Compiling P0_gg_ttx...
INFO: Compiling P0_uux_ttx...
INFO: Compiling P0_uxu_ttx...
terminate called after throwing an instance of 'LHAPDF_YAML::InvalidScalar'
  what(): yaml-cpp: error at line 28, column 12: invalid scalar

Program received signal SIGABRT: Process abort signal.

Backtrace for this error:
#0 0x10a6334f2
#1 0x10a633cae
#2 0x7fff87f3a5a9
terminate called after throwing an instance of 'LHAPDF_YAML::InvalidScalar'
  what(): yaml-cpp: error at line 28, column 12: invalid scalar

Program received signal SIGABRT: Process abort signal.

Backtrace for this error:
#0 0x10128a4f2
#1 0x10128acae
#2 0x7fff87f3a5a9
terminate called after throwing an instance of 'LHAPDF_YAML::InvalidScalar'
  what(): yaml-cpp: error at line 28, column 12: invalid scalar

Program received signal SIGABRT: Process abort signal.

and so on.

My gfortran is the one provided by gcc version 4.9.2 (Homebrew gcc 4.9.2) an my g++ is Apple LLVM version 6.0 (clang-600.0.56) (based on LLVM 3.5svn).

Thanks

Luca

Revision history for this message
marco zaro (marco-zaro) wrote :

Ciao Luca,
i fear that having gcc and g++ from different manufacturers creates many problems on a Mac...
I succeeded to use lhapdf6 opn a mac, but i had to make sure that all compilers (gcc/g++/gfortran) come from the gnu family, ie. no clang...

Otherwise i don't have a solution...
Cheers,

Marco

Changed in mg5amcnlo:
assignee: nobody → marco zaro (marco-zaro)
Revision history for this message
Luca (r8li) wrote :

Ciao Marco

What did you do? Did you compile lhapdf with gcc and the you set the g++ compiler in amc@nlo to a gnu family one? Do you think it will be enough?

thanks

Luca

Revision history for this message
marco zaro (marco-zaro) wrote : Re: [Bug 1424752] Re: lhapdf 6 issues with 2.2.3

Ciao Luca,
actually i did something more radical, as i made sure that the g++/c++ /gcc commands from the shell all refers to the gnu compiler
you can try your solution first, and see if it works…
Let me know,

Marco

On 23 Feb 2015, at 20:10, Luca <email address hidden> wrote:

> Ciao Marco
>
> What did you do? Did you compile lhapdf with gcc and the you set the
> g++ compiler in amc@nlo to a gnu family one? Do you think it will be
> enough?
>
> thanks
>
> Luca
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1424752
>
> Title:
> lhapdf 6 issues with 2.2.3
>
> Status in MadGraph5_aMC@NLO Generator:
> New
>
> Bug description:
> I downloaded the last version of MG5_aMC. When I try to use lhapdf
> 6.1.5 I get the following errors
>
> INFO: Using LHAPDF v6.1.5 interface for PDFs
> INFO: Compiling source...
> INFO: ...done, continuing with P* directories
> INFO: Compiling directories...
> INFO: Compiling on 8 cores
> INFO: Compiling P0_gg_ttx...
> INFO: Compiling P0_uux_ttx...
> INFO: Compiling P0_uxu_ttx...
> terminate called after throwing an instance of 'LHAPDF_YAML::InvalidScalar'
> what(): yaml-cpp: error at line 28, column 12: invalid scalar
>
> Program received signal SIGABRT: Process abort signal.
>
> Backtrace for this error:
> #0 0x10a6334f2
> #1 0x10a633cae
> #2 0x7fff87f3a5a9
> terminate called after throwing an instance of 'LHAPDF_YAML::InvalidScalar'
> what(): yaml-cpp: error at line 28, column 12: invalid scalar
>
> Program received signal SIGABRT: Process abort signal.
>
> Backtrace for this error:
> #0 0x10128a4f2
> #1 0x10128acae
> #2 0x7fff87f3a5a9
> terminate called after throwing an instance of 'LHAPDF_YAML::InvalidScalar'
> what(): yaml-cpp: error at line 28, column 12: invalid scalar
>
> Program received signal SIGABRT: Process abort signal.
>
>
> and so on.
>
> My gfortran is the one provided by gcc version 4.9.2 (Homebrew gcc
> 4.9.2) an my g++ is Apple LLVM version 6.0 (clang-600.0.56) (based on
> LLVM 3.5svn).
>
> Thanks
>
> Luca
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mg5amcnlo/+bug/1424752/+subscriptions

Revision history for this message
Luca (r8li) wrote :

Ciao Marco,

I am sorry, but I think that I don't like such a radical solution; I understand that as a developer you need to have a working copy of MG5 but as an user I don't see the necessity to use gnu compilers. Clang works perfectly fine (with the *only* exception of MG5 at the moment), is meant to optimise performances on OSX and therefore I am not willing to change it.

However, I temporarily changed g++/gcc/c++ and I build boost, lhapdf 6.1.5 (which now includes YAML that apparently causes the problem) and I tried to run MG5 but I keep finding the same error. At this point I am not sure what could be the solution; I may need to rebuild everything with gnu compilers to be sure that everything is consistent, but this is something that I don't want to do.

Thanks

Luca

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers