menulibre removes items from whisker menu

Bug #1732099 reported by Bill West
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fix Released
Sean Davis

Bug Description

Started with current Ubuntu 16.04 version as of today, then followed instructions in BUG "#1315991 too messy to summarize" to add ppa repository and updated from there.

Using Whisker menu.

Attempted to add new Launcher from command-line (bash) script in my home directory. Somewhere in the process menulibre crashed, but the launcher was added, but not in any category. Note that on original entry to menulibre the arrangement of items in the sidebar to not map in any obvious way to the arrangement of items in Whisker menu. Ignored this, but in retrospect think this was part of the problem.

Found the launcher under "All" in Whisker menu, and added it to favorites. Tried it, and it was not finding the command-line script. Went to "Edit Applications" again from whisker menu in order to update new Launcher. Menulibre crashed again. When I again looked at Whisker menu, the items in Favorites were completely different.

Opened menulibre again. My launcher was invisible, and the sidebar was very different.

Found bug #1315991 and followed upgrade instructions. Tried to use menulibre. Got this:

The following desktop files have failed parsing by the underlying library, and will therefore not show up in menulibre - please investigate these problems with the associated package maintainer:

/home/bill/.local/share/applications/menulibre-new-launcher.desktop: Exec program '~/start_synergys ' has not been found in the PATH

/usr/share/applications/evolution-data-server-uoa.desktop: Exec key not found

/usr/share/xubuntu/applications/Thunar-bulk-rename.desktop: Type key was not found

/usr/share/xubuntu/applications/Thunar.desktop: Type key was not found

/usr/share/xubuntu/applications/debian-uxterm.desktop: Type key was not found

/usr/share/xubuntu/applications/debian-xterm.desktop: Type key was not found

/usr/share/xubuntu/applications/thunar-settings.desktop: Type key was not found

/usr/share/xubuntu/applications/xfce4-terminal.desktop: Type key was not found

All of these things were working from Whisker menu before I started this process. It seems there is some kind of incompatibility between the way Whisker menu and menulibre handler the data file associated with the menus.

I have had similar problems with menulibre and Whiskey menu before, in particular when trying to add items under Wine. Strange things seemed to happen, but they were confined to the Wine sub-menu, and were not very critical, so I just ignored the problem, and started things from the command line when necessary.

Sorry this is not a clearer explanation, but I wasn't really paying close attention until things went significantly wrong. Since I don't have a backup of the original configuration, I can't really try to reproduce the problem.

Tags: whiskermenu
Bill West (billwest9)
tags: added: whiskermenu
removed: whiskeymenu
Revision history for this message
Sean Davis (bluesabre) wrote :

It seems launchers do not agree with ~/ paths. The below commit replaces these with the full home directory, eliminating this issue.

Changed in menulibre:
status: New → Fix Committed
Sean Davis (bluesabre)
Changed in menulibre:
milestone: none → 2.1.4
assignee: nobody → Sean Davis (bluesabre)
Sean Davis (bluesabre)
Changed in menulibre:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.