ffmpeg Unknown encoder 'mpeg2video' (Intredpid x64)

Reported by Wes Garner on 2008-09-14
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Medibuntu
Medium
Lionel Le Folgoc

Bug Description

FFmpeg version r11872+debian_3:0.svn20080206-12ubuntu1+medibuntu1

Terminal:
root@WG-Desktop:/home/wesgarner# /usr/bin/ffmpeg -i "/home/wesgarner/Videos/Data Drive/mvs-smart.avi" -vcodec mpeg2video -r 29.97 -b 4096K -maxrate 30000k -bufsize 1024k -aspect 16:9 -s 544x480 -comment pyTivo.py -ab 384k -ar 48000 -acodec ac3 -copyts -f vob "/test.avi"
FFmpeg version r11872+debian_3:0.svn20080206-12ubuntu1+medibuntu1, Copyright (c) 2000-2008 Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-pp --enable-swscaler --enable-x11grab --prefix=/usr --enable-libgsm --enable-libtheora --enable-libvorbis --enable-pthreads --disable-strip --enable-libdc1394 --enable-nonfree --enable-libamr-nb --enable-nonfree --enable-libamr-wb --enable-libmp3lame --enable-libfaac --enable-gpl --enable-libxvid --enable-gpl --enable-libx264 --enable-libfaadbin --enable-libfaad --enable-liba52 --enable-shared --disable-static
  libavutil version: 49.6.0
  libavcodec version: 51.50.0
  libavformat version: 52.7.0
  libavdevice version: 52.0.0
  built on Sep 7 2008 18:38:01, gcc: 4.3.2
Input #0, avi, from '/home/wesgarner/Videos/Data Drive/mvs-smart.avi':
  Duration: 01:45:25.5, start: 0.000000, bitrate: 926 kb/s
    Stream #0.0: Video: mpeg4, yuv420p, 640x352 [PAR 1:1 DAR 20:11], 25.00 tb(r)
    Stream #0.1: Audio: mp3, 48000 Hz, stereo, 32 kb/s
Unknown encoder 'mpeg2video'

I require the mpeg2video output because I am using pyTivo to transmit to my TiVo.

Lionel Le Folgoc (mrpouit) wrote :

Thanks for your bug report.
They have been removed in the debian/ubuntu packages, and we didn't see that…

Changed in medibuntu:
assignee: nobody → mrpouit
importance: Undecided → Medium
status: New → Triaged
milestone: none → intrepid
Changed in medibuntu:
status: Triaged → In Progress
Changed in medibuntu:
status: In Progress → Fix Released
wauwau (wauwau) wrote :

Hi,

as I am affected with the same problem, how did you solve it?!

Ubuntu Server 8.10 Alpha 6.

Ian Barton (ian-manor-farm) wrote :

I have installed the unstripped libraries:

sudo apt-get install libavcodec-unstripped-51
libavdevice-unstripped-52 libavutil-unstripped-49
libpostproc-unstripped-51 libswscale-unstripped-0

Now it seems that ffmpeg can't find them, or is trying to load the wrong version:

/home/ian/dvd/output/Great_British_Journeys_-_2008-10-03,_4-59_PM_-_William_Cobbett's_Rural_Rides.mpg
ffmpeg: error while loading shared libraries: libswscale.so.0: cannot open shared object file: No such file or directory

Ian.

Lionel Le Folgoc (mrpouit) wrote :

Is that the +unstripped1 or +unstripped2 revision? I think this issue should be fixed with the +unstripped2 one.

Ian Barton (ian-manor-farm) wrote :

It's the ones from Universe. Not sure if they are +1 or +2:

libavcodec-unstripped-51 - ffmpeg codec library
libavdevice-unstripped-52 - ffmpeg device handling library
libavformat-unstripped-52 - ffmpeg file format library
libavutil-unstripped-49 - ffmpeg utility library
libpostproc-unstripped-51 - ffmpeg video postprocessing library
libswscale-unstripped-0 - ffmpeg video scaling library

I have also tried the packages available from https://launchpad.net/~motumedia/+archive but these seem to lack support fro AAC at the moment. See https://bugs.launchpad.net/empathy/+bug/254201/comments/9

Ian.

Ian Barton (ian-manor-farm) wrote :

I have just done an apt-get update to get today's releases. This fixes the problem in https://bugs.launchpad.net/medibuntu/+bug/269997/comments/3 . However, I now get the problem I reported in https://bugs.launchpad.net/empathy/+bug/254201/comments/9

/home/ian/dvd/output/Great_British_Journeys_-_2008-10-03,_4-59_PM_-_William_Cobbett's_Rural_Rides.mpg
FFmpeg version r11872+debian_3:0.svn20080206-12ubuntu3, Copyright (c) 2000-2008 Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-pp --enable-swscaler --enable-x11grab --prefix=/usr --enable-libgsm --enable-libtheora --enable-libvorbis --enable-pthreads --disable-strip --enable-libfaad --enable-libfaadbin --enable-liba52 --enable-liba52bin --enable-libdc1394 --disable-armv5te --disable-armv6 --disable-altivec --disable-vis --enable-shared --disable-static
  libavutil version: 49.6.0
  libavcodec version: 51.50.0
  libavformat version: 52.7.0
  libavdevice version: 52.0.0
  built on Oct 3 2008 22:40:31, gcc: 4.3.2
Input #0, mpeg, from '/home/ian/dvd/output/Great_British_Journeys_-_2008-10-03,_4-59_PM_-_William_Cobbett's_Rural_Rides.mpg':
  Duration: 00:45:50.8, start: 0.242767, bitrate: 2762 kb/s
    Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 720x576 [PAR 64:45 DAR 16:9], 3748 kb/s, 25.00 tb(r)
    Stream #0.1[0x1c0]: Audio: mp2, 48000 Hz, stereo, 192 kb/s
Unknown encoder 'aac'

Ian.

wauwau (wauwau) wrote :

Where can I get the unstripped files? I couldnt find the repositories to add in my sources.conf.

Lionel Le Folgoc (mrpouit) wrote :

Ian > you should reopen the Ubuntu bug and add a comment on it.

wauwau > They are in intrepid/multiverse (http://packages.ubuntu.com/source/intrepid/ffmpeg).

Lionel Le Folgoc (mrpouit) wrote :

For the aac/xvid support missing, see Bug #285540. I uploaded a new revision in ubuntu, so hopefully this should be fixed soon.

boskicinek (boski-cinek) wrote :

I had the same problem with mpeg4 codec. Installing unstripped libs fixed it.

Ace Suares (acesuares) wrote :

Installing unstripped libs fixed something for me, too.

Anyway the program can prompt the user to add the stripped libraries? That would eliminated the need for them having to find this thread on the internet to realize that they need it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers