can't playback a second video

Bug #1376467 reported by Bill Filler
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Media Hub
Invalid
Undecided
Jim Hodapp
mediaplayer-app
Fix Released
Critical
Renato Araujo Oliveira Filho
qtubuntu-media
Invalid
Undecided
Thomas Voß
mediaplayer-app (Ubuntu RTM)
Fix Released
Undecided
Unassigned
qtubuntu-media (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

krilling rtm-proposed build 75

Playing back a video from the video scope or the camera app will launch the mediaplayer and play the video correctly. If you then switch back from the mediaplayer to the scope or app and try to play a different video, the mediaplayer does not update correctly and does not play it.

Steps:
- Go to camera-app
- record two different videos
- select the first one from the Photo Roll (via right edge swipe)
- press play button
- confirm the video plays in the media player
- when video finished switch back to camera-app
- now play the second video

Expected results:
video plays

Actual results:
mediaplayer does not update the preview and does not play the new video.

NOTE: you'll need the attached camera-app to test as the one in build 75 is broken because of file://

Related branches

Revision history for this message
Bill Filler (bfiller) wrote :
Revision history for this message
Bill Filler (bfiller) wrote :

install it with "pkcon --allow-untrusted install-local com.ubuntu.camera_3.0.0.400_armhf.click "

Changed in mediaplayer-app:
importance: Undecided → High
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
tags: added: rtm14 touch-2014-10-09
Revision history for this message
Renato Araujo Oliveira Filho (renatofilho) wrote :

I did some tests and I can confirm that. The application is requesting the MediaPlayer component to play the new file, but for some reason the low level library is not working correct.

Revision history for this message
Renato Araujo Oliveira Filho (renatofilho) wrote :
Revision history for this message
Bill Filler (bfiller) wrote :

marking invalid for mediaplayer-app as this code has not changed and was working up until recently. something in mediahub or other part of the stack changed to cause this regression

Changed in media-hub:
importance: Undecided → Critical
tags: removed: touch-2014-10-09
Changed in media-hub:
assignee: nobody → Jim Hodapp (jhodapp)
Changed in mediaplayer-app:
status: New → Invalid
Revision history for this message
Bill Filler (bfiller) wrote :

could be the same root causes that is causing this bug as well?
https://bugs.launchpad.net/gallery-app/+bug/1368767

Michael Frey (mfrey)
Changed in media-hub:
status: New → Confirmed
tags: added: touch-2014-10-23
Olli Ries (ories)
tags: added: touch-2014-10-16
removed: touch-2014-10-23
Revision history for this message
Ricardo Salveti (rsalveti) wrote :

Just confirmed this is still an issue with image 104 (rtm - krillin). It fails even if you try to play the second video without the first one completely finished (moving back to the video scopes trying to open up the second video).

Revision history for this message
Ricardo Salveti (rsalveti) wrote :

Works fine with image 72 (rtm - krillin), but then on image 73 I can't even play the video (mediaplayer-app will not even start). I can play the video with 75, but then I have the same issue as described by this bug.

http://people.canonical.com/~ogra/touch-image-stats/rtm/73.changes
http://people.canonical.com/~ogra/touch-image-stats/rtm/75.changes

Quite a few landings on both images, and both including media-hub.

Revision history for this message
Ricardo Salveti (rsalveti) wrote :

Sorry, media-hub is only at 75, the other changes in 73 are just responsible for the video not playing at all.

So it might be a regression with the huge landing we had on media-hub, the one that ended up bumping the api version to 2.

Jim Hodapp (jhodapp)
Changed in media-hub:
status: Confirmed → Triaged
Revision history for this message
Jim Hodapp (jhodapp) wrote :

The following always reproduces it for me:

1. Play a video from the scope
2. Swipe back to Unity which pauses video playback and suspends the mediaplayer-app
3. Play a second video from the scope, observe that it brings up mediaplayer-app but the video does not play

This method always plays:

1. Play a video from the scope
2. Tap to bring up the toolbar in mediaplayer-app, press the left arrow button to return to the video scope
3. Play a second video from the scope, observe that it brings up mediaplayer-app and plays the video

The second method works because it actually kills mediaplayer-app when you tap the left arrow. The first method only suspends and reuses the same media-hub session.

Changed in media-hub:
status: Triaged → In Progress
Changed in qtubuntu-media:
importance: Undecided → Critical
assignee: nobody → Thomas Voß (thomas-voss)
Revision history for this message
Michael Frey (mfrey) wrote :

After tracing this -- the media-player app does not properly convert the URI it is sent by the scope.

you can see in the media-hub log
audio_sink: pulsesink
video_sink: mirsink
Creating a new Engine instance in gstreamer::Engine::Engine()
Audio stream role: props,media.role=multimedia
virtual void core::ubuntu::media::PlayerImplementation::stop()
stop
Client allowed access since it's unconfined
filename: file:///home/phablet/Videos/com.ubuntu.camera/video20141015_181503349.mp4
Found video content
Creating video sink for texture_id: 1
void core::ubuntu::media::ServiceSkeleton::Private::handle_pause_other_sessions(const Ptr&)
Requested new display wakelock
play
pause

void core::ubuntu::media::PlayerImplementation::Private::clear_wakelock(const core::ubuntu::media::PlayerImplementation::Private::wakelock_clear_t&)
Clearing display wakelock
virtual void core::ubuntu::media::PlayerImplementation::stop()
[Info] Flush buffer h264_dec_decode !
[Info] Flush buffer h264_dec_decode !
[Info] Flush buffer h264_dec_decode !
[Info] Flush buffer h264_dec_decode !
[Info] Flush buffer h264_dec_decode !
[Info] Flush buffer h264_dec_decode !
stop
Client allowed access since it's unconfined
filename: video:///home/phablet/Videos/com.ubuntu.camera/video20141015_181503349.mp4
filename: video:///home/phablet/Videos/com.ubuntu.camera/video20141015_181503349.mp4
Found audio content
Creating video sink for texture_id: 1
void core::ubuntu::media::ServiceSkeleton::Private::handle_pause_other_sessions(const Ptr&)

Changed in media-hub:
status: In Progress → Invalid
Changed in mediaplayer-app:
status: Invalid → Confirmed
Revision history for this message
Michael Frey (mfrey) wrote :

The URI is only converted when the app is launched and passed via command line.

Changed in mediaplayer-app:
importance: High → Critical
Changed in qtubuntu-media:
importance: Critical → Undecided
Changed in media-hub:
importance: Critical → Undecided
Changed in qtubuntu-media (Ubuntu):
status: New → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mediaplayer-app - 0.20.5+14.10.20141015-0ubuntu1

---------------
mediaplayer-app (0.20.5+14.10.20141015-0ubuntu1) 14.09; urgency=low

  [ CI bot ]
  * Resync trunk

  [ Renato Araujo Oliveira Filho ]
  * Parse video uri when received from UriHandler. (LP: #1376467)
 -- Ubuntu daily release <email address hidden> Wed, 15 Oct 2014 21:51:43 +0000

Changed in mediaplayer-app (Ubuntu RTM):
status: New → Fix Released
Olli Ries (ories)
tags: added: touch-2014-10-23
removed: touch-2014-10-16
Changed in mediaplayer-app:
status: Confirmed → Fix Released
Changed in qtubuntu-media:
status: New → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtubuntu-media - 0.7.1+15.04.20141104-0ubuntu1

---------------
qtubuntu-media (0.7.1+15.04.20141104-0ubuntu1) vivid; urgency=low

  * New rebuild forced

qtubuntu-media (0.7.1+14.10.20141031~rtm-0ubuntu1) 14.09; urgency=low

  [ thomas-voss ]
  * Cut event connections on destruction. (LP: #1386803)

qtubuntu-media (0.7.1+14.10.20141022~rtm-0ubuntu1) 14.09; urgency=low

  [ Jim Hodapp ]
  * Add simple support for Orientation Property changed signal that
    comes from media-hub. Pass the video frame dimension in from media-
    hub through to qtvideo-node (LP: #1191934)

qtubuntu-media (0.7.1+14.10.20141015.1~rtm-0ubuntu1) 14.09; urgency=low

  [ thomas-voss ]
  * Make sure that invocations on probably deleted objects in async
    callbacks are guarded. Condense creation/deletion of controls in one
    place. (LP: #1376467)
 -- Ubuntu daily release <email address hidden> Tue, 04 Nov 2014 05:40:48 +0000

Changed in qtubuntu-media (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers