Music starts playing after a missed call

Bug #1421620 reported by costales on 2015-02-13
74
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Canonical Phone Foundations
Media Hub
Fix Released
High
Jim Hodapp
Ubuntu Music App
Undecided
Unassigned
media-hub (Ubuntu)
Undecided
Jim Hodapp
media-hub (Ubuntu RTM)
Undecided
Jim Hodapp

Bug Description

Hi! I have a similar issue to this bug #1414386. Not sure if it could be the same.
Device: Official BQ E4.5 Ubuntu Edition.

Steps:
1. Plugin headphones.
2. Play music.
3. Unplug headphones without stop the music > Music auto stops.
4. Make a missed call.
5. Bug > When the missed call is finish, the music starts playing by itself.

Thanks in advance!

Tags: bq Edit Tag help

Related branches

costales (costales) on 2015-02-13
description: updated
Victor Thompson (vthompson) wrote :

Hi costales! Thanks for taking the time to file this issue and for helping to make Ubuntu and the experience on the phone better! I would agree, this issue does sound identical to bug #1414386. I do not have a SIM on my device, so I can't replicate your issue. Hopefully someone from the media-hub project can figure out what the issue is and/or what data/logs they might need to do so.

James Lewis (james-fsck) wrote :

Confirmed, this happens to me, I think text message (possibly other notification sounds) trigger it also.

Changed in media-hub:
status: New → Confirmed
Jim Hodapp (jhodapp) wrote :

Confirmed. This is a media-hub issue for sure as I can also reproduce it using the music scope song preview instead of the music-app.

Changed in music-app:
status: New → Invalid
Changed in media-hub:
status: Confirmed → Triaged
assignee: nobody → Jim Hodapp (jhodapp)
importance: Undecided → High
Changed in ubuntu-rtm:
status: New → Confirmed
Changed in ubuntu:
status: New → Confirmed
Jim Hodapp (jhodapp) on 2015-02-23
Changed in ubuntu:
assignee: nobody → Jim Hodapp (jhodapp)
Changed in ubuntu-rtm:
assignee: nobody → Jim Hodapp (jhodapp)
Jim Hodapp (jhodapp) on 2015-03-20
summary: - Music starts playing after a missing call
+ Music starts playing after a missed call

This happens also in a slightly different scenario:

Steps to reproduce:
1. play music on headphones
2. unplug headphones (music stops playing, good!)
3. (about 10 minutes later) receive and answer a phone call
4. end the phone call

Desired effect:
Nothing happens, the music does not start playing again, because that would be weird!

Effect I got:
Music starts playing again. THAT IS WEIRD!

Jim Hodapp (jhodapp) wrote :

This is on the backlog of items to fix, hopefully we will get to it soon as I agree this is an annoying one. Thanks for your patience.

Jim Hodapp (jhodapp) on 2015-03-31
Changed in media-hub:
status: Triaged → In Progress
Changed in ubuntu:
status: Confirmed → In Progress
Changed in ubuntu-rtm:
status: Confirmed → In Progress
description: updated
description: updated
Jim Hodapp (jhodapp) on 2015-03-31
Changed in media-hub:
status: In Progress → Fix Committed
affects: ubuntu → media-hub (Ubuntu)
affects: ubuntu-rtm → media-hub (Ubuntu RTM)
Changed in canonical-devices-system-image:
assignee: nobody → Canonical Phone Foundations (canonical-phonedations-team)
importance: Undecided → Medium
milestone: none → ww13-ota
status: New → In Progress
tags: added: bq
Changed in media-hub (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Jim Hodapp (jhodapp) on 2015-04-02
Changed in media-hub (Ubuntu):
status: In Progress → Fix Committed
Jim Hodapp (jhodapp) on 2015-04-08
Changed in media-hub (Ubuntu):
status: Fix Committed → Fix Released
Changed in media-hub:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers