On a call w/headphones, device button don't adjust volume

Bug #1336536 reported by Julien Funk
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Media Hub
Invalid
Undecided
Unassigned
The Sound Menu
Invalid
Undecided
Unassigned
indicator-sound (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

1. Make a call to your mother with headphones in and a reasonably high volume (mother optional)
2. Wince at the high volume as your mother speaks to you
3. Attempt to reduce volume by clicking the 'volume down' button on the side of the phone

EXPECTED RESULT: volume goes down

What happened was the volume remained very high and I was forced to unplug the headphones to continue talking.

<https://wiki.ubuntu.com/Sound#primary-output>: "...the primary sound output ... is the device ... that should change volume when you press ... the volume buttons/rocker on a phone ... If you connect or pair headphones or a headset, or any audio output device except a secondary display, the primary output should change to that device."

Revision history for this message
Julien Funk (jaboing) wrote :
Revision history for this message
Julien Funk (jaboing) wrote :

The fix for this should come with an automated test so this regression doesn't happen again.

Jim Hodapp (jhodapp)
Changed in media-hub:
status: New → Invalid
Revision history for this message
Julien Funk (jaboing) wrote :

Just discovered this also affects all other modes, ie regular call volume and speakerphone. All 3 should be tested in automation.

Revision history for this message
Ricardo Salveti (rsalveti) wrote :

This is not a regression, and known. Will be fixed once we're able to control the voice volume during a call (which I'm still working on).

description: updated
Changed in indicator-sound:
status: New → Triaged
Ted Gould (ted)
Changed in indicator-sound (Ubuntu):
status: New → Triaged
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

long ago fixed

tags: added: volume
Changed in indicator-sound (Ubuntu):
status: Triaged → Invalid
Changed in indicator-sound:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers