Dialer app for Ubuntu Touch

[dialer app] During a live call, there's no volume adjustment available

Reported by Christina Li on 2013-08-29
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
Christina Li
dialer-app
High
Unassigned
dialer-app (Ubuntu)
High
Ricardo Salveti
Saucy
High
Ricardo Salveti
pulseaudio (Ubuntu)
High
David Henningsson
Saucy
High
David Henningsson

Bug Description

Current situation:
Can't adjust the voice volume during a live call, making it difficult to hear the receiver

Desired:
Can adjust volume during a live call (Eg using the volume buttons on the device)

tags: added: dialer-app-aug-2013
Changed in ubuntu-ux:
status: New → Fix Committed
assignee: nobody → Christina Li (christina-li)
importance: Undecided → High
summary: - [dailer] During a live call, there's no volume adjustment available
+ [dailer app] During a live call, there's no volume adjustment available
Bill Filler (bfiller) on 2013-08-29
Changed in ofono (Ubuntu):
assignee: nobody → Tony Espy (awe)
Changed in pulseaudio (Ubuntu):
assignee: nobody → David Henningsson (diwic)
Changed in ofono (Ubuntu):
importance: Undecided → High
Changed in pulseaudio (Ubuntu):
importance: Undecided → High
Tony Espy (awe) on 2013-08-29
Changed in ofono (Ubuntu):
status: New → Invalid

I marked ofono (Ubuntu) as "Invalid", as call-volume is something that needs to be handled by an external component.

Although the high-level ofono API provides a call-volume feature, RIL does not ( it only offers mute ), and thus call volume must be driven by the higher layers ( most likely telepathy-ofono ) either via PulseAudio, or the Android audio HAL interface.

summary: - [dailer app] During a live call, there's no volume adjustment available
+ [dialer app] During a live call, there's no volume adjustment available
David Henningsson (diwic) wrote :

I think there are two bugs here. The current code sets the voice volume to maximum.

I'm currently looking into how to change that volume from PulseAudio.

However, if your problem is that it's "difficult to hear the receiver", it sounds like the volume needs to be higher than it is today. Can you clarify this, and if so, which device is it that is having the problem (N4 or GN?), and does it occur both on earpiece, speakerphone and headphone modes?

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
Christina Li (christina-li) wrote :

I'm on Nexus 4.

Volume set today is too soft to hear. The same problem occurs for earpiece. Haven't tested with speaker phone yet.

David Henningsson (diwic) wrote :

That's a little weird - I have tested Nexus 4 today (with an image from a few days ago), and I think the call volume is quite ok.
(But it's difficult to verify when you're calling yourself for the testing.)

Christina Li (christina-li) wrote :

This was actually tested between two Nexus 4 between myself and another designer on the team. We tested it on 4 Sept's image.
We both had problems hearing each other.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dialer-app (Ubuntu):
status: New → Confirmed
David Henningsson (diwic) wrote :

This should now be fixed on Mako (Nexus 4) - you can use the sound indicator to change the volume while you're on a call. Anybody wants to verify?

Still not working on Maguro (Galaxy Nexus), I don't know why. It looks like the relevant call to Android is working as expected.

Changed in pulseaudio (Ubuntu):
status: Incomplete → Fix Released
Bill Filler (bfiller) wrote :

@diwic
What's the plan to fix on Galaxy Nexus? Changing status back to confirmed until that is addressed.

Changed in pulseaudio (Ubuntu):
status: Fix Released → Confirmed
no longer affects: ofono (Ubuntu)
Changed in dialer-app:
status: New → Confirmed
importance: Undecided → High
Changed in dialer-app (Ubuntu):
importance: Undecided → High
David Henningsson (diwic) wrote :

@bfiller, something is wrong on the Android side, inside the proprietary blob somehow. rsalveti to investigate further.

Changed in touch-preview-images:
assignee: nobody → Ricardo Salveti (rsalveti)
Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
Christina Li (christina-li) wrote :

@everyone- I tested the volume on Nexus 4 today. While on a call, the volume is now fine at maximum, however the same volume (maximum) is too soft when switched to speaker phone.

tags: added: dialer-app-sept-2013
Alan Pope ㋛ (popey) on 2013-09-18
Changed in dialer-app (Ubuntu):
assignee: nobody → Ricardo Salveti (rsalveti)
no longer affects: touch-preview-images
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers