3.0b2 database schema migrations

Bug #971013 reported by Barry Warsaw on 2012-04-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNU Mailman
Critical
Barry Warsaw

Bug Description

The following database schema migrations are required. This is a release blocker for 3.0 final. Add more to this bug as you find them.

 * Change news_prefix_subject_too -> nntp_prefix_subject_too

 * Remove nntp_host from table mailing list

Barry Warsaw (barry) wrote :

* archive and archive_private -> archive_policy

See LP: 967238

Barry Warsaw (barry) wrote :

Make that LP: #967238

Barry Warsaw (barry) on 2012-04-08
summary: - Database schema migrations needed
+ 3.0b2 database schema migrations
Barry Warsaw (barry) wrote :

news_moderation -> newsgroup_moderation

Barry Warsaw (barry) on 2012-04-20
Changed in mailman:
status: Confirmed → In Progress
assignee: nobody → Barry Warsaw (barry)
Barry Warsaw (barry) wrote :

include_list_post_header should probably be renamed too because RFC 2369 says that announce lists should still include the List-Post header, but set its value to NO.

I'm not sure what the flag should be called though.

Barry Warsaw (barry) wrote :

include_list_post_header -> allow_list_posts

When set to False, add List_Post: NO

Barry Warsaw (barry) on 2012-07-26
Changed in mailman:
status: In Progress → Fix Committed
Changed in mailman:
status: Fix Committed → Confirmed
Barry Warsaw (barry) wrote :

Bernard. I appreciate your help, but please don't change the status of fix committed bugs. This status helps us track issues for releases, adn "Confirmed" means it's an open bug. Even if the bug hasn't been fixed, please simply enter a comment instead of changing the bug status. Thanks.

Changed in mailman:
status: Confirmed → Fix Committed
Barry Warsaw (barry) on 2012-09-08
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers