Feature Request: Admin change subscriber's e-mail

Bug #266809 reported by Djbehrens
2
Affects Status Importance Assigned to Milestone
GNU Mailman
Medium
Mark Sapiro

Bug Description

I would like to be able to go into Membership
Management and be able to change a subscriber's e-mail
address without sending a confirmation to the user.
I'd rather not have to unsubscribe and resubscribe them
with a different e-mail address.

In my case, I'm taking an old listproc list and moving
the user list wholesale into mailman, and then cleaning
up the resulting mess.

[http://sourceforge.net/tracker/index.php?func=detail&aid=1286298&group_id=103&atid=350103]

Related branches

Revision history for this message
Nes49 (nes49) wrote :

Originator: NO

Yes, please. If the administrator can add someone without their
confirmation, why is a confirmation required for an address change?

Revision history for this message
Mark Sapiro (msapiro) wrote :

Originator: NO

I have some implementation questions.

The simplest way to do this is to check in the options page processing for
authorization by list or site admin and if so, skip the confirmation of an
address change. However, this is a substantive change of behavior and could
be a big surprise for an admin who expected the change to require
confirmation. So is this change in behavior acceptable?

If not, what shoud the UI look like for an address change? Should it still
be on the options page with a note for admins only that it won't be
confirmed or a check box for admins only to bypass confirmation, or should
it be a new function in membership management?

Revision history for this message
Djbehrens (djbehrens) wrote :

Originator: YES

I would think the best place for this would be the membership management
page. There is a checkbox to unsub the subscriber, I would think another
checkbox could be added to edit the subscriber's address. Then another
page would load to be able to edit the e-mail address, and then there could
be a checkbox on that page to make the change without sending the
subscriber confirmation e-mails.

Also I would think if a change is made on the options page processing that
this could possibly lead to un-intended list config change--and might cause
more problems than it's worth.

The main reason I requested this feature was in migrating an old listproc
list, where a user was subscribed as <email address hidden> their
emails would be stamped as <email address hidden> or
<email address hidden> obviously mailman would reject their
e-mail postings (as being a list that only subscribers can post to.)

Revision history for this message
Mark Sapiro (msapiro) wrote :

This has recently come up on the mailman-users list, and I realize the obvious way to do it is just add a 'change member address' category under Membership Management.... Or possibly add a 'new address' text box to the Membership List pages. I'll consider this for the next release.

Changed in mailman:
assignee: nobody → Mark Sapiro (msapiro)
milestone: none → 2.1.20
status: New → Triaged
Mark Sapiro (msapiro)
Changed in mailman:
status: Triaged → Fix Committed
Mark Sapiro (msapiro)
Changed in mailman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers