Option to not have a display name on Views

Bug #548021 reported by Ian Knox on 2009-08-06
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Nigel Cunningham

Bug Description

Currently all views show a display name. It would be good to have an option to just have a view title without 'by display name'.

Nigel-catalyst (nigel-catalyst) wrote :

Thanks for the report :)

Changed in mahara:
assignee: Richard Mansfield (richard-mansfield) → nobody
description: updated
tags: removed: mahara-eduforge-feature-request
Aaron Wells (u-aaronw) wrote :

Identified as a usability priority by the Slovenian Mahara user group: https://mahara.org/interaction/forum/topic.php?id=6283&offset=0&limit=10#post26642

tags: added: usability
Tobias Zeuch (tobias-zeuch-8) wrote :

What about only showing the author, if his profile is visible to the viewer? This would hide the the author when he publishes the page in most cases, except when he publically shared his profile.
On the other hand, it doesn't make sense to link to the profile if the viewer can't see it anyways.
Plus it's easy to realize, suggested patch following

Reviewed: https://reviews.mahara.org/3373
Committed: http://gitorious.org/mahara/mahara/commit/8766e7df0b966bd53831c45b71245e6aa1b5abae
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 8766e7df0b966bd53831c45b71245e6aa1b5abae
Author: Tobias Zeuch <email address hidden>
Date: Tue May 20 14:23:33 2014 +0200

Hide author on view if his profile page isn't visible

Bug 548021: Right now, the author is always displayed on a page, even if it is
publically shared. Suggestion: only show author, if the currently logged in
user (may be anonymous/not logged in) can see his profile page

Change-Id: I998e1395d3a5f8d167314862d6e1e4b83a7bdf4b
Signed-off-by: Tobias Zeuch <email address hidden>

Robert Lyon (robertl-9) on 2014-05-28
Changed in mahara:
milestone: none → 1.10.0
status: Confirmed → Fix Committed
Aaron Wells (u-aaronw) wrote :

I'm not comfortable with this patch, because it allows users to create anonymous pages (i.e. pages where a normal user visiting the page cannot tell who authored the page). And anonymous content creation is not something that should be entered into lightly.

There's actually never a case where the profile link does nothing. If the visitor is logged-in, a private profile shows information about the profile owner, i.e. "send a message", "request friend", etc. If the visitor is logged-out, clicking on a private profile link redirects them to the transient login page, the same as any other attempt to view a page that is inaccessible to a logged-out user.

What's the use-case for hiding the author line? If there's a compelling use-case for it, then I'd say we can keep this but we should add a config setting that makes it disabled by default. If there is not a compelling use-case, we should revert the patch.

Changed in mahara:
importance: Wishlist → Critical
status: Fix Committed → In Progress

I'd also like to see more info why it is important to not show the author. If you are in an institution, people should probably always have to show their name so that a tutor / teacher etc. knows who the page belongs to. Thus, if we keep an anonymous version, institutions should be able to have some config options.

When you blog on the internet, you also always have your name associated with what you write. So I'm not quite sure about the anonymous option. You can already choose whether to display your entire name, first name or display name so already have quite a bit of freedom.

Dirk Meyer (dirkca68) wrote :

I could see how this might be useful when young kids are wanting (or their teachers are asking) to write some public blogs or pages to be shared with let's say some audience in a partner class in some school overseas, and they do not want their name to be displayed at all. Changing their display name or only showing their first name, as it is right now, affects their entire portfolio. They may only want to do a few public pages now , but in their overall, long term portfolio they may want to keep showing their full name.

Aaron Wells (u-aaronw) wrote :

Thanks for the feedback, Dirk!

It sounds like the scenario you're describing is, basically, where students want to share pages with people outside their school, but still not make the student's identity visible to the general Internet public.

I think we normally tell people to do this through secret URLs. The page author is still visible to whoever views the secret URL, but you have to know the secret URL for that. And pages viewed through a secret URL have a "no crawl" meta tag on top of them that prevents them from being indexed by search engines, so the secret URL itself remains the only way to gain access to it as an outsider (unless the student makes the page public).

Hm, I could see a scenario though like, you want to have students enter webpages into a public web authoring competition, while still keeping their names secret out of privacy concerns. You could workaround that by using group pages for a group with hidden membership, but that could get unwieldy and it wouldn't allow certain types of page content that can't be used in group pages, like blog entries (although actually blog entries always print your full name anyway... ). But in that case, I think, in order to reduce the possibility of fraudulently creating pages that look official, it would still make sense for it to say something like "by a site user" or "by site staff", and the page author should be visible to staff & admin users.

Aaron Wells (u-aaronw) wrote :

Actually, on further thought, in the scenario where you want students to create web content to interact with the public, but still keep their real names secret, the proper thing to do would be set the "Users can hide real names" setting, and have each student tick the option to hide their real name, and give themselves a display name unrelated to their real name. Or assign them one.

(You have to rely on active student cooperation anyway, if you want them to author content and retain their anonymity, because they could for instance create a text block that says, "Hi, my name is Aaron Wells!")

So I'm still not seeing a strong need for pages with no author line.

Another reason for having the author line: Mahara pretty much only has user-generated content. If we don't have an author for a page, people think the page is created by the site itself and don't realize it that it's the fault of a specific user when there is bad content.

It would be like not having an uploaders name on a YouTube channel, on SlideShare etc.

Already for that reason alone I think we need to keep the author line. the user can decide what part of their name to display. That is already quite a bit of freedom.

Dirk Meyer (dirkca68) wrote :

I could see more use cases such as in the prevention of bullying, allowing participation from institutionalized young offenders with regular school students, enabling participation when court ordered restraining orders are in place for example.

However, it sounds like the suggested methods are preferred over the potential risks and headaches that come with allowing anonymous pages. I am not the original poster or the user group so I don't know what their rational is. Hope my comments are useful in some way. Cheers

Hi All,
I encountered a use case the other week from an academic who wanted his students to blind mark other students ePortfolios.

So Student X creates a portfolio, Student Y is tasked with assessing it according to various criteria and giving feedback - without even knowing who created the portfolio.

Peer assessment as we know is a powerful assessment for learning tool, is there a way we can do this?

Aaron Wells (u-aaronw) wrote :

Hi Dirk,

Thanks, your comments are useful! For the cases you describe, where we want to hide the user's real-life identity, I think the "hide real names" option is the way to go. I've also talked to a teacher here in NZ who assigned arbitrary firstnames and lastnames to her students (i.e. "student one", "student two", etc) to make sure their names stayed hidden.

I do indeed favor this approach of giving the user an "anonymous identity". It maintains community-accountability in the site, while keeping the user's real name hidden.

Cheers,
Aaron

Aaron Wells (u-aaronw) wrote :

Hi Shane,

Ah, I think you've hit the nail on the head! Blind evaluation is indeed quite a compelling reason to allow pages without an author line.

Now we could work this in as a setting into the Mahara assessment system and extend it to be supported by the Moodle plugin as well. But there would still be value in just making it a setting on arbitrary pages, for if you were doing ad-hoc page evaluation outside of these systems. Like, having the students print out their pages and shuffling them up and handing them back out to each other.

Hm, okay, I think the blind evaluation use-case indeed justifies having this functionality. So we should keep it, but make the following changes:

1. Add a config option to disable anonymous pages, and have the feature turned off by default.

2. When the author line is hidden, put a notice in its place that says "(Author's name hidden)" with another copy of the "Flag objectionable content" button next to it. This would prevent the phishing problem by making it obvious it's not just a system page.

3. And admins & staff should be able to see the page author's name. I think for an admin/staff, it should show "(Author's name hidden)", and have a button next to it that says "Show", which then displays the author's name. That way if a teacher wants to do blind evaluations themselves, they'd be able to. (And perhaps an option to send a notification to the user if a staff/admin clicks that button, like we do for when a staff/admin masquerades as a user.)

Nigel Cunningham (nigelc-g) wrote :

Does this still need work? I see there was a patch committed earlier, but the discussion seems to have progressed since then. I'm willing to start working on a patch to implement Aaron's ideas in comment 16 if that's desired.

Aaron Wells (u-aaronw) wrote :

Hi Nigel,

Yes, it still needs work. I marked it "critical" in order to note that we need to implement the things I recommended in comment #16, before the 1.10.0 release.

Cheers,
Aaron

Changed in mahara:
assignee: nobody → Nigel Cunningham (nigelc-g)
Nigel Cunningham (nigelc-g) wrote :

Hi Aaron.

Are you imagining that if the system wide option is enabled, each page will then have an option to anonymise the author of that page? From my point of view, I'm thinking this sounds like something you'd want to set on a per-page basis, but perhaps that's not what you're thinking of.

Nigel

Nigel Cunningham (nigelc-g) wrote :

Hi again.

The meta field should also be scrubbed, shouldn't it?

<meta name="author" content="My Display Name (Nigel Cunningham - nigelc)">

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/3486

Nigel Cunningham (nigelc-g) wrote :

Hi again.

I've just submitted for review an early version of the patch that just adds a system-wide config setting and simple anonymisation of the page. I want to get feedback as to whether I'm headed in the direction you're thinking of.

Nigel Cunningham (nigelc-g) wrote :

(Should hasten to add I'm part way through more work, so don't expect the version I posted to work yet - the smarty variable hasn't yet been modified in the version posted to Gerrit!).

Nigel Cunningham (nigelc-g) wrote :

Another question: I'm starting on adding the per-page settings. Should this be made part of the accessdata? (Would it be useful to be able to say anonymise in some circumstances and not others? ... Sounds like the answer is 'yes' to me).

Nigel Cunningham (nigelc-g) wrote :

A patch implementing just about everything in comment 16 is now available for review.

The only thing I haven't done is notifications if a person views the author of the anonymised page. I'd like to discuss more whether it's worth implementing that (I don't yet see the point).

Aaron Wells (u-aaronw) wrote :

Yep, the new patch addresses everything I wanted. :)

Hm, now that I see it, the "report objectional material" link on the top of the page is kind of large, though. Maybe we should make it just the icon, or get rid of it entirely.

Reviewed: https://reviews.mahara.org/3486
Committed: http://gitorious.org/mahara/mahara/commit/9624d430e9b825f09073fdd536ae6954ce4905f1
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 9624d430e9b825f09073fdd536ae6954ce4905f1
Author: Nigel Cunningham <email address hidden>
Date: Thu Jul 10 12:07:07 2014 +1000

(Bug548021) Add support for anonymising pages.

This patch adds support for anonymising pages.

It creates a site option in the General Settings section named 'Allow
anonymous pages' that must be checked for any page to be anonymised.

If the site option is enabled, a new 'Anonymise' setting in the
'Edit title and description' tab of pages is enabled, allowing the owner
to request that this page be anonymised.

When both settings are enabled and a user views a page, two things may
happen to the author's information.

First, if the user is not logged in or does not have admin, staff or
owner privileges for the page, the author's name is replaced by the
anonymous text (defaulting to "(Author's name hidden)") in both the
body of the page and the metadata author field.

If the user does have admin, staff or owner privileges for the page,
the author's name is anonymised as above except that the text displayed
is made into a link. When this link is clicked, the anonymous author
text is replaced by the normal author information for the page.

Anonymous pages displayed in the 'Latest pages' block and shared with
a group are also anonymised by this patch.

Change-Id: I2e2c92f641329a1a305cf58a5c5d47bf95436a8b
Signed-off-by: Nigel Cunningham <email address hidden>

Aaron Wells (u-aaronw) on 2014-09-16
Changed in mahara:
status: In Progress → Fix Committed
importance: Critical → Wishlist

Reviewed: https://reviews.mahara.org/3700
Committed: http://gitorious.org/mahara/mahara/commit/ffd8eb94be31036c460e368c1e2a478804cb0d03
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit ffd8eb94be31036c460e368c1e2a478804cb0d03
Author: Robert Lyon <email address hidden>
Date: Tue Sep 16 17:15:45 2014 +1200

Fixing merge problem with upgrade script (Bug 548021)

missing a closing } on an if statement.

Change-Id: Icc0194e6c5753e006551afe50334a89937572f0a
Signed-off-by: Robert Lyon <email address hidden>

Aaron Wells (u-aaronw) on 2014-10-21
tags: added: nominatedfeature
Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers