WYSIWYG Editor for Editing View Text Boxes is not available in Full Screen Mode

Reported by Alex on 2010-03-02
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Mahara
Low
François Marier

Bug Description

Feature Request:

In Mahara 1.3 the wysisyg editor is no longer available in Full Screen Mode.
Therfore it is difficult to enter and format longer texts.

Furthermore you can't alter the wysiwyg size and look in the templates css file.
This limits theming options!

For more informartion check out this forum discussion:
http://mahara.org/interaction/forum/topic.php?id=1574#post7435

Evan Goldenberg (naveg) on 2010-03-04
Changed in mahara:
assignee: nobody → Evan Goldenberg (naveg)
milestone: none → 1.3.0
Evan Goldenberg (naveg) wrote :

This feature was removed as the solution to #2996 on the old tracker.

http://eduforge.org/tracker/?func=detail&group_id=176&aid=2996&atid=739

I re-enabled it, and did have some problems with the content not getting put back in the small text box when I was done. I think we might have to leave this one as is for the time being.

Evan Goldenberg (naveg) on 2010-03-16
Changed in mahara:
status: New → Confirmed
Changed in mahara:
assignee: Evan Goldenberg (naveg) → nobody
Changed in mahara:
importance: Undecided → Medium
milestone: 1.3.0 → none
Andrew Nicols (dobedobedoh) wrote :

For reference, the bug in eduforge is now bug #547424

Andrew Nicols (dobedobedoh) wrote :

We could use the alternative full screen option rather than opening tinymce in a new window. It's actually the default option for tinymce. It is (however) a little less intuitive - particularly with regards to getting out of fullscreen mode!

Andrew Nicols (dobedobedoh) wrote :

An alternative which would probably suit a majority of people is to use the autoresize plugin to make the box larger as content is added.
Another alternative would be to write a new fullscreen plugin to open the editor in a semi-fullscreen mode (I'm thinking the gallery-like popups you see all over the shop for viewing larger images etc).

Craig Eves (craig-flexible) wrote :

Hi Andrew

We have just had feedback from an mahara admin who sees this as a major problem - users are now copying and pasting from word or using google docs instead of the builtin editor.

Increasing the size of the editor window is required to make the editor usable.

The autoresize plugin sounds good as it will keep the simpler interface as default rather than the more complex interface of the full screen mode. I assume that the full screen mode will still be accessible using this option.

Eugene (eugenev) wrote :

Just to confirm, can we now go ahead and enable to autoresize plugin?

Eugene, sure give it a go. I've actually just implemented a bit of a workaround for the lack of the fullscreen option inside the block editor, see http://mahara.org/interaction/forum/topic.php?id=1574

It basically just lets you make the block configuration form open up really big even when there's no content in it yet.

But if autoresize works well then I don't see why we shouldn't have that too - it'd be helpful for all the editors that aren't inside block config forms.

Eugene (eugenev) on 2010-10-04
Changed in mahara:
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed
Eugene (eugenev) wrote :

Hi Richard,

I enabled the 'autoresize' plugin for tinyMCE and had a bit of a play. I think a combination between your current workaround/patch and this plugin would work. This plugin seems to resize the editor vertically (as you add more content), while your workaround (if enabled) provides the optimum width.
I have tested the plugin on the browsers I have to my disposal (Firefox, IE6 and Chromium) and it seems to work fine.

I have attached a patch that enables the plugin.

I've committed the autoresize patch now. I guess I can't mark this as fixed yet, but I'll lower the priority (on the fullscreen button).

Changed in mahara:
importance: Medium → Low
Ruslan Kabalin (rkabalin) wrote :

The patch has been reverted in https://reviews.mahara.org/#q,287,n,z due to the bug #791854

There's an older hack/workaround for the textbox block tinymce height in commit 55a8feadbe, commissioned by Dirk Meyer. Autoresize was a better solution, so I removed the textbox workaround, but maybe we should consider putting it back if we no longer have autoresize.

Reviewed: https://reviews.mahara.org/287
Committed: http://gitorious.org/mahara/mahara/commit/651fcdba81e529ffa5506c7b68756338f4ff2b98
Submitter: Francois Marier (<email address hidden>)
Branch: master

commit 651fcdba81e529ffa5506c7b68756338f4ff2b98
Author: Francois Marier <email address hidden>
Date: Sat Jun 4 16:57:15 2011 +1200

    tinymce: disable autoresize plugin (bug #791854)

    The auto-resize plugin is currently broken in Chrome:

      http://tinymce.moxiecode.com/develop/bugtracker_view.php?id=4416

    This effectively reverts 5525cb60742b19a475cdbd824c5cd567639fabd8
    and reopens bug #530656.

    Change-Id: I2729dec02247ea1eb3d5d10f9a4f4a8bf93f1b52
    Signed-off-by: Francois Marier <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/291
Committed: http://gitorious.org/mahara/mahara/commit/1b231d7667b7dd4451c61c4d472922ad3fcd4419
Submitter: Francois Marier (<email address hidden>)
Branch: master

commit 1b231d7667b7dd4451c61c4d472922ad3fcd4419
Author: Francois Marier <email address hidden>
Date: Tue Jun 7 13:06:05 2011 +1200

    text block: add option for larger tinymce editor

    This is a cherry-pick of the following commits:

      688a506321262dffcbe8400ccf6dd46588afb657
      b4c77eb66b07c2928f5566b6df8857eda4f15c67
      0e7a938a8b5005efca86403e156c453f1af940ae
      ff8b17d30ff7edd62eed77e58fa8141543ce95ce
      b8ca346ac2b28f01d32ea3cf61bc6930939d8750

    The original one was done to fix bug #530656 but was then reverted
    in 55a8feadbecf31725b4b3808e9e26b783b9ed873 after the tinymce
    autoresize plugin was enabled.

    However, the autoresize plugin was removed after causing problems
    in bug #791854 (see 651fcdba81e529ffa5506c7b68756338f4ff2b98) so
    we'll restore this work-around for the time being.

    Change-Id: I74176a3a155a7d9442448d09f206250b55394611
    Signed-off-by: Francois Marier <email address hidden>

tags: added: tinymce
Melissa Newman (melissa-l) wrote :

Solution to this bug:

File: lib/web.php
Line: 110, add "fullscreen" to the end of the line.
Orig:
"bold,italic,underline,strikethrough,separator,forecolor,backcolor,separator,justifyleft,justifycenter,justifyright,justifyfull,separator,hr,emotions,image,spellchecker,cleanup,separator,link,unlink,separator,code",
New:
"bold,italic,underline,strikethrough,separator,forecolor,backcolor,separator,justifyleft,justifycenter,justifyright,justifyfull,separator,hr,emotions,image,spellchecker,cleanup,separator,link,unlink,separator,code,fullscreen",

Line: 123
Orig:
    plugins: "table,emotions,spellchecker,inlinepopups,paste",
New:
    plugins: "table,emotions,spellchecker,inlinepopups,paste,fullscreen",

Melissa Newman (melissa-l) wrote :

Did you try to embed large chunks of text into the fullscreen mode and then go out of it? That seemed to have been one of the problems earlier on (see above) with using the fullscreen button which had been in Mahara some time ago.

François Marier (fmarier) wrote :

It works for me as well. I have pushed a patch to be reviewed:

https://reviews.mahara.org/773

Thanks for that contribution Melissa!

Changed in mahara:
assignee: nobody → François Marier (fmarier)
status: Confirmed → In Progress
milestone: none → 1.5.0
Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/773
Committed: http://gitorious.org/mahara/mahara/commit/eb227153ab2f268a6da415106c83268d4b21c6c8
Submitter: Richard Mansfield (<email address hidden>)
Branch: master

commit eb227153ab2f268a6da415106c83268d4b21c6c8
Author: Francois Marier <email address hidden>
Date: Tue Oct 4 22:16:21 2011 +1300

    Enable fullscreen button in tinymce (bug #530656)

    Thanks to Melissa Newman for the solution!

    Change-Id: Icc8f03e7b5a69f653ed37cd00db148e092de8ed3
    Signed-off-by: Francois Marier <email address hidden>

Changed in mahara:
status: In Progress → Fix Committed
tags: removed: feature request wysiwyg
tags: added: newfeature
Melissa Draper (melissa) on 2012-04-18
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.