Comment 2 for bug 1440617

Steven (stevens-q) wrote :

Environment tested: Master
Browser tested: Chrome

PRECONDITIONS:
------------------------
1) "Institution One" exists
--- a) Registration has been allowed for this institution
--- b) Confirm registration has been set to yes
2) New users have requested registration for Institution One
--- a) all new registers have an email as follows steven+<number>@catalyst.net.nz
3) Notification settings for the site have been all set to inbox

TEST STEPS:
------------------------
1) Log in as Institution admin
2) Confirm that admin user / Inst admin have a notification in their inbox - indicating a new registration ✘
3) Browse to Admin menu > Institutions > Pending registrations
4) Confirm a list of new registrations are listed in a table ✔
5) Confirm each new register has an option of either "Approve" or "Deny" ✔
6) Click the "Deny" button
7) Confirm a modal window is displayed with
--- a) a "Denial reason" field ✔
--- b) a "Deny" submit button ✔
--- c) a "Cancel" link to go back to previous step ✔
8) Fill in the required field and click the "Deny" button
9) Confirm the following
--- a) the modal window closes and user is on the Pending registrations page ✔
---b) the user has been removed from the list of pending registers ✔
---c) the pending register receives an email with the reason for denial ✘
10) Select another user from the pending users list and click the "Approve" button
11) Confirm a modal window is displayed with
--- a) a "Denial reason" field ✔
--- b) a "Deny" submit button ✔
--- c) a "Cancel" link to go back to previous step
12) Fill in the required field and click the "Approve" button
13) Confirm the following
--- a) the modal window closes and user is on the Pending registrations page ✔
--- b) the Approve and Deny buttons are not displayed ✔
--- c) a message of "Approval sent, waiting on user completion" is displayed where the buttons used to be ✔
--- d) the pending register receives an email with the reason for approval ✘

Catalyst QA Failed Testing ✘

NOTE: I am not receiving emails for pending users or notifications in inbox of admin users about users who wish to register. I do get notifications in my in box for friend requests and group invitations.