Upload site logo through front end

Bug #1408473 reported by Kristina Hoeppner on 2015-01-07
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Unassigned

Bug Description

Currently, institutions can upload a logo to include that when users of that institution log in.

It would be good to also have that feature available on the entire site, i.e. for "No institution".

Note: This refers only to the theme when viewed with the normal header.

I am going to file a separate bug for when a site uses small headers. Currently, the logo that is uploaded through the interface is not used there.

summary: - Upload logo
+ Upload site logo through front end
Changed in mahara:
assignee: nobody → Sylvi Low (sylvilow-student)
Changed in mahara:
assignee: Sylvi Low (sylvilow-student) → nobody
Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4192

Changed in mahara:
assignee: nobody → Sylvi Low (sylvilow-student)
status: Confirmed → In Progress
Changed in mahara:
status: In Progress → Incomplete
Changed in mahara:
assignee: Sylvi Low (sylvilow-student) → nobody
status: Incomplete → In Progress
milestone: none → 15.04.0

Reviewed: https://reviews.mahara.org/4192
Committed: http://gitorious.org/mahara/mahara/commit/90a1c4294cc29181d474093420a172ab01bd1d1a
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 90a1c4294cc29181d474093420a172ab01bd1d1a
Author: Sylvi Low <email address hidden>
Date: Thu Jan 15 16:41:38 2015 +1300

Upload no 'institution' site logo through admin -> institution

(Bug #1408473)

Change-Id: Ic290e4b9a17ff192334cbd6bef3b9f3b433ec702

Aaron Wells (u-aaronw) on 2015-02-16
Changed in mahara:
status: In Progress → Fix Committed
tags: added: nominatedfeature

Limitation: the logo does not show up when small headers are used. That is the same limitation as for institutions right now. Since we are thinking of removing small headers altogether and provide a better navigation, we'll not fix this.

Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers