Group forums posts email don't show user name of who posted

Bug #1405427 reported by Simha Bode on 2014-12-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Critical
Son Nguyen
1.10
Critical
Son Nguyen
15.04
Critical
Son Nguyen

Bug Description

I facilitate a group for Gaia University. It used to be that when someone posted in a forum it would send it out as an email to all the members and it would include the user name of the one who posted. Now the user name of the one posting is not displayed in the email. This is a bit annoying to not know who is posting when you get an email.

Hello Simha,

Which version of Mahara are you using? For Mahara.org (1.9), I do get the usernames and realnames displayed. I think that is only though because I am a site administrator.

Could you please provide a screenshot of what it looks like for you? Do you still see the name of the people in the "From" field?

Thanks
Kristina

I can confirm that the name of the person posting a forum post is not displayed anymore. Instead it seems to be the site name for Mahara 1.10. I suspect the behavior is also for 15.04, but there is bug #1406372 which prevents me from testing it.

I attach a screenshot of what it looks like.

Changed in mahara:
importance: Undecided → Critical
tags: added: regression
Son Nguyen (ngson2000) wrote :

The patch for fixing https://bugs.launchpad.net/mahara/+bug/738263 has changed the From field to no-reply address

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4119

Reviewed: https://reviews.mahara.org/4118
Committed: http://gitorious.org/mahara/mahara/commit/391033fe469a4ec5818eb51feaf87ec6f2a82e69
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.10_STABLE

commit 391033fe469a4ec5818eb51feaf87ec6f2a82e69
Author: Son Nguyen <email address hidden>
Date: Wed Dec 31 12:51:46 2014 +1300

Make sure the forum post emails show the poster's name (Bug 1405427)

Change-Id: Ibe0495f8959e55106ad5e582fe6050a65dc40662
Signed-off-by: Son Nguyen <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4119
Committed: http://gitorious.org/mahara/mahara/commit/e9c7bebdae89d8c6afe11e4e40eebdb8ec0c0641
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit e9c7bebdae89d8c6afe11e4e40eebdb8ec0c0641
Author: Son Nguyen <email address hidden>
Date: Wed Dec 31 12:51:46 2014 +1300

Make sure the forum post emails show the poster's name (Bug 1405427)

Change-Id: Ibe0495f8959e55106ad5e582fe6050a65dc40662
Signed-off-by: Son Nguyen <email address hidden>

Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments