Help icon hard to find

Bug #1381719 reported by Dirk Meyer on 2014-10-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon
1.10
High
Robert Lyon
15.04
High
Unassigned

Bug Description

I was unable to spot the help icon easily. Could we alter the text or change help icon and make more visible?

Dirk Meyer (dirkca68) wrote :
Aaron Wells (u-aaronw) wrote :

Hi Dirk,

Good point. The help icon we're referring to is way up next to the "Edit access" page title, nowhere near where we tell the user "Click the help icon". It also has a lowercase "i" on it instead of the word "help" or a question mark. If I were to look at it, I would assume the "i" is for "information" and call it an "information icon" rather than a "help icon".

So our options are:

1. BEST: Put a link there that will expand the help text as if you'd clicked on the help icon. I'm not sure at first glance whether our help icon code really robustly supports that, though.

2. GOOD: Change the text to give the user a better clue what they're looking for. BUT with some caveats! For accessibility, the text has to make sense to screen-reader users (the current text more or less does, because the icon has the title attribute "Help"). And we can't say "the button with the i on it" because the button's appearance may change depending on the theme. Perhaps something like "the help icon next to the 'Edit access' page title".

3. NOT AS GOOD: Just delete the line about clicking the help icon entirely. It's a common thing throughout Mahara that clicking one of those things provides information.

Those are things to fix this message for Mahara 1.10.0.

In the longer run... I'd say that for this page, we should get rid of the help paragraph entirely. Probably no one is reading it. Replace it with a more prominent "Help!" link. And maybe, if a page is not yet shared with anyone, a notice that says "This page is not yet visible to anybody".

Also, we should get rid of that "shall" in the sentence, "On this page you decide who shall have access to them besides you." It doesn't read well to my American-English eyes, so it'd be an easy win to replace it with something more internationally acceptable.

Aaron Wells (u-aaronw) on 2014-10-16
Changed in mahara:
milestone: none → 1.10.0
importance: Undecided → High
status: New → Confirmed
Robert Lyon (robertl-9) on 2014-10-16
Changed in mahara:
status: Confirmed → In Progress
assignee: nobody → Robert Lyon (robertl-9)

Reviewed: https://reviews.mahara.org/3827
Committed: http://gitorious.org/mahara/mahara/commit/91c9e3c3738ec3af9c502d00d649b8ee67a00581
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 91c9e3c3738ec3af9c502d00d649b8ee67a00581
Author: Robert Lyon <email address hidden>
Date: Fri Oct 17 11:09:08 2014 +1300

Changed text to be a link that referes to the help icon (Bug #1381719)

This way the user can toggle the same help info by either clicking on the
help icon or by clicking the help text.

Also changed 'shall have access' to 'can access'.

Change-Id: Ia86c713a7a74ab3dce11bb9ed6552eb49c90776d
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments