Change the "Access permissions have changed" notification from a JS popup to an inline CSS thing

Bug #1379086 reported by Aaron Wells on 2014-10-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon

Bug Description

One of the neat features we added in Mahara 1.10, was the ability to drag & drop pages into a collection.

However, we also added a Javascript popup that comes up with each dragged page, if the permissions for the page will change now that it's in the collection.

Example:

1. Create Page 1 & Page 2
2. Put Page 1 into Collection A
3. Set Collection A to be visible to the public
4. Drag Page 2 into Collection A

With all due respect, this notification is pretty annoying, and it kinda cancels out all the added utility that we got from implementing drag-and-drop, because often you have to click it after every single added page. (It also hurts our "number of clicks to get things done" metric.) And in Firefox if a page gives you JS pop-ups more than a few times, Firefox itself adds a tickbox to let you ignore further pop-ups, which I'm betting will confuse users and make them think their site is broken somehow.

If we must have a message telling users that the pages' permissions have changed, let's do it as an inline notice like the one you see on the Content -> Files page after you upload a file and it says "Upload of ___ complete". It shouldn't be green like that one, or red like an error notice. Perhaps the yellow "warning" styling that we use on the Admin Home page for site config warnings would be appropriate.

Aaron Wells (u-aaronw) wrote :

If possible, it would be good to consolidate the "permissions have changed" notices. Otherwise, as happens when you upload a lot of files to the file access page, it'll tend to scroll everything on the page down down down as they stack up.

Robert Lyon (robertl-9) on 2014-10-09
Changed in mahara:
assignee: nobody → Robert Lyon (robertl-9)
Robert Lyon (robertl-9) on 2014-10-12
Changed in mahara:
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/3780
Committed: http://gitorious.org/mahara/mahara/commit/a7ef581d674725abeda6606e707412885d9cff25
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit a7ef581d674725abeda6606e707412885d9cff25
Author: Robert Lyon <email address hidden>
Date: Fri Oct 10 09:29:17 2014 +1300

Changed alert popup to warn message (Bug #1379086)

If you add a page by drag/drop it adds a warn for each time due to it
being a one item only transaction

If you add one or more pages by checkbox/submit it gives a digest of
the pages changed in the warn message

Change-Id: Ifccccca2c8de9fe4b1a4c2919a290c68f594dff4
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2014-10-13
Changed in mahara:
status: In Progress → Fix Committed

Reviewed: https://reviews.mahara.org/3794
Committed: http://gitorious.org/mahara/mahara/commit/1a122c09c1742751d00bd39832f2f1322debf788
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.10_STABLE

commit 1a122c09c1742751d00bd39832f2f1322debf788
Author: Robert Lyon <email address hidden>
Date: Fri Oct 10 09:29:17 2014 +1300

Changed alert popup to warn message (Bug #1379086)

If you add a page by drag/drop it adds a warn for each time due to it
being a one item only transaction

If you add one or more pages by checkbox/submit it gives a digest of
the pages changed in the warn message

Change-Id: Ifccccca2c8de9fe4b1a4c2919a290c68f594dff4
Signed-off-by: Robert Lyon <email address hidden>

tags: added: nominatedfeature
Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers