Remove pre-1.1.0 sections of the core plugins' update scripts.

Bug #1301109 reported by Aaron Wells on 2014-04-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Nigel Cunningham

Bug Description

In Mahara 1.8, we dropped support for upgrading from Mahara versions prior to 1.1.0, and we removed a big chunk of htdocs/lib/db/upgrade.php that covered all the pre-1.1.0 upgrade stuff.

BUT, all the core plugins also have their own db/upgrade.php files, and many of these still have big sections of pre-1.1.0 upgrade stuff as well!

We should:

1. Find out what version each core plugin was it in the 1.1.0_RELEASE tag

2. Strip out all the upgrade.php sections where the version number is less than or equal to the 1.1.0 version number.

Aaron Wells (u-aaronw) on 2014-04-02
Changed in mahara:
milestone: none → 1.9.0
importance: Undecided → Low
status: New → Confirmed
description: updated
Aaron Wells (u-aaronw) on 2014-04-15
Changed in mahara:
milestone: 1.9.0 → 1.9.1
Aaron Wells (u-aaronw) on 2014-06-12
no longer affects: mahara/1.9

Reviewed: https://reviews.mahara.org/3480
Committed: http://gitorious.org/mahara/mahara/commit/01d92107fffd2b761c09bb32ea3f83241c091f6b
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 01d92107fffd2b761c09bb32ea3f83241c091f6b
Author: Nigel Cunningham <email address hidden>
Date: Tue Jul 8 14:20:32 2014 +1000

Remove pre-1.1.0 sections of core plugin update scripts (Bug 1301109)

Remove support for upgrading from pre-1.1.0, from core plugins.

Change-Id: I7dce8210152b75cc0931894bb21450805294c5b3
Signed-off-by: Nigel Cunningham <email address hidden>

Aaron Wells (u-aaronw) on 2014-10-20
no longer affects: mahara/1.10
Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers