When you delete a blog entry, count of blog entries doesn't update

Bug #1297079 reported by Aaron Wells on 2014-03-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Unassigned
1.10
Medium
Unassigned
1.9
Medium
Unassigned

Bug Description

To replicate:

1. Install Mahara
2. Navigate to Content -> Journal
3. Create 2 blog entries in your default journal.
4. On artefact/blog/view/index.php, when displaying the list of journal entries, notice that at the bottom there is small grey text that says "2 entries"
5. Delete 1 entry by clicking its delete button (the garbage can icon)

Expected result:
The grey text at the bottom should change to say "1 entry"

Actual result:
The grey text at the bottom still says "2 entries".

This is most noticeable when you delete all the entries in a journal. Then all that's left on the page is the grey text saying "2 entries", which makes you wonder whether they actually got deleted or not.

Son Nguyen (ngson2000) wrote :

Hi Aaron;

I can not replicate the issue using Mahara master, Chrome

Aaron Wells (u-aaronw) on 2014-04-30
Changed in mahara:
status: Confirmed → Incomplete
Aaron Wells (u-aaronw) wrote :

This problem was fixed by one of the patches for https://bugs.launchpad.net/mahara/+bug/1287922

Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
milestone: 1.10.0 → none
Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers