Allow a VERP "bounces_ratio" of 0

Bug #1261233 reported by Aaron Wells on 2013-12-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Aaron Wells

Bug Description

Our VERP bounce system has two parameters to determine when to disable someone's email. The absolute number of bounces must be greater than "bounces_min", and the ratio of bounces received versus emails sent, must be greater than "bounces_ratio".

The problem is, on mahara.org we have some email addresses that have received thousands of emails, and others that have received less than a dozen. This makes the bounces_ratio feature not that useful; if we set it something like the default 0.2, then an email address that has been registered for years but has recently become invalid, will have to send us hundreds of bounce messages before we disable it.

So, I want to disable the bouncesratio feature, by setting it to 0 (so that no matter what the ratio of sent to bounced is, it'll be higher than 0). However, check_overcount() short-circuits if *either* bounces_min or bounces_ratio is false, so I can't use 0 because it evaluates to false.

Reviewed: https://reviews.mahara.org/2803
Committed: http://gitorious.org/mahara/mahara/commit/044a5f39d96efbe44218f4f12360b1f46207aac3
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 044a5f39d96efbe44218f4f12360b1f46207aac3
Author: Aaron Wells <email address hidden>
Date: Mon Dec 16 11:19:07 2013 +1300

Allow a $cfg->bounces_ratio of 0

Bug 1261233: If you set the ratio to 0, you'll bounce someone
as soon as they hit bounces_min, regardless of what the sent/bounced
ratio is

Change-Id: Ibe8223054fa70ea27748d78b099afa079be7f900

Aaron Wells (u-aaronw) on 2014-02-25
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers