[UI 2.0 beta1] Subnet page doesn't show which machine or device owns an IP address

Bug #1567150 reported by Andres Rodriguez on 2016-04-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Mike Pontillo

Bug Description

The subnet page lists:

IP Address Owner Usage Type Last seen
192.168.10.2 admin Machine Automatic

but It doesn't show which machine specifically owns the IP.

Tags: ui Edit Tag help

Related branches

Changed in maas:
milestone: none → 2.0.0
importance: Undecided → High
status: New → Confirmed
tags: added: ui
Changed in maas:
status: Confirmed → Triaged
summary: - [2.0 beta1] Subnet page doesn't show which machine or device owns an IP
- address
+ [UI 2.0 beta1] Subnet page doesn't show which machine or device owns an
+ IP address
Changed in maas:
assignee: nobody → Mike Pontillo (mpontillo)
Carla Berkers (carlaberkers) wrote :

Originally IP was supposed to link to node details but agreed with Andres we could have the FQDN. Both info is important for identifying the machine so would leave them as separate columns for now.

Think the challenge here is grouping content in a logical way. "Usage" is the type of node, so related to FQDN. "Type" seems to be type of IP address.
So with the current content, IP adress - type - interface - FQDN - usage - owner - last seen would be the most logical order. This way related columns are next to each other.

So far, the user texting participants find the content/labels on this table a bit confusing, so might need more work later. But hopefully this is a solid fix for now.

Changed in maas:
status: Triaged → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers