maas-cluster-controller does not update pserv.yaml when dpkg-reconfigure is run

Bug #1273197 reported by Ronald McCollam on 2014-01-27
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
High
Andres Rodriguez
maas (Ubuntu)
Critical
Andres Rodriguez

Bug Description

When dpkg-reconfigure is run on maas-cluster-controller, /etc/maas/pserv.yaml is not updated with the new address.

(This was previously reported as bug #1081212 and fixed, but appears to have regressed in Trusty.)

Related branches

Changed in maas:
status: New → Invalid
tags: added: regression
Changed in maas (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
Andres Rodriguez (andreserl) wrote :

I have just tested this and I can't seem to be able to reproduce:

ubuntu@ubuntu:/etc/maas$ sudo cat pserv.yaml | grep generator
  generator: http://192.168.122.58/MAAS/api/1.0/pxeconfig/
ubuntu@ubuntu:/etc/maas$ sudo dpkg-reconfigure maas-cluster-controller
maas-cluster-celery stop/waiting
maas-pserv stop/waiting
 * Restarting web server apache2 AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
                                                                         [ OK ]
maas-pserv start/running, process 11994
maas-cluster-celery start/running, process 12028
ubuntu@ubuntu:/etc/maas$ sudo cat pserv.yaml | grep generator
  generator: http://192.168.122.57/MAAS/api/1.0/pxeconfig/

Changed in maas (Ubuntu):
assignee: nobody → Andres Rodriguez (andreserl)
Andres Rodriguez (andreserl) wrote :

@Dustin,

could you please confirm this is still an issue for you? Because I can't really seem to be able to reproduce it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.5+bzr1948-0ubuntu2

---------------
maas (1.5+bzr1948-0ubuntu2) trusty; urgency=low

  * debian/maas-cluster-controller.postinst: Make sure generator on
    pserv.yaml is updated on upgrade or reconfigure. (LP: #1273197)
  * debian/maas-cluster-controller.maas-pserv.upstart: Make sure maas-pserv
    is started with authbind.
 -- Andres Rodriguez <email address hidden> Sat, 15 Feb 2014 13:55:20 -0500

Changed in maas (Ubuntu):
status: Confirmed → Fix Released
Christian Reis (kiko) wrote :

See also bug 1068383.

sba (stephane-baziak) wrote :

This bug also affects me. In the hope of making standalone cluster controller work http://askubuntu.com/questions/601092/issue-with-maas-cluster-controller-no-enlistment) I have just updated to 1.7.2+bzr3355-0ubuntu1~trusty1 and still need to update generator manually in pserv.yaml.

Changed in maas:
status: Invalid → New
importance: Undecided → High
status: New → Confirmed
milestone: none → 1.8.0
assignee: nobody → Andres Rodriguez (andreserl)
Changed in maas:
status: Confirmed → Fix Committed

Hello Ronald, or anyone else affected,

Accepted maas into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/1.7.5+bzr3369-0ubuntu1~14.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Changed in maas:
status: Fix Committed → Fix Released
tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers