Lyricue - Lyric Display System

Letters missing in preview and miniview

Reported by Eduardo Rivas on 2010-05-23
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
lyricue
Medium
ChrisDebenham

Bug Description

The preview pane is not working at all.
The miniview pane shows the lyrics with "holes"
You can see the screenshot for this issue, the text is:

This is a test song
Some of the letters
are missing, it only happens
in the miniview pane.

Started when I upgraded to Ubuntu Lucid.

Eduardo Rivas (jerivasmelgar) wrote :
Changed in lyricue:
assignee: nobody → ChrisDebenham (chris-debenham)
importance: Undecided → Medium
status: New → Confirmed
ChrisDebenham (chris-debenham) wrote :

I saw this on the weekend as well for the first time.
I found that if I resize the miniview area eventually you can see those missing letters - it is just that they are partially transparent (the amount of transparency reduces as the size increases which is why they start to show up as the size grows)
This is not something lyricue is doing - rather it is a problem in Clutter itself.
Perhaps the recent update of libclutter is causing this?

Eduardo Rivas (jerivasmelgar) wrote :

Yesterday this happened in the server itself. As you describe above, some letters were transparent, and you could see a hint of them. Interestingly, changing the font type fixed the issue, for a while.

Eduardo Rivas (jerivasmelgar) wrote :

Something weird happens after the last update. The server works fine, but the miniview and preview only show the backgrounds, no letters. The only letter shown is capital P.

It sounds like a problem in the glyph (character) store used by clutter.
I'm not sure what/how I can work around this issue

On 25 May 2010 03:56, Eduardo Rivas <email address hidden> wrote:
> Something weird happens after the last update. The server works fine,
> but the miniview and preview only show the backgrounds, no letters. The
> only letter shown is capital P.
>
> --
> Letters missing in preview and miniview
> https://bugs.launchpad.net/bugs/584757
> You received this bug notification because you are a bug assignee.
>
> Status in Lyricue Lyric Display System: Confirmed
>
> Bug description:
> The preview pane is not working at all.
> The miniview pane shows the lyrics with "holes"
> You can see the screenshot for this issue, the text is:
>
> This is a test song
> Some of the letters
> are missing, it only happens
> in the miniview pane.
>
> Started when I upgraded to Ubuntu Lucid.
>
>
>

ChrisDebenham (chris-debenham) wrote :

This is a problem in libclutter.
The mipmap cache for the text is getting corrupted/lost.
It can be worked around by running "export CLUTTER_DISABLE_MIPMAPPED_TEXT=1" before lyricue/lyricue_display
This will disable the mipmap cache for the text and work around this issue until it is fixed upstream

Changed in lyricue:
status: Confirmed → Fix Committed
Eduardo Rivas (jerivasmelgar) wrote :

Well, I don't know if I'm not following the directions correctly, but I ran the command in terminal and rendered no output. Then run "lyricue" and the preview and miniview are black all the time.
Ubuntu Lucid with Gnome
Lyricue 3.0.12-1

arubislander (arubislander) wrote :

Did you run lyricue from the same terminal you ran the command in? I did and it works for me. What I did next was write a short bash script that issues the command and then runs lyricue. I created a desktop launcher for the script and use that instead of the regular menu item. See below for the script

[CODE]
#!/bin/bash
export CLUTTER_DISABLE_MIPMAPPED_TEXT=1
lyricue
[/CODE]

Don't forget to make the script executable.

Eduardo Rivas (jerivasmelgar) wrote :

Tried the script, no luck. This is the output when running it on terminal:

(lyricue_display:4738): ClutterGLX-CRITICAL **: Unable to make the stage window 0x5600027 the current GLX drawable
(lyricue_display:4739): ClutterGLX-CRITICAL **: Unable to make the stage window 0x5400027 the current GLX drawable

arubislander (arubislander) wrote :

The script solves the 'transparent letters due to bug in clutter' issue, not the non functional preview / miniview windows.

Changed in lyricue:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments