Crash on start ( core dumped )

Bug #212262 reported by Gueraph Mayax on 2008-04-05
8
Affects Status Importance Assigned to Milestone
LottaNZB
High
LottaNZB Development Team

Bug Description

When I launch lottanzb 0.2 on Feisty I get this:

"gueraph@ubuntu:~$ lottanzb
INFO Démarrage de LottaNZB 0.2 en utilisant Python 2.5.1.
INFO Le fichier de configuration de LottaNZB n'a pu être chargé. Démarrage de l'assistant de configuration.
INFO Création du répértoire HellaNZB /home/gueraph/.lottanzb/.
Erreur de segmentation (core dumped)"

Gueraph Mayax (yoann-weber) wrote :

EDIT: I used the package version for Ubuntu, I didn't compile it.

Sander Tuit (avirulence) wrote :

Can you try the source archive? The instructions are on the website. It might be due to the fact that the package wasn't build for Feisty.

Changed in lottanzb:
importance: Undecided → High
Severin Heiniger (severinh) wrote :

I'm not sure if this will solve the problem because the deb package isn't much different from the plain source package (the python files aren't "compiled" in any way"): The fact that is was created on Hardy basically shouldn't be a problem for any other version. It's just a question of dependencies. You were able to install it, so the necessary software seems to be installed.

I guess this problem is related to the following question on Launchpad: https://answers.edge.launchpad.net/lottanzb/+question/28311

I added a guide which explains how to make a backtrace. Using this backtrace me might be able to figure out why the application crashed with a segmentation fault.

Gueraph Mayax (yoann-weber) wrote :

Well, I solved the problem by installing Hardy yesterday night. It's working perfectly now.
I tried the method from Severin but it didn't work ( I don't remember the bdg output problem ). It doesn't have any matter 'cause Lottanzb work on Ubuntu 8.04 :D.
Thx a lot aVirulence and Severin ;-)

Severin Heiniger (severinh) wrote :

We're glad to hear that it's working perfectly for you now, but still, we would like make LottaNZB compatible with non-beta versions of Ubuntu as well. I downloaded a Gusty installation medium yesterday and I'm going to do some debugging asap.

Stéphane Maniaci (stephh) wrote :

I do have the same problem on my Hardy 8.04 Beta.

ERROR Impossible de connecter le daemon HellaNZB
INFO Sortie de HellaNZB: Unable to load specified config file: /home/steph/.lottanzb/hellanzb.conf

Seems latest revision doesn't create the config file in ~/.lottanzb

Stéphane Maniaci (stephh) wrote :

Launching a reconfiguration prints :

ERROR can't write hellanzb.conf file

Launching LottaNZB as superuser doesn't fix, this is not a permission problem.

Severin Heiniger (severinh) wrote :

Try to remove the try-except-else statements from "Prefs.hella.save(paths.clientDir("hellanzb.conf"))" on line 108 in firstrun.py. This will give us a more detailed error message. In the meantime, you might consider filing a new bug for your problem, because yours isn't connected to the segmentation fault bug imo.

This one proves it another time: We need a much better error handling system so that people don't need to make changes to the source code in order to track down problems.

Sander Tuit (avirulence) wrote :

It should be possible to print the error message when using try: except:, right? Or is this only possible when excepting a specific error?

Thomas Fritz (fritzthomas.com) wrote :

I have the same Problem on Ubuntu 8.04. When i start lottanzb the first time i get the error. I tried to install it first with the deb Package. THen i uninstalled the package and downloaded the source and installed it as it is described here: http://www.lottanzb.org/index.php?option=com_content&view=article&id=11&Itemid=11 but without any other results.

I removed the try-except-ese statments around the Prefs.hella.save call as you mentioned earlier in the discussion. Thats the output when i start lottanzb:

thomas@T61P:~$ lottanzb
INFO LottaNZB 0.2 wird mit Python 2.5.2 gestartet.
INFO Das Konfiguration von LottaNZB konnte nicht geladen werden. Der Konfigurationsassistent wird gestartet.
INFO Das LottaNZB-Verzeichnis /home/thomas/.lottanzb/ wurde angelegt.
Traceback (most recent call last):
  File "/usr/bin/lottanzb", line 8, in <module>
    load_entry_point('lottanzb==0.2', 'gui_scripts', 'lottanzb')()
  File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/lottanzb.py", line 63, in run
    Lotta()
  File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/lottanzb.py", line 48, in __init__
    self.assistant = firstrun.Assistant(True)
  File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/firstrun.py", line 46, in __init__
    self.showUsageHint()
  File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/firstrun.py", line 130, in showUsageHint
    if Backend.isRunning():
  File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/backend.py", line 384, in isRunning
    list = util.ProcessList()
  File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/util.py", line 315, in __init__
    process = Process(int(f))
  File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/util.py", line 283, in __init__
    self.parent_pid = int(parent_pid)
ValueError: invalid literal for int() with base 10: 'S'

Please tell me if you need more infos.

Thomas Fritz (fritzthomas.com) wrote :

Hi, again...

I read severins guide (https://answers.edge.launchpad.net/lottanzb/+question/28311) to make the backtrace with gdb, heres a coutout of the output:

Traceback (most recent call last):
  File "lottanzb.py", line 66, in <module>
    run()
  File "lottanzb.py", line 63, in run
    Lotta()
  File "lottanzb.py", line 48, in __init__
    self.assistant = firstrun.Assistant(True)
  File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/firstrun.py", line 46, in __init__
    self.showUsageHint()
  File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/firstrun.py", line 130, in showUsageHint
    if Backend.isRunning():
  File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/backend.py", line 384, in isRunning
    list = util.ProcessList()
  File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/util.py", line 315, in __init__
    process = Process(int(f))
  File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/util.py", line 283, in __init__
    self.parent_pid = int(parent_pid)
ValueError: invalid literal for int() with base 10: 'S'

Program exited with code 01.
(gdb) bt
No stack.
(gdb)

Hi Thomas,

Thank you very much for taking the time to fill out this bug report. I
think the command line output will be very helpful. The gdb backtrace
was unnecessary since it's probably an error in our program instead of
the python/pygtk code.

Thanks again, we'll try to solve this problem ASAP.

On Thu, Jun 12, 2008 at 12:36 PM, Thomas Fritz <email address hidden> wrote:
> Hi, again...
>
> I read severins guide
> (https://answers.edge.launchpad.net/lottanzb/+question/28311) to make
> the backtrace with gdb, heres a coutout of the output:
>
> Traceback (most recent call last):
> File "lottanzb.py", line 66, in <module>
> run()
> File "lottanzb.py", line 63, in run
> Lotta()
> File "lottanzb.py", line 48, in __init__
> self.assistant = firstrun.Assistant(True)
> File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/firstrun.py", line 46, in __init__
> self.showUsageHint()
> File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/firstrun.py", line 130, in showUsageHint
> if Backend.isRunning():
> File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/backend.py", line 384, in isRunning
> list = util.ProcessList()
> File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/util.py", line 315, in __init__
> process = Process(int(f))
> File "/usr/lib/python2.5/site-packages/lottanzb-0.2-py2.5.egg/lottanzb/util.py", line 283, in __init__
> self.parent_pid = int(parent_pid)
> ValueError: invalid literal for int() with base 10: 'S'
>
> Program exited with code 01.
> (gdb) bt
> No stack.
> (gdb)
>
> --
> Crash on start ( core dumped )
> https://bugs.launchpad.net/bugs/212262
> You received this bug notification because you are subscribed to
> LottaNZB.
>
> Status in LottaNZB • Automated Usenet Client: New
>
> Bug description:
> When I launch lottanzb 0.2 on Feisty I get this:
>
> "gueraph@ubuntu:~$ lottanzb
> INFO Démarrage de LottaNZB 0.2 en utilisant Python 2.5.1.
> INFO Le fichier de configuration de LottaNZB n'a pu être chargé. Démarrage de l'assistant de configuration.
> INFO Création du répértoire HellaNZB /home/gueraph/.lottanzb/.
> Erreur de segmentation (core dumped)"
>

Severin Heiniger (severinh) wrote :

The code responsible for this crash has already been removed from the LottaNZB codebase, so I guess the problem will be fixed in the upcoming 0.3 version.

The crash was caused by the mechanism that detects, whether a HellaNZB instance is already running or not. This code block was a copy&pasted snippet from somewhere on the internet and unfortunately, we hadn't done much testing. Our new approach shouldn't be as buggy as the old one and it isn't platform-dependent anymore.

Stay tuned!

Severin Heiniger (severinh) wrote :

Wonder if you still get these segmentation faults using the recently released LottaNZB version 0.3. LottaNZB has become much more stable and is likely to produce less problems such as this one.

Gueraph Mayax (yoann-weber) wrote :

Hy! Well, I moved to Fedora 9. I tried the lastest version ( 0.3 ) and another problem has come.
I've installed it with the package "lottanzb-0.3-1.fc9.noarch.rpm" found at http://www.lottanzb.org/downloads.
Now, when I start lottanzb, I get this:

Traceback (most recent call last):
  File "/usr/bin/lottanzb", line 8, in <module>
    lottanzb.main()
AttributeError: 'module' object has no attribute 'main'

I should try the source code...

So, my answer to your question is: "Yes, the segmentation faults probleme isn't here now" ^^

Otherwise, when I was in Hardy, the 0.2 version worked good.

Gueraph Mayax (yoann-weber) wrote :

EDIT: same problem with source code ;)

Traceback (most recent call last):
  File "/usr/bin/lottanzb", line 8, in <module>
    lottanzb.main()
AttributeError: 'module' object has no attribute 'main'

Severin Heiniger (severinh) wrote :

This will solve the "'module' object has no attribute 'main'" problem: https://answers.launchpad.net/lottanzb/+question/38070

Gueraph Mayax (yoann-weber) wrote :

Yes, that solved the problem! Thanks Severin!
No longer problems with segmentation faults! Good job!

Changed in lottanzb:
assignee: nobody → lottanzb
milestone: none → 0.3
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers