installer crashes with encrypted home

Bug #889460 reported by flib on 2011-11-12
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Linux Mint

Bug Description

1) Linux Mint 12 Lisa RC
2) The option in the installer to encrypt the home directory is selected.
3) After the installer has finished copying files, it will crash and doesn't give the option to report the bug as it claims.
4) I expected the installer to not crash.
5) This always happens, and is confirmed to happen to at least one other person.

Three other persons have the same problem here. In x64 bits also. We are writing about this problem in ubuntu forum romania. Other details about our discusions, here ->

cyclooctane (cyclooctane) wrote :

I can also confirm this bug.
Exactly the same response as listed in the initial report.
Occurred with both the 32 and 64 bit ISOs.
And on both an asus G60JX and an acer aspire 1
I have attempted re-burning both ISOs but to no avail.

Carmelo Cruz (carmelo-cruz) wrote :

I am also confirming this bug.
Using the x64 DVD iso.

Skeletor (gmskel87) wrote :

Confirming. 64-bit DVD. Tried to install twice with Home encryption enabled. I was able to install without home encryption.

Fredrik Svanström (fredria) wrote :

Can confirm, using 64bit. Will try to install w/o encrypted HOME

Confirm on IBM Thinkpad with 32bit Iso. Installation w/o does fine!

flib (i-am-flib) on 2011-11-17
Changed in linuxmint:
status: New → Confirmed
Stephan Muhs (stephan-dinoco) wrote :

Same problem here (Mint 12 RC amd64 DVD Image), MD5 sums correct and DVD verified good. Installation without encrypted home folder succeeds.

VRllera (vrllera) wrote :

Confirming. 32bit dvd iso. Installation without encrypted home folder succeeds.

Cleocir (contato-cleocir) wrote :

Same problem here: 64bit DVD iso.

Confirming this bug on Acer Aspire One 32Bit dvd iso. Crashes with encrypted home folder, installs fine without

This bug is still present in Mint 12 64 bit KDE DVD ISO version released last week. Again no problem with unencrypted home.

linkx (link-mustbuilddigital) wrote :

Confirming on the 64-bit KDE DVD installing /home to separate partition. Installed without encryption no prob. Wasted 1/2 day trying to get it installed.

Radek (drozdos) wrote :

Hi, I have the same problem with Mint KDE 12 x64, when mount my old home partition. Problem was solved, when put my old username and password. The old partition was crypted by old Ubuntu distro.

Karl (kh2l) wrote :

Yep, definitely broken, clicking encryption is like saying "install all the files, but break afterwards".

CPJ (hv77t) wrote :

I can confirm the bug once more Mint 15 Cinnamon. Actually it is in several distributions, e.g also in lubuntu.

I can also not install Linux Mint on an encrypted volume if I just make swap and a root partition. If I tell him to decide everything himself but encrypt the drive it works. A bit ridiculous.

Laurent Cas (laurent-cas) wrote :

bug confirmed in Mint 16 32 bits all editions KDE / XFCE / Mate / Cinnamon

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers