The Linux Mint Distribution

libgtk2.0-dev fails to install due to broken dependencies

Reported by Axel Pahl on 2010-12-30
102
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Linux Mint
High
Clement Lefebvre

Bug Description

Running LMDE, I get the following error when I try to install libgtk2.0-dev:

$ sudo apt-get install libgtk2.0-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk2.0-dev : Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
                 Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
E: Broken packages

Kind regards,
 Axel

jejbarr (jejbarr) wrote :

Heh, was just coming here to post this.

I don't know if it helps, but I tried an apt-get install on the dependencies, and their dependencies, and so on. Below are those results, with alot of the filler from the output removed for brevity.

apt-get install libgtk2.0-dev
The following packages have unmet dependencies:
 libgtk2.0-dev : Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
                 Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed

apt-get install libpango1.0-dev
The following packages have unmet dependencies:
 libpango1.0-dev : Depends: libxft-dev but it is not going to be installed
                   Depends: libfontconfig1-dev (>= 2.1.91) but it is not going to be installed
                   Depends: libcairo2-dev (>= 1.8.2-2) but it is not going to be installed

apt-get install libcairo2-dev
The following packages have unmet dependencies:
 libcairo2-dev : Depends: libcairo-gobject2 (= 1.10.0-1ubuntu2) but it is not installable
                 Depends: libfontconfig1-dev (>= 2.2.95) but it is not going to be installed
                 Depends: libpixman-1-dev (>= 0.18.4) but it is not going to be installed

apt-get install libxft-dev
The following packages have unmet dependencies:
 libxft-dev : Depends: libfontconfig1-dev but it is not going to be installed

apt-get install libfontconfig1-dev
The following packages have unmet dependencies:
 libfontconfig1-dev : Depends: libfontconfig1 (= 2.8.0-2.1) but 2.8.0-2ubuntu1 is to be installed

apt-get install libpixman-1-dev
The following packages have unmet dependencies:
 libpixman-1-dev : Depends: libpixman-1-0 (= 0.16.4-1) but 0.18.4-1 is to be installed

Justin Krehel (jkrehel) wrote :

Thank you all for reporting this!

I can confirm this as I was trying to build packages last night with the same result. I'll see what can be done.

Thank you again. We really appreciate the reports!

Changed in linuxmint:
status: New → Confirmed
importance: Undecided → High
Changed in linuxmint:
assignee: nobody → Clement Lefebvre (clementlefebvre)
Koscum (koscum-gmail) wrote :

I managed to install it by enabling Debian Experimental repository and using Force Version in Synaptic on the following packages:
fontconfig-config: 2.8.0-2.1 (testing)
libfontconfig1: 2.8.0-2.1 (testing)
libpixman-1-0: 0.21.2-1 (experimental)
libpixman-1-dev: 0.21.2-1 (experimental)
libcairo2: 1.10.2-1 (experimental)
libcairo-gobject2: 1.10.2-1 (experimental)
libcairo2-dev: 1.10.2-1 (experimental)

Changed in linuxmint:
milestone: none → lmde-upcoming

Fixed.

The following packages were imported from Ubuntu:

- libfontconfig1-dev
- libpixman-1-dev
- libcairo-gobject2

All dependencies should now be satisfied.

Changed in linuxmint:
status: Confirmed → Fix Released
Volker Meyer (vlhm) wrote :

Fix works for me (LMDE 64bit) !

Thank you very much, Clem

Axel Pahl (chemist69) wrote :

Hi, unfortunately the bug still exists for me (LMDE 32bit)
I still get this error:
The following packages have unmet dependencies:
 libgtk2.0-dev : Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
                 Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
E: Broken packages

Thanks for your efforts so far!
Axel

Volker Meyer (vlhm) wrote :

Hi Axel,

i just started an "apt-get install libgtk2.0-dev" on a 32bit LMDE. There were no complaints about dependencies. The machine was plain before, means I never installed any -dev package by hand.
So maybe you have to play around with deinstalling / installing or forceversion for the related packages in synaptic a little. This was also the case in 64bit.

Good luck
Volker

Axel Pahl (chemist69) wrote :

Hi,
I'm sorry, but when I try to install libfontconfig1-dev I get the error that the corresponding libconfig1 will not be pulled from ubuntu, but from debian:

$ sudo apt-get install libfontconfig1-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 libfontconfig1-dev : Depends: libfontconfig1 (= 2.8.0-2ubuntu1) but 2.8.0-2.1 is to be installed
E: Broken packages

And, sure enough, when I reinstall libconfig1, the debian version is pulled which does not fulfill the requirements for the -dev package:
$ sudo apt-get install --reinstall libfontconfig1
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 274 kB of archives.
After this operation, 0 B of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  libfontconfig1
Authentication warning overridden.
Get:1 http://ftp.debian.org/debian/ testing/main libfontconfig1 i386 2.8.0-2.1 [274 kB]
Fetched 274 kB in 5s (45.8 kB/s)
(Reading database ... 217483 files and directories currently installed.)
Preparing to replace libfontconfig1 2.8.0-2.1 (using .../libfontconfig1_2.8.0-2.1_i386.deb) ...
Unpacking replacement libfontconfig1 ...
Setting up libfontconfig1 (2.8.0-2.1) ...

Kind regards,
 Axel

Volker Meyer (vlhm) wrote :

Maybe You can try this line?

sudo apt-get install libfontconfig1-dev=2.8.0-2.1 libfontconfig1=2.8.0-2.1 fontconfig-config=2.8.0-2.1

Volker Meyer (vlhm) wrote :

Previous comment has some automatic line break in it. It is only one commandline!

Axel Pahl (chemist69) wrote :

That WORKED !!
Thanks a lot, Volker !
Kind regards,
 Axel

Volker Meyer (vlhm) wrote :

You're welcome.

antigirl666 (antigirl666) wrote :

there is same error for me but when i type
sudo apt-get install libfontconfig1-dev=2.8.0-2.1 libfontconfig1=2.8.0-2.1 fontconfig-config=2.8.0-2.1
it says:
E: Version '2.8.0-2.1' for 'libfontconfig1-dev' was not found
E: Version '2.8.0-2.1' for 'libfontconfig1' was not found
E: Version '2.8.0-2.1' for 'fontconfig-config' was not found

Volker Meyer (vlhm) wrote :

Looks like You either do not have the source repositories enabled or you package information is not up to date.
The version is still correct for squeeze and wheezy on packages.debian.org

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers