[mintsources] Cannot change the "Base (trusty)" mirror

Bug #1400096 reported by Daniel D'Onofrio on 2014-12-07
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
Medium
Clement Lefebvre

Bug Description

Cannot change the base's mirror. The window is not opening, and sametimes the whole mintsources crash when try to open that window.

mintsources 1.3.7 on Linux Mint 17.1 (rebecca)

Dorian Baciu (baciu-dorian) wrote :

I confirm that don’t work the “Base (trusty)” selection in mintsources (software sources) ver. 1.3.7 for choosing alternate server, in Linux Mint 17.1. Maybe mintsources ver. 1.3.7 has a bug.

Beside this think, for the updates from Base (Trusty), download speed from the only one server accessible from the "list" (the list is blocked in mintsources ver. 1.3.7), archive.ubuntu.com/ubuntu (from UK) is very very slow (300-400 KB/s), comparated to the server from my country (Romania), http://ubuntu.mirrors.linux.ro/archive, which may be selected in mintsources ver. 1.3.4 and may be downloaded the updates at a speed of 2000-3000 KB/s (no kbps).

Here’s the error in choosing another server (alternate server) for “Base (trusty)” in mintsources ver. 1.3.7 (Software sources):

“~ $ mintsources

(gksu:8183): Gtk-WARNING **: Theme file for default has no name

(gksu:8183): Gtk-WARNING **: Theme file for default has no directories

Error ‘RETR response: 550′ on url ftp://ftp.rrzn.uni-hannover.de/pub/mirror/linux/ubuntu
Error ‘RETR response: 550′ on url ftp://ftp.rezopole.net/ubuntu
Error ‘Could not resolve host: ubuntu-archive.mirrors.free.org’ on url http://ubuntu-archive.mirrors.free.org/ubuntu
Error ‘RETR response: 550′ on url ftp://ftp.cesca.cat/ubuntu/archieve
Error ‘RETR response: 550′ on url ftp://ftp.cs.mun.ca/pub/mirror/ubuntu
Error ‘Could not resolve host: mirror.peer1.net’ on url http://mirror.peer1.net/ubuntu
Error ‘RETR response: 550′ on url ftp://ftp.fu-berlin.de/linux/ubuntu
Error ‘Couldn’t resolve host ‘dl2.foss-id.web.id” on url http://dl2.foss-id.web.id/ubuntu
/usr/lib/linuxmint/mintSources/mintSources.py:1105: GtkWarning: Theme file for default has no directories

self._main_window.show_all()
Traceback (most recent call last):
File “/usr/lib/linuxmint/mintSources/mintSources.py”, line 1087, in select_new_base_mirror
url = self.mirror_selection_dialog.run(self.base_mirrors)
File “/usr/lib/linuxmint/mintSources/mintSources.py”, line 508, in run
self._update_list()
File “/usr/lib/linuxmint/mintSources/mintSources.py”, line 434, in _update_list
self._all_speed_tests()
File “/usr/lib/linuxmint/mintSources/mintSources.py”, line 440, in _all_speed_tests
thread_id = thread.start_new_thread(self._speed_test, (self._mirrors_model, iter))
thread.error: can’t start new thread”

I use Linux Mint 17.1 (Rebecca) - Cinnamon (after upgrade from Linux Mint 17.0 (Qiana) - Cinnamon).

The same problem is also a clean install of Linux Mint 17.1 (Rebecca) - Cinnamon.

Sorry for my bad English.

Changed in linuxmint:
status: New → Incomplete
status: Incomplete → New
WinterTroubles (wintertroubles) wrote :
Download full text (13.3 KiB)

I would also like to add confirmation of this issue.

Running Mint 17.1 Cinnamon 32bit, upgraded from Mint 17 via the update manager... Mint 17 was a fresh install.

Selecting 'Base (Rebecca)' in mintsources works as expected, however selecting 'Base (trusty)' results in either window closure or failure to open the next window.

Running mintsources in terminal gives these errors when 'Base(trusty)' button clicked..

steve@mint17cinn ~ $ mintsources
Error '' on url http://ftp.uninett.no/ubuntuError '' on url http://no.archive.ubuntu.com/ubuntu

Error 'RETR response: 550' on url ftp://ftp.rrzn.uni-hannover.de/pub/mirror/linux/ubuntu
Error 'Failed to connect to ubuntu.univ-reims.fr port 80: Connection timed out' on url http://ubuntu.univ-reims.fr/ubuntu
Error 'Failed to connect to mirrors.coreix.net port 80: Connection timed out' on url http://mirrors.coreix.net/ubuntu
Error 'RETR response: 550' on url ftp://ftp.cesca.cat/ubuntu/archieve
Error 'Failed to connect to ubuntu.virginmedia.com port 80: Connection timed out' on url http://ubuntu.virginmedia.com/archive
Error 'Failed to connect to mirror.as24220.net port 80: Connection timed out' on url http://mirror.as24220.net/pub/ubuntu
Error 'Failed to connect to ubuntu.etf.bg.ac.rs port 80: Connection refused' on url http://ubuntu.etf.bg.ac.rs/ubuntu
Error 'Failed to connect to archive.ubuntu.nautile.nc port 80: Connection timed out' on url http://archive.ubuntu.nautile.nc/ubuntu
Error 'Failed to connect to mirror.bjtu.edu.cn port 80: Connection timed out' on url http://mirror.bjtu.edu.cn/ubuntu
Error 'RETR response: 550' on url ftp://ftp.rezopole.net/ubuntu
Error 'Couldn't resolve host 'ubuntu.mirror.pop-sc.rnp.br'' on url http://ubuntu.mirror.pop-sc.rnp.br/ubuntuError 'Couldn't resolve host 'archive.ubuntu.csg.uzh.ch'' on url http://archive.ubuntu.csg.uzh.ch/ubuntu
Error 'Couldn't resolve host 'ubuntu-archives.mirror.nexicom.net'' on url http://ubuntu-archives.mirror.nexicom.net
Error 'Couldn't resolve host 'mirror.dhakacom.com'' on url http://mirror.dhakacom.com/ubuntu-archive
Error 'Couldn't resolve host 'mirrors.aliyun.com'' on url http://mirrors.aliyun.com/ubuntuError 'Couldn't resolve host 'ftp.byfly.by'' on url http://ftp.byfly.by/ubuntu
Error 'Couldn't resolve host 'ubuntu.mirror.iweb.ca'' on url http://ubuntu.mirror.iweb.ca

 Error 'Couldn't resolve host 'mirror.switch.ch'' on url http://mirror.switch.ch/ftp/mirror/ubuntuError 'Couldn't resolve host 'mirror.lzu.edu.cn'' on url http://mirror.lzu.edu.cn/ubuntuError 'Couldn't resolve host 'mirror.unesp.br'' on url http://mirror.unesp.br/ubuntu

Error 'Couldn't resolve host 'mirror.its.sfu.ca'' on url http://mirror.its.sfu.ca/mirror/ubuntu

Error 'Couldn't resolve host 'mirror.globo.com'' on url http://mirror.globo.com/ubuntu/archive
Error 'Couldn't resolve host 'ubuntu.c3sl.ufpr.br'' on url http://ubuntu.c3sl.ufpr.br/ubuntu
Error 'Couldn't resolve host 'sft.if.usp.br'' on url http://sft.if.usp.br/ubuntuError 'Couldn't resolve host 'ubuntu.bhs.mirrors.ovh.net'' on url http://ubuntu.bhs.mirrors.ovh.net/ftp.ubuntu.com/ubuntuError 'Couldn't resolve host 'ubuntu.mirror.rafal.ca'' on url http://ubuntu.mirror.rafal.ca/ubuntuError 'Couldn't reso...

Changed in linuxmint:
status: New → Confirmed
status: Confirmed → New
Changed in linuxmint:
status: New → Confirmed
Anton Markov (anton-92-m) wrote :

Hello, Dorian

This is how to change the repositories list manually.
1. Browse to this directory: "/etc/apt/sources.list.d".
2. Open "official-package-repositories.list" as administrator.
3. Make file to look exactly like this:

--------------------------------------------------------------------------------------------------------------------------------
deb http://mirrors.serverhost.ro/mint/packages rebecca main upstream import

deb http://extra.linuxmint.com rebecca main

deb http://ro.archive.ubuntu.com/ubuntu trusty main restricted universe multiverse
deb http://ro.archive.ubuntu.com/ubuntu trusty-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ trusty partner
---------------------------------------------------------------------------------------------------------------------------------

While this bug is not fixed, use the method, explained above.

Anton Markov (anton-92-m) wrote :
Download full text (20.6 KiB)

Hello, Guys

This is my output from "mintsources"

user@userdesktop ~ $ mintsources
removed ‘/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_trusty_Release’
removed ‘/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_trusty_Release.gpg’
removed ‘/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_trusty_partner_binary-i386_Packages’
removed ‘/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_trusty_partner_i18n_Translation-en’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty-updates_Release’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty-updates_Release.gpg’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty-updates_main_binary-i386_Packages’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty-updates_main_i18n_Translation-en’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty-updates_multiverse_binary-i386_Packages’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty-updates_multiverse_i18n_Translation-en’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty-updates_restricted_binary-i386_Packages’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty-updates_restricted_i18n_Translation-en’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty-updates_universe_binary-i386_Packages’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty-updates_universe_i18n_Translation-en’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty_Release’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty_Release.gpg’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty_main_binary-i386_Packages’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty_main_i18n_Translation-en’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty_multiverse_binary-i386_Packages’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty_multiverse_i18n_Translation-en’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty_restricted_binary-i386_Packages’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty_restricted_i18n_Translation-en’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty_universe_binary-i386_Packages’
removed ‘/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty_universe_i18n_Translation-en’
removed ‘/var/lib/apt/lists/extra.linuxmint.com_dists_rebecca_Release’
removed ‘/var/lib/apt/lists/extra.linuxmint.com_dists_rebecca_Release.gpg’
removed ‘/var/lib/apt/lists/extra.linuxmint.com_dists_rebecca_main_binary-i386_Packages’
removed ‘/var/lib/apt/lists/lock’
removed ‘/var/lib/apt/lists/packages.linuxmint.com_dists_rebecca_Release’
removed ‘/var/lib/apt/lists/packages.linuxmint.com_dists_rebecca_Release.gpg’
removed ‘/var/lib/apt/lists/packages.linuxmint.com_dists_rebecca_import_binary-i386_Packages’
removed ‘/var/lib/apt/lists/packages.linuxmint.com_dists_rebecca_main_binary-i386_Packages’
removed ‘/var/lib/apt/lists/packages.linuxmint.com_dists_rebecca_upstream_binary-i386_Packages’
removed ‘/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_Release’
removed ‘/var/...

Ugo Palazzo (led-zep-trash) wrote :

I confirm I also have this bug, as reported here
http://forums.linuxmint.com/viewtopic.php?f=47&t=183974#p958186

I apologize for not being at my Mint pc ATM, so I can't be of further help with terminal outputs and such.

UgoRipley

WinterTroubles (wintertroubles) wrote :

This post was added to the Mint Forums topic yesterday (http://forums.linuxmint.com/viewtopic.php?p=959053#p959053), pasting it here as it seems obviously relevant

By sandt1g3r

I have this problem too (among others :P )

As a workaround, editing the mintSources.py file ( /usr/lib/linuxmint/mintSources/mintSources.py ) by commenting

self._all_speed_tests() // Line 434 in function _update_list(self)

avoids the problem (ofcourse it no longer runs the speed tests on all repo servers but that is ok for me till official fix is out)

Thanks, confirmed in 32bit and reproducible, we'll get that fixed.

WinterTroubles (wintertroubles) wrote :

Thanks Clem, much appreciated :)

Dorian Baciu (baciu-dorian) wrote :

Thank you very much Clem for your response.

Ugo Palazzo (led-zep-trash) wrote :

Thanks Clem.

Clem, or any Dev team member, if you see this.

Now that 17.1 Xfce and KDE have been released is there any news on when the fix for this bug is likely to be made available?

Obviously the release of of 17.1 has been a busy time, but, I assumed (probably without good reason) that the Team would want to make the fix for this before promoting Xfce and KDE to Final.

I'm probably underestimating the difficulty of the fix due to it not being confirmed in 64bit and am more than willing to be told to be more patient if that's the case :)

Regards
WT

Hi,

It's down to multithreading... we're basically testing the speed of the mirrors in parallel. When there are many mirrors we open many threads... that's a bit to agressive and past a certain limit, we're told to crash basically :)

The issue is identified, there are a few solutions we can try.

Thanks for the update Clem :)

As usual I'd underestimated the complexity of the issue.

I fully appreciate all the effort you and the rest of the team put into making this distro and as this issue is non-critical, for me, I will be patient and grateful that Mint 17.1 is otherwise bug free for me.

Regards
WT

Fixed by https://github.com/linuxmint/mintsources/commit/cc9201cb7b22e68c0c1a9131a077075ccba0adcb

The number of concurrent threads is now set to 80.

If this still doesn't work for you, try and reduce that number (here's the line of code https://github.com/linuxmint/mintsources/blob/master/usr/lib/linuxmint/mintSources/mintSources.py#L441).

This bug was fixed in mintsources 1.3.8.

If you still encounter this problem, please create an issue at https://github.com/linuxmint/mintsources/issues

Changed in linuxmint:
status: Confirmed → Fix Released
importance: Undecided → Medium
assignee: nobody → Clement Lefebvre (clementlefebvre)

Mintsources 1.3.8 fixed it for me

Many thanks Clem :)

Dorian Baciu (baciu-dorian) wrote :

Thank you very much Clem for the correction to choose an alternate server to Base (Trusty) from mintsources.
Now everything works well in mintsources (ver. 1.3.8).
Thank you Clem.

Best regards,
Dorian

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments