WiFi / WLAN LED not working on notebooks with Intel iwl4965 | iwl3945

Bug #176090 reported by Michael Doube on 2007-12-13
244
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Wishlist
Ubuntu
Undecided
Unassigned
Nominated for Jaunty by Sebastian Haselbeck
linux (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Sebastian Haselbeck
linux-backports-modules-2.6.24 (Ubuntu)
Medium
Tim Gardner
Nominated for Jaunty by Sebastian Haselbeck
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Sebastian Haselbeck

Bug Description

The WLAN LED does not glow on recent Intel-based notebooks (including Sony Vaio, Dell Inspiron, Lenovo Thinkpad and many others - we know, please don't list yours here), using the iwl4965 or iwl3945 WiFi drivers.

There appears to be a regression in the latest drivers in proposed, specifically 2.6.24-20.38, where the LED does not blink at all, even with backports installed.

This problem is fixed for Ubuntu 8.04 (Hardy) in the backported kernel modules. (Note, however, that it does not behave the same way as it used to. The light will not blink on and off, but will be steady.) Please install 'linux-backports-modules-hardy' before posting to this bug report complaining that your LED doesn't work:

:~$ sudo apt-get install linux-backports-modules-hardy
then:
:~$ sudo rmmod iwl4965; sudo modprobe iwl4965
or:
:~$ sudo rmmod iwl3945; sudo modprobe iwl3945

Please only add to this bug if:

a) you are informing about changes made to code or packaging.
b) you find a duplicate bug.
c) the backports modules don't fix your LED

Michael Doube (michael-doube) wrote :
Michael Doube (michael-doube) wrote :
Michael Doube (michael-doube) wrote :

Hi Michael,

Thank you for your report and helping to make Ubuntu better. For future reference, if you could attach your log files as separate flat text files rather than zipped up tarballs, it would be much appreciated.

I wanted to let you know the Hardy Heron Alpha2 release will be coming out soon (around Dec 20). It will have an updated version of the kernel. It would be great if you could test with this new release and verify if this issue still exists. I'll be sure to update this report when Alpha2 is available. Thanks!

Changed in linux:
status: New → Incomplete

I'm opened a new task against the actively developed kernel. However, I'm closing the report against linux-source-2.6.22 as it does not meet the criteria for a stable release update. You can learn more about the stable release update process at https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux-source-2.6.22:
status: New → Won't Fix

Hi Leann

Thanks for getting back to me on this. I'll have a go with hardy
alpha-2 once it's out. I think this problem is a bug in the iwl4965
driver, which Intel are addressing themselves:

http://bughost.org/bugzilla/show_bug.cgi?id=1209

Mike

Leann Ogasawara wrote:
> Hi Michael,
>
> Thank you for your report and helping to make Ubuntu better. For future
> reference, if you could attach your log files as separate flat text
> files rather than zipped up tarballs, it would be much appreciated.
>
> I wanted to let you know the Hardy Heron Alpha2 release will be coming
> out soon (around Dec 20). It will have an updated version of the
> kernel. It would be great if you could test with this new release and
> verify if this issue still exists. I'll be sure to update this report
> when Alpha2 is available. Thanks!
>
> ** Also affects: linux (Ubuntu)
> Importance: Undecided
> Status: New
>
> ** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>
> ** Tags added: hardy-alpha2
>
>

Thanks for the pointer to the other bug report. I've set up a bug watch for it (https://wiki.ubuntu.com/Bugs/Watches) . Hopefully the patches mentioned there will make it into the upstream mainline kernel soon and then we'll pull from there. Thanks!

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in linux:
status: Unknown → In Progress
Michael Doube (michael-doube) wrote :

Not fixed in Hardy alpha-2.

Fred (frederic-lespez) wrote :

Confirming this bug on an ACER TravelMate 6292 with iwl4965 driver.
Tested on Gutsy and Hardy Alpha 2.

Confirmed on DELL XPS M1330 too, with gutsy and hardy!
I have reinstalled vista to confirm this, and the wlan led appear in vista :)

wodz (wodz) wrote :

Thinkpad R61 - not fixed in Hardy Alpha 3. :-(

description: updated
wodz (wodz) wrote :

I have build 2.6.24-rc7 with this patch applied http://bughost.org/bugzilla/attachment.cgi?id=1263 and wifi led worsk (it is solid on when associated to ap and off when not). Led reacts to rfkill switch correctly. So I vote for inclusion of this patch into Hardy's kernel. Preferably I would like to see wifi led react on network traffic but it is much better to have any kind of indication that wifi is in use than to not have.

Michael Doube (michael-doube) wrote :

Yeah, I'd like to see the LED blink on network activity ideally, but just having it on at all would be a big improvement from its current status of not working at all.

Michael Doube (michael-doube) wrote :

This bug is still present in Hardy alpha-4

Erik Vetters (evetters) wrote :

Confirmed on Dell D420 and D430

description: updated
David Tomaschik (matir) wrote :

Confirmed on System76 Pangolin.

Mikhail Yakshin (greycat) wrote :

Confirmed on Dell D630

Hi woodz,

Thanks for testing the patch. However, it doesn't appear the patch has been merged upstream yet. It is a lot of extra work for the Ubuntu kernel team to maintain out of tree patches. As such they require evidence of upstream submission before considering to maintain community patches locally. With the current Hardy development cycle going into Feature Freeze It's likely this may not get resolved until Hardy+1. We'll continue to keep an eye on it. Thanks.

Changed in linux:
status: Triaged → Incomplete
dhenry (tfc-duke) wrote :

A first patch for getting LED working on linux-2.6.24 should be avalaible soon...
http://sourceforge.net/mailarchive/forum.php?thread_name=47ABFCCC.3040703%40atsystem.org&forum_name=ipw3945-devel

Vytas (vytas) wrote :

Confirmed on Dell D620

Tim Gardner (timg-tpi) wrote :

Enabled CONFIG_MAC80211_LEDS

Changed in linux:
assignee: ubuntu-kernel-team → timg-tpi
milestone: none → hardy-alpha-6
status: Incomplete → Fix Committed
Changed in linux-source-2.6.24:
status: New → Invalid
Michael Doube (michael-doube) wrote :

Looking forward to seeing this fixed - fix didn't make it into hardy a5

Jerone Young (jerone) wrote :

How can a patch be commited into Ubuntu kernel when upstream doesn't even have a proper patch for this yet. I truely hope you didn't take the patch out to the bugzilla (as that is not an acceptilble patch) that wodz reported .. this patch is not acceptable upstream...this has been gone over for long time upstream on the list... it should be fixed soon (according to Mohamed last week...but nothing yet)...but if you did take that patch in bugzilla .. PULL IT!

And wait till the right one is created up stream.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-ubuntu-modules-2.6.24 - 2.6.24-10.14

---------------
linux-ubuntu-modules-2.6.24 (2.6.24-10.14) hardy; urgency=low

  [Jay Chetty]

  * poulsbo: update to beta 6 version of the driver
  * poulsbo: update to beta 6 version of the driver

  [Stefan Bader]

  * Pull in the RAID4/5 target for device-mapper.
  * Pull in the RAID4/5 target for device-mapper.
  * Remove exports of dm-log to solve duplicate symbols.
  * Update hdaps_ec to use vendor IBM for X40 and X41.
    - LP: #33950

  [Tim Gardner]

  * Adjust quirk for snd-hda-intel on Dell laptops
    - LP: #191859
  * Added acer-wmi
    - LP: #190677
  * Enabled iwlwifi LEDS
    - LP: #176090
  * iwlwifi spams syslog
    - LP: #191388
  * Updated to et131x-1.2.3-1
    - LP: #150515
  * et131x: Slow down error timer
    - LP: #150515

 -- Tim Gardner <email address hidden> Sun, 17 Feb 2008 21:52:02 -0700

Changed in linux-ubuntu-modules-2.6.24:
status: Fix Committed → Fix Released
Sympy (sympathy4no1) wrote :

Will a patch / workaround for Gutsy be made available?

Ben Collins (ben-collins) wrote :

No, this does not pass the SRU policy for gutsy. However, hardy will be released in less than 2 months, so you will be able to upgrade soon.

Vytas (vytas) wrote :

I have latest packages installed (including linux-ubuntu-modules 2.6.24-10.14), but this is still not fixed.
I have Dell D620 laptop with intel wireless:

$ lsmod | grep iwl
iwl3945 89844 0
iwlwifi_mac80211 219876 1 iwl3945
cfg80211 15112 1 iwlwifi_mac80211

I have tested the same hardware under Windows XP, LED works as expected, so it is not hardware problem

Changed in linux-ubuntu-modules-2.6.24:
status: Fix Released → New
Michael Doube (michael-doube) wrote :

Same as Vytas: I updated packages this morning (including linux-ubuntu-modules 2.6.24-10.14) and the LED is not working with iwl4965.

Mikael Gerdin (mgerdin) wrote :

I can also confirm that iwl3945 in linux-ubuntu-modules 2.6.24-10.14 does not enable the LED on my Dell XPS M1210 (amd64 userland)

Vytas (vytas) on 2008-02-27
Changed in linux-ubuntu-modules-2.6.24:
status: New → Confirmed
Attila Molnár (molnar-attila) wrote :

confirmed.
My Acer 6292 not work yet.
 # lsmod | grep iwl
iwl4965 105844 0
iwlwifi_mac80211 219876 1 iwl4965
cfg80211 15112 1 iwlwifi_mac80211

Bjoern Schuemann (bjoerns) wrote :

With 2.6.24-11-generic and the respective restriced-modules, this issue is still present.

Problem confirmed also on the Dell XPS M1530.

Steve Langasek (vorlon) wrote :

confirmed that LED doesn't work for me either, Lenovo T60 w/ iwl3945 and linux-ubuntu-modules-2.6.24-11-generic 2.6.24-11.15 on amd64.

Changed in linux-ubuntu-modules-2.6.24:
milestone: hardy-alpha-6 → ubuntu-8.04
Marco (mfj) wrote :

Same problem with last kernel on a Fujitsu Siemens Amilo Pro V3205.

BC7333 (brian-abtrafco) wrote :

Same problem using 2.6.24-12.19 Flybook V5 Centrino duo based laptop.

Jeremy Nickurak (nickurak) wrote :

Confirmed on a Lenovo 3000 N100 0768DDU

stereoit (smol-robert) wrote :

Confirmed on Dell Vostro 1400 (iwl3945) and linux-ubuntu-modules 2.6.24-12.17.

Don't add wasteful comments "confirming" this already well confirmed bug. I see that there have been 8 "confirmations" in the last week or so.

Michael Doube (michael-doube) wrote :

Bug still present on Hardy Beta.

description: updated
Changed in linux-ubuntu-modules-2.6.24:
assignee: timg-tpi → ben-collins
status: Confirmed → Fix Committed
Tom Vetterlein (smbm) on 2008-04-03
Changed in linux:
status: New → Invalid
Tim Gardner (timg-tpi) on 2008-04-03
Changed in linux-ubuntu-modules-2.6.24:
assignee: ben-collins → timg-tpi
status: Fix Committed → Fix Released
description: updated
description: updated
description: updated
73 comments hidden view all 153 comments
petit-prince (petit-prince) wrote :

Levis,

I filed a new bug report for the kernel panic at
https://bugs.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.24/+bug/251767

Feel free to post your comments regarding the kernel oops there, too.

DO55 (reewdwd) wrote :

i have lenovo n100 with 3945ab

before installing backports:
1-the led is not working
2-the wireless is not working

after installing backports:
1-the led is not working
2-the wireless is not working

i cant make wireless connection with or without backports

description: updated
Changed in linux-backports-modules-2.6.24:
status: Fix Released → Confirmed
DannyDei (dei-bnb) wrote :

Guys I might delude a few of you but I have solved my problem !!!

Nothing very technical : it was the wi-fi alarm system in the house : now if I go off site from the sensors I get connected immediately and the if I come inside even in rooms where the detectors are working, the line keeps steady and high speed.

That was why i could go wi-fi fine everywhere but home and why even changing router the problem persisted : it was not depending on Linux nor on the PC nor on the Router ..... just soem wi-fi POLLUTION in the area.

Good luck to you for solving your problem as well.
Ciao From Florence Italy

Michael Doube (michael-doube) wrote :

The WLAN LED is on and blinking in Intrepid alpha 4. The blink is pretty weird though - it doesn't seem to correlate with real traffic (try pinging something and you will see what I mean). So the blink is annoying (compare to the traffic LED on the back of an ethernet card for example).

The LED stopped illuminating with the release of 2.6.24-20-generic and has not come back for me. I'm on Hardy 8.04.1, fully updated, etc., etc.... running on a Dell XPS M1530 Laptop.

Mike Hix (mike-musl) wrote :

I'm seeing the same behavior on a Lenovo X61 (7675-CTO) running Hardy. Wifi works fine, no status LED.

uname -a
Linux rho 2.6.24-21-generic #1 SMP Tue Aug 12 13:03:01 UTC 2008 x86_64 GNU/Linux

I'm using the ubuntu-default-automagically-setup iwl3945 modules. Fully patched and updated.

Mike Hix (mike-musl) wrote :

Additionally, I use the backports + proposed updates repositories with no issue.

Intel abgn 4965
Linux 2.6.26-5-generic #1 SMP Fri Aug 15 13:54:22 UTC 2008 x86_64 GNU/Linux
and i have no light!

Martianz (martianz+) wrote :

Confirmed on HP 530.

The issue is only about the LED light. Connection working without errors.

Running Ubuntu Hardy (plus backports) with no positive effects.

In this days i'm going to update to Intrepid.
Results will be posted here.

openhacker (leisner) wrote :

I saw "use backports" comment to fix the problem.

On a Lenovo X61, I upgraded to backports today...no difference.

Original wifi driver: 1.2.0, backported driver 1.2.26k -- no difference
in the led state...

Took a while to figure out wifi was working but the led was not...

marty

The Hardy "backports solution" didn't work for me too.

 Upgrading to Intrepid solved the problem.

When the wireless network is active the LED stays on.
Connected to a WiFi network blinks on I/O.

Martin.

On 9/1/08, openhacker <email address hidden> wrote:
>
> I saw "use backports" comment to fix the problem.
>
> On a Lenovo X61, I upgraded to backports today...no difference.
>
> Original wifi driver: 1.2.0, backported driver 1.2.26k -- no difference
> in the led state...
>
> Took a while to figure out wifi was working but the led was not...
>
> marty
>
> --
> WiFi / WLAN LED not working on notebooks with Intel iwl4965 | iwl3945
> https://bugs.launchpad.net/bugs/176090
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Martianz wrote:
> The Hardy "backports solution" didn't work for me too.
>
> Upgrading to Intrepid solved the problem.
>
> When the wireless network is active the LED stays on.
> Connected to a WiFi network blinks on I/O.

Upgrading to Intrepid is not an option. The LED worked in -19, just not
since. Why not fix the regression and just let the light stay on solid
when wireless is active? That's at least half the fix, and probably all
most of us want.

dhenry (tfc-duke) wrote :

Wifi LED works and blinks with linux-2.6.27-rc3 on hardy (deb packages from http://kernel.ubuntu.com/pub/next/2.6.27-rc3/), on my Lenovo 3000 N100 (intel wireless 3945). It also works in Intrepid with Live CD. If nothing breaks before Intrepid is released, this should be finally fixed with Ubuntu 8.10.

Note: I had to manually copy iwlwifi-3945.ucode and iwlwifi-3945-1.ucode from /lib/firmware/2.6.24-19-generic/ to /lib/firmware/2.6.27-1-generic/ (I had to create this directory, also)

dhenry wrote:
> Wifi LED works and blinks with linux-2.6.27-rc3 on hardy (deb packages
> from http://kernel.ubuntu.com/pub/next/2.6.27-rc3/), on my Lenovo 3000
> N100 (intel wireless 3945). It also works in Intrepid with Live CD. If
> nothing breaks before Intrepid is released, this should be finally fixed
> with Ubuntu 8.10.
>
> Note: I had to manually copy iwlwifi-3945.ucode and iwlwifi-3945-1.ucode
> from /lib/firmware/2.6.24-19-generic/ to /lib/firmware/2.6.27-1-generic/
> (I had to create this directory, also)

Is there a -backports module for this version yet? I can't just install
the image since the -backports module contains the nvidia driver I need
for my video.

Alvaro Kuolas (kuolas) wrote :

Could we contact upstream and ask them to add module option for the blinking? It's annoying I/O blink, in feisty it's was on connection and when it was activated. Some people likes the blink... other not (me!).

Mariner09 (smcmackin) wrote :

I tried the 2.6.27-1 kernel as mentioned above on a Lenovo T61 and it won't even boot. Something other than the base linux-image package must be required.

With 2.6.24-21, I get no wifi LED, but wireless does work.

Mariner09 (smcmackin) wrote :

While I finally did get the 2.6.27-1-generic kernel to boot, I've found that it does not contain the iwl4965 driver. Something needs to be done about that...

I'm marking this "Fix Released" for Intrepid.

Mariner09 - the iwl4965 driver is compiled into the 2.6.27 kernel:

ogasawara@emiko:~$ grep -rn "CONFIG_IWL4965" /boot/config-2.6.27-2-generic
1835:CONFIG_IWL4965=y

Regarding the annoying blinking LED in Intrepid, refer to bug 250211. Thanks

Changed in linux:
status: Invalid → Fix Released

I'm sorry Leann, but I have no light what so ever after X11 starts
I own a 4965 and i'm booting from kernel .27-1 and .27-2.

Changed in linux:
status: Fix Released → New
dhenry (tfc-duke) wrote :

What does dmesg says? Maybe the driver failed to load the firmware, like for me because I had to copy it from old kernel to the proper place for the new kernel...

dhenry: copying didnt fix it.

Chris Jones (cmsj) wrote :

rather than complicate this already long bug with things about trying to run the Intrepid kernel on Hardy, I would suggest you download the latest Intrepid Alpha CD and boot that.

@Bugabundo - as Chris mentioned, can you please test via a LiveCD? If the LED is still broken, please attach your full dmesg output. Thanks.

On Thursday 18 September 2008 19:21:14 Leann Ogasawara wrote:
> can you please test via a LiveCD? If the LED is still broken, please attach your full dmesg output. Thanks.

I have a full log from a LiveDVD at https://bugs.launchpad.net/bugs/263963

--
BUGabundo :o)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net
Linux user #443786 GPG key 1024D/A1784EBB
My new micro-blog @ http://BUGabundo.net

Aanjhan Ranganathan (aanjhan) wrote :

I am just typing this comment from Intrepid Alpha 6 Live CD and my Wifi LED is working again after several months. Yay! It keeps blinking when there is some data transfer or connetion and remains on if no Active connection. Details apart it never used to be turned on for the past 5-7 months. But now it works again!

Mine is a Dell XPS M1210 with iwl3945 drivers. Hope this helps

Could you please tell me what is new in Intrepid Ibex?????????
Should I upgrade to it now or wait till the stable version is released????

On Sat, Sep 20, 2008 at 10:45 PM, Aanjhan Ranganathan <<email address hidden>
> wrote:

> I am just typing this comment from Intrepid Alpha 6 Live CD and my Wifi
> LED is working again after several months. Yay! It keeps blinking when
> there is some data transfer or connetion and remains on if no Active
> connection. Details apart it never used to be turned on for the past 5-7
> months. But now it works again!
>
> Mine is a Dell XPS M1210 with iwl3945 drivers. Hope this helps
>
> --
> WiFi / WLAN LED not working on notebooks with Intel iwl4965 | iwl3945
> https://bugs.launchpad.net/bugs/176090
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in The Linux Kernel: In Progress
> Status in Ubuntu: Invalid
> Status in "linux" source package in Ubuntu: New
> Status in "linux-backports-modules-2.6.24" source package in Ubuntu:
> Confirmed
> Status in "linux-source-2.6.22" source package in Ubuntu: Won't Fix
>
> Bug description:
> The WLAN LED does not glow on recent Intel-based notebooks (including Sony
> Vaio, Dell Inspiron, Lenovo Thinkpad and many others - we know, please don't
> list yours here), using the iwl4965 or iwl3945 WiFi drivers.
>
> There appears to be a regression in the latest drivers in proposed,
> specifically 2.6.24-20.38, where the LED does not blink at all, even with
> backports installed.
>
> This problem is fixed for Ubuntu 8.04 (Hardy) in the backported kernel
> modules. (Note, however, that it does not behave the same way as it used to.
> The light will not blink on and off, but will be steady.) Please install
> 'linux-backports-modules-hardy' before posting to this bug report
> complaining that your LED doesn't work:
>
> :~$ sudo apt-get install linux-backports-modules-hardy
> then:
> :~$ sudo rmmod iwl4965; sudo modprobe iwl4965
> or:
> :~$ sudo rmmod iwl3945; sudo modprobe iwl3945
>
> Please only add to this bug if:
>
> a) you are informing about changes made to code or packaging.
> b) you find a duplicate bug.
> c) the backports modules don't fix your LED
>

Sameer this is not the place to discuss this, but i'm providing you with the link to more details:
http://www.ubuntu.com/testing/intrepid/alpha6

Upgrading to a newer version is question of needs and personal taste.
Also testing Development versions is a great way to provide feedback on your lack of hardware and apps support.
Reporting bugs on the Stable version release will usually transfer those correction to the next development cycle. So if you have a BACKUP of your data, and fill comfortable with regular breakage of your system, fill free to help us out.

Alvaro Kuolas (kuolas) wrote :

I-m using Intrepid Ibex Beta and the light is working, but it-s blinking constantly... constantly annoying! Could be user configurable at a kernel parameter? Its better the way it used to be in Feisty Fawn (ie, Blink only when connecting and just be on when the link is up... no blinking under traffic). Its against Gnome HIG the constant blinking under traffic, It just distract you with usefulness information.

David Tomaschik (matir) wrote :

Alvaro Kuolas wrote:
> I-m using Intrepid Ibex Beta and the light is working, but it-s blinking
> constantly... constantly annoying! Could be user configurable at a
> kernel parameter? Its better the way it used to be in Feisty Fawn (ie,
> Blink only when connecting and just be on when the link is up... no
> blinking under traffic). Its against Gnome HIG the constant blinking
> under traffic, It just distract you with usefulness information.
>
>
The Gnome HIG really doesn't apply to this bug... this bug is about a
hardware driver, not a part of the Gnome desktop environment. This bug
exists even when just on the console.

Alvaro Kuolas (kuolas) wrote :

Let me explain my thoughts:

Ubuntu is trying to be a Desktop OS as it's target, and the WiFi LED is important under a desktop environment. Ubuntu primary Desktop environment is Gnome, so if we want a consistent user interface we should be consistent with the UI, inside the desktop and outside with the hardware. A la Apple, be consistent.

I think that the blinking light is useless. There are people who likes it, there are who don't. A kernel run-time option us fair for me, but that's a upstream decision.

Let's think that this kernel option exists: What will be the default behavior?

My idea is: Be consistent with the UI: Gnome. Be simple and intrusive.

Alvaro Kuolas (kuolas) wrote :

I submitted this report in the Upstream bug tracking system:

http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1771

Tim Gardner (timg-tpi) wrote :

linux-backports-modules-2.6.24 (2.6.24-21.27) hardy-proposed; urgency=low

  [Tim Gardner]

  * Update to use compat-wireless-2.6-old
  * iwlwifi backport from Intel
  * Fix symbol collision issues with the iwlwifi backport
  * Fix compat-wireless build warnings.
  * Add LUM header dependencies.
  * Updated to compat-wireless-old cd7615b4e5ad9793c20fb19cdd4e7525e9dd07b7
  * Munge the ucode file names used by the iwlwifi drivers.
  * Disable IWL modules in compat-wireless, use Intel's backported drivers instead
    since the versions in compat-wireless don't work with NetworkManager.
    Should also fix suspend crash.
    - LP: #251252

 -- Tim Gardner < <email address hidden>> Tue, 09 Sep 2008 08:26:34 -0600

Changed in linux-backports-modules-2.6.24:
milestone: ubuntu-8.04 → ubuntu-8.04.2
status: Confirmed → Fix Released
Changed in linux:
status: New → Invalid

Tim would you mind getting a GUY kiss?
I got this email, turn on my wifi, and it just worked! thank you guys so much. after MONTHS I finally have got my wifi working.
lets hope it keeps going for a long long time. now i need to go close all LP tickets about it.

uname -a
Linux blubug 2.6.27-6-generic #1 SMP Tue Oct 7 04:15:23 UTC 2008 x86_64 GNU/Linux

Wifi card intel iwlagn

maybe I spoke too soon, or Tim didnt want to get that kiss...

$ sudo iwlist wlan2 scanning
wlan2 No scan results

$ sudo modprobe -r iwlagn
$ sudo modprobe iwlagn

Oct 9 09:12:41 blubug kernel: [ 5218.751618] iwlagn 0000:04:00.0: PCI INT A disabled
Oct 9 09:12:41 blubug nm-system-settings: SCPlugin-Ifupdown: devices removed (udi: /org/freedesktop/Hal/devices/net_00_1d_e0_12_a2_57)
Oct 9 09:12:41 blubug NetworkManager: <info> (wlan2): now unmanaged
Oct 9 09:12:41 blubug NetworkManager: <info> (wlan2): device state change: 3 -> 1
Oct 9 09:12:41 blubug NetworkManager: <info> (wlan2): cleaning up...
Oct 9 09:12:54 blubug kernel: [ 5231.607541] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27ks
Oct 9 09:12:54 blubug kernel: [ 5231.607549] iwlagn: Copyright(c) 2003-2008 Intel Corporation
Oct 9 09:12:54 blubug kernel: [ 5231.607668] iwlagn 0000:04:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
Oct 9 09:12:54 blubug kernel: [ 5231.607682] iwlagn 0000:04:00.0: setting latency timer to 64
Oct 9 09:12:54 blubug kernel: [ 5231.607714] iwlagn: Detected Intel Wireless WiFi Link 4965AGN REV=0x4
Oct 9 09:12:54 blubug kernel: [ 5231.646774] iwlagn: Tunable channels: 13 802.11bg, 19 802.11a channels
Oct 9 09:12:54 blubug kernel: [ 5231.648370] phy0: Selected rate control algorithm 'iwl-agn-rs'
Oct 9 09:12:54 blubug kernel: [ 5231.658536] udev: renamed network interface wlan0 to wlan2
Oct 9 09:12:54 blubug nm-system-settings: SCPlugin-Ifupdown: devices added (udi: /org/freedesktop/Hal/devices/net_00_1d_e0_12_a2_57_0, iface: wlan2)
Oct 9 09:12:54 blubug NetworkManager: <info> wlan2: driver is 'iwlagn'.
Oct 9 09:12:54 blubug NetworkManager: <info> wlan2: driver supports SSID scans (scan_capa 0x01).
Oct 9 09:12:54 blubug NetworkManager: <info> Found new 802.11 WiFi device 'wlan2'.
Oct 9 09:12:54 blubug NetworkManager: <info> (wlan2): exported as /org/freedesktop/Hal/devices/net_00_1d_e0_12_a2_57_0
Oct 9 09:12:58 blubug NetworkManager: <info> (wlan2): device state change: 1 -> 2
Oct 9 09:12:58 blubug NetworkManager: <info> (wlan2): bringing up device.
Oct 9 09:12:58 blubug kernel: [ 5235.689361] iwlagn 0000:04:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
Oct 9 09:12:58 blubug kernel: [ 5235.689599] firmware: requesting iwlwifi-4965-2.ucode
Oct 9 09:12:58 blubug kernel: [ 5235.694805] iwlagn: Radio disabled by HW RF Kill switch
Oct 9 09:12:58 blubug kernel: [ 5235.727413] ADDRCONF(NETDEV_UP): wlan2: link is not ready
Oct 9 09:12:58 blubug NetworkManager: <info> (wlan2): preparing device.
Oct 9 09:12:58 blubug NetworkManager: <info> (wlan2): deactivating device.
Oct 9 09:12:58 blubug NetworkManager: <info> (wlan2): device state change: 2 -> 3
Oct 9 09:12:58 blubug NetworkManager: <info> (wlan2): supplicant interface state change: 1 -> 2.

> Oct 9 09:12:58 blubug kernel: [ 5235.694805] iwlagn: Radio disabled by HW RF Kill switch
That nasty RF Kill switch is hitting me again. anyone got a ticket for this?

skyggen (skyggen) wrote :

2.6.24-21 update for ubuntu 8.04 fixed my wireless issue on Lenovo 3000 N200. It's now blinking on activity. =)

no wlan led on thinkpad t61 with jaunty RC either... sorry fellas, this aint fixed. the bluetooth led right next to it works though

André Pirard (a.pirard) wrote :

Using 09.10 alpha 6 LiveCD on a Medion MD 97900.
Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

WiFi by iwl3945 is simply unusable because the button doesn't enable the controller (and the LED doesn't turn on).

If iwl3945 LED problems are solved, how do I fix my (his) problem in practical terms?

Just in case anyone imagines that this may have been fixed in 9.10 then guess again. No wireless light and the fixes described here do not resolve it. [Dell Latitude E6400]

Michael Doube (michael-doube) wrote :

Edward

Can you please run
]$ apport-collect 176090

To attach detailed debug information for the developers

This has been fixed for me for ages, perhaps your notebook needs its own branch of this bug?

Alvaro Kuolas (kuolas) wrote :

It's "fixed" in the patch proposed in the upstream bug http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=1771

Current (to this date) lucid 10.04 blink constantly and it's annoying.

Changed in linux-backports-modules-2.6.24 (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Timo Aaltonen (tjaalton) on 2011-02-02
Changed in linux:
status: In Progress → Unknown
Changed in linux:
importance: Unknown → Wishlist
status: Unknown → Fix Released
Displaying first 40 and last 40 comments. View all 153 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.