[intel graphics] Desktop login freeze with kernel 3.2.0-38.59

Bug #1119809 reported by linrunner on 2013-02-08
90
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

Hardware: ThinkPad X220, 42914CG BIOS, 8DET67WW (1.37 ) – Sandy Bridge, HD3000 graphics

System: Ubuntu 12.04 (amd64, UEFI), Unity desktop, all updates, only kernel 3.2.0-38.59 from proposed

lsb_release -rd
Description: Ubuntu 12.04.2 LTS
Release: 12.04

uname -a
Linux trurl 3.2.0-38-generic #59-Ubuntu SMP Tue Feb 5 17:53:03 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

*** Primary problem – Login freeze

Steps to reproduce:
• Start System
• Login (with newly created user)

Symptoms:
• Empty panel
• Starter with dash and workspace switcher icons only
• SIM PIN dialog (X220 has UMTS card)
• Nothing clickable

Workaround:
• restart lightdm from virtual console oder via ssh
• Login now works
• Remarks: workaround possible on BAT power only – with AC restart lightdm hangs but ssh still works

*** Secondary problem (after workaround) - Blackscreen on resume

Steps to reproduce:
• Suspend (via system menu)
• Resume (via Fn-Key)

Symptoms:
• Blackscreen
• no recovery possible via virtual console or ssh

*** Outputs
Unfortunately ubuntu-bug linux stubbornly insist to say about linux-image-3.2.0-38-generic: "this is not an official ubuntu package", so tell me what additional data you need.

*** None of the above symptoms occur with kernel 3.2.0-37.58
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tk 6063 F.... pulseaudio
CRDA:
 country 98:
  (2402 - 2482 @ 40), (N/A, 20)
  (5170 - 5250 @ 40), (N/A, 20), NO-OUTDOOR
  (5250 - 5330 @ 40), (N/A, 20), NO-OUTDOOR, DFS
  (5490 - 5710 @ 40), (N/A, 26), DFS
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf1620000 irq 52'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:14f1506e,17aa21da,00100002 HDA:80862805,80860101,00100000'
   Controls : 27
   Simple ctrls : 9
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [off]
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=/dev/mapper/vg_trurl-lv_swap
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120117)
MachineType: LENOVO 42914CG
MarkForUpload: True
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-38-generic root=/dev/mapper/vg_trurl-lv_root ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-38.59-generic 3.2.37
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-38-generic N/A
 linux-backports-modules-3.2.0-38-generic N/A
 linux-firmware 1.79.1
StagingDrivers: mei
Tags: precise running-unity staging
Uname: Linux 3.2.0-38-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip fuse kvm libvirtd lpadmin plugdev sambashare sudo vboxusers
WifiSyslog:

dmi.bios.date: 12/05/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET67WW (1.37 )
dmi.board.asset.tag: Not Available
dmi.board.name: 42914CG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET67WW(1.37):bd12/05/2012:svnLENOVO:pn42914CG:pvrThinkPadX220:rvnLENOVO:rn42914CG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 42914CG
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tk 6063 F.... pulseaudio
CRDA:
 country 98:
  (2402 - 2482 @ 40), (N/A, 20)
  (5170 - 5250 @ 40), (N/A, 20), NO-OUTDOOR
  (5250 - 5330 @ 40), (N/A, 20), NO-OUTDOOR, DFS
  (5490 - 5710 @ 40), (N/A, 26), DFS
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf1620000 irq 52'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:14f1506e,17aa21da,00100002 HDA:80862805,80860101,00100000'
   Controls : 27
   Simple ctrls : 9
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [off]
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=/dev/mapper/vg_trurl-lv_swap
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120117)
MachineType: LENOVO 42914CG
MarkForUpload: True
Package: linux 3.2.0.38.46
PackageArchitecture: amd64
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-38-generic root=/dev/mapper/vg_trurl-lv_root ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-38.59-generic 3.2.37
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-38-generic N/A
 linux-backports-modules-3.2.0-38-generic N/A
 linux-firmware 1.79.1
StagingDrivers: mei
Tags: precise running-unity staging
Uname: Linux 3.2.0-38-generic x86_64
UnreportableReason: This is not an official Ubuntu package. Please remove any third party package and try again.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip fuse kvm libvirtd lpadmin plugdev sambashare sudo vboxusers
WifiSyslog:

dmi.bios.date: 12/05/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET67WW (1.37 )
dmi.board.asset.tag: Not Available
dmi.board.name: 42914CG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET67WW(1.37):bd12/05/2012:svnLENOVO:pn42914CG:pvrThinkPadX220:rvnLENOVO:rn42914CG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 42914CG
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO

linrunner (linrunner) wrote :
linrunner (linrunner) wrote :
tags: added: apport-collected precise running-unity staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Outputs completed (notice to self: had to install package "linux" from proposed).

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

The same issue on the same x220 (4290LU7).
I was able to get access to the desktop after the killing dbus-daemon and re-login.
Bug only affects Unity. Mate and Enlightenment allow log.

Stelios Vouzonikos (nem0-p) wrote :

The same here!!!

quarara (classic-art-showcase) wrote :

Same here. My kernel is 3.2.0-38.46.

Nicola Jelmorini (jelmorini) wrote :

Same here on my Intel based computer (cpu, graphic card and sound card, all by Intel)
After the login only a grey Unity Launcher with two icons and the desktop is completely freezed.

Fabien Toral (malibug) wrote :

Same for me on an Asus B23E laptop with an integrated intel Sandy Bridge HD3000 graphics.

Bristow (web-frayssinet) wrote :

A login with Unity 2D is ok !

apienk (andrzej-pienkowski) wrote :

3.2.0-38-generic #59-Ubuntu SMP x86_64
Dell XPS L502x: HD3000 + discrete nVidia GF540M
All symptoms match.

Yann Dupont (yann-dupont) wrote :

idem on a HP with intel graphics (sorry don't have exact model)
This is new and kernel related : Previous kernel 3.2.0-37 is working fine.
On 3.2.0-38 unity crash the graphics stacks, but as previously said unity 2D is working fine.

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: regression-update
linrunner (linrunner) wrote :

Hello all,

Same here.
Client is Lenovo E120.
Ubuntu 3.2.0-38-Generic

The launcher shows only 3 icons:
- dash
- workspace switcher
- trash

The menu bar is empty as well (no icons).
Nothing responds when using either the keyboard or the mouse/touchpad/trackball, etc.

My only question is - how do I roll back to version 3.2.0-38-Generic?

A workaround is to use the previous (3.2.0-37) kernel by default:

sudo gedit /etc/default/grub

-GRUB_DEFAULT=0
+GRUB_DEFAULT="2>0"

sudo update-grub

I've found another way to roll-back to kernel 3.2.0-37:

Start terminal

Type sudo apt-get remove 3.2.0-38-Generic

Press Enter
(at some point during file removal it might ask again for confirming file delete - press Y)

Type sudo update-grub

It's funny how it seems no one is thouroughly testing the new kernels before release...

tags: added: kernel-da-key
tags: added: needs-bisect
Herton R. Krzesinski (herton) wrote :

For anyone affected, please try the updated packages from http://people.canonical.com/~herton/lp1119809/ ? Hopefully they will fix the bug (I was able to reproduce and identify the issue).

linrunner (linrunner) wrote :

Hi Herton,

yes, your packages fix the problem.

Regards, Thomas

Andy Whitcroft (apw) on 2013-02-13
summary: - Desktop login freeze with kernel 3.2.0-38.59
+ [intel graphics] Desktop login freeze with kernel 3.2.0-38.59
fabio (fabio1977) wrote :

@Herton,

solves it here too. Thanks.

Fabio

Fabien Toral (malibug) wrote :

It works for for me too.
I've installed the three debs for my architecture with dpkg -i

Thanks Herton for your job and the new packages.
When could we expect an official update from Ubuntu repositories ?

Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-38.60). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
linrunner (linrunner) wrote :

Verified. The proposed kernel 3.2.0-38.60 fixes all my symptoms. Thank you very much.

Luis Henriques (henrix) wrote :

Great, thanks for testing. Tagging as verified in Precise as per comment #64.

tags: added: verification-done-precise
removed: verification-needed-precise
Launchpad Janitor (janitor) wrote :
Download full text (17.3 KiB)

This bug was fixed in the package linux - 3.2.0-38.60

---------------
linux (3.2.0-38.60) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1124013

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: fix i915 regression after commit 9594e7e
    - LP: #1119809

linux (3.2.0-38.59) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1116240

  [ Andy Whitcroft ]

  * [Config] enable various HVC consoles
    - LP: #1102206

  [ Herton Ronaldo Krzesinski ]

  * [Config] updateconfigs for 3.2.36 stable update

  [ Stefan Bader ]

  * (config) Move 9p modules into generic package
    - LP: #1107658

  [ Upstream Kernel Changes ]

  * Revert "device_cgroup: fix RCU usage"
    - LP: #1096966
  * Revert "sched, autogroup: Stop going ahead if autogroup is disabled"
    - LP: #1096966
  * Revert "ath9k_hw: Update AR9003 high_power tx gain table"
    - LP: #1096966
  * Revert "mm: vmscan: fix endless loop in kswapd balancing"
    - LP: #1096966
  * freezer: PF_FREEZER_NOSIG should be cleared along with PF_NOFREEZE
    - LP: #1096966
  * i915: Quirk no_lvds on Gigabyte GA-D525TUD ITX motherboard
    - LP: #1096966
  * drm/i915: Add no-lvds quirk for Supermicro X7SPA-H
    - LP: #1096966
  * ACPI: missing break
    - LP: #1096966
  * workqueue: convert BUG_ON()s in __queue_delayed_work() to
    WARN_ON_ONCE()s
    - LP: #1096966
  * hwmon: (coretemp) Improve support of recent Atom CPU models
    - LP: #1096966
  * hwmon: (coretemp) Add support for Atom D2000 and N2000 series CPU
    models
    - LP: #1096966
  * hwmon: (coretemp) Improve support for TjMax detection on Atom CPUs
    - LP: #1096966
  * hwmon: (coretemp) Add support for Atom CE4110/4150/4170
    - LP: #1096966
  * ARM: 7566/1: vfp: fix save and restore when running on pre-VFPv3 and
    CONFIG_VFPv3 set
    - LP: #1096966
  * sata_svw: check DMA start bit before reset
    - LP: #1096966
  * drivers/leds/leds-lp5521.c: fix typo
    - LP: #1096966
  * drivers/leds/leds-lp5521.c: ret may be uninitialized
    - LP: #1096966
  * drivers/leds/leds-lp5521.c: fix lp5521_read() error handling
    - LP: #1096966
  * scsi: aha152x: Fix sparse warning and make printing pointer address
    more portable.
    - LP: #1096966
  * ALSA: hda - Fix missing beep on ASUS X43U notebook
    - LP: #1096966
  * i7300_edac: Fix error flag testing
    - LP: #1096966
  * Revert misapplied "mmc: sh-mmcif: avoid oops on spurious interrupts"
    - LP: #1096966
  * tmpfs: fix shared mempolicy leak
    - LP: #1096966
  * powerpc: fix wii_memory_fixups() compile error on 3.0.y tree
    - LP: #1096966
  * s390/kvm: dont announce RRBM support
    - LP: #1096966
  * cgroup: cgroup_subsys->fork() should be called after the task is added
    to css_set
    - LP: #1096966
  * freezer: add missing mb's to freezer_count() and freezer_should_skip()
    - LP: #1096966
  * mm: add kmap_to_page()
    - LP: #1096966
  * mm: highmem: export kmap_to_page for modules
    - LP: #1096966
  * virtio: 9p: correctly pass physical address to userspace for high pages
    - LP: #1096966
  * virtio: force vring descriptors to be allocated from lowmem
    - LP: #1096966
  * ath9k_hw: Ena...

Changed in linux (Ubuntu):
status: Confirmed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers