Panda 4460 with HDMI + Unity 3D: No output on "es2gears" & "glmark2-es2" test, system UI hangs.

Bug #1029271 reported by Botao on 2012-07-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
High
Unassigned

Bug Description

On Panda 4460 board, with hardware pack:

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/197/hwpack_linaro-lt-panda-x11-base_20120723-197_armhf_supported.tar.gz

and ubuntu rootfs:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/305/linaro-precise-ubuntu-desktop-20120723-305.tar.gz

There is no output for "es2gears" & "glmark2-es2" test. Refer to attachment to get full serial console log.

###################################################################
For Panda 4460 board, this issue is observed on following images:

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/197/hwpack_linaro-lt-panda-x11-base_20120723-197_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/219/lt-panda-x11-base-precise_ubuntu-desktop_20120803-219.img.gz

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/242/lt-panda-x11-base-precise_ubuntu-desktop_20120812-242.img.gz

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/256/lt-panda-x11-base-precise_ubuntu-desktop_20120819-256.img.gz

http://releases.linaro.org/12.08/ubuntu/leb-panda/lt-panda-x11-base_20120826-270-ubuntu-desktop.img.gz

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/279/lt-panda-x11-base-precise_ubuntu-desktop_20120830-279.img.gz

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/299/lt-panda-x11-base-precise_ubuntu-desktop_20120909-299.img.gz

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/312/lt-panda-x11-base-precise_ubuntu-desktop_20120916-312.img.gz

Botao (botao-sun) wrote :

On Thu, Jul 26, 2012 at 3:06 AM, Botao Sun <email address hidden> wrote:
> Public bug reported:
>
> On Panda 4460 board, with hardware pack:
>
> http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/197
> /hwpack_linaro-lt-panda-x11-base_20120723-197_armhf_supported.tar.gz
>
> and ubuntu rootfs:
>
> http://snapshots.linaro.org/precise/images/ubuntu-desktop/305/linaro-
> precise-ubuntu-desktop-20120723-305.tar.gz
>
> There is no output for "es2gears" & "glmark2-es2" test. Refer to
> attachment to get full serial console log.

Are you using Unity 3D or Unity 2D while running both applications? I
know there's an issue with the current PVR driver in case you're
running Unity 3D.

@Ricardo, I'm using Unity 3D to run these test programs - log out and log in with "ubuntu" option. And after triggered them, no output in console, and system UI hangs too.

Therefore, I back to Unity 2D to run them again, they can be launched up successfully, but many errors follow. However, I can see the gears when run "es2gears", and different graphic shapes when "glmark2-es2" runs. System UI now can keep alive even these 2 test programs terminated by some unknown errors.

Refer to attachment to get the log output in my serial console.

Botao (botao-sun) wrote :

For Panda 4460 board, observed same behaviour as comment #3 on DVI-D display mode with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/219/lt-panda-x11-base-precise_ubuntu-desktop_20120803-219.img.gz

Refer to attachment to get the running log in serial console.

Botao (botao-sun) wrote :

Same behaviour observed as comment #3 & #5 on Panda 4430 board with same pre-built image as Panda 4460.

Amit Khare (amit-khare) wrote :

observed with panda ubuntu build on 4430

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/256/lt-panda-x11-base-precise_ubuntu-desktop_20120819-256.img.gz

with 3D running "glmark2-es2" hangs the board

Botao (botao-sun) wrote :

For Panda 4460 board, observed same behaviour as comment #3 on DVI-D display mode with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/256/lt-panda-x11-base-precise_ubuntu-desktop_20120819-256.img.gz

However, no error flushing out in serial console now.

Botao (botao-sun) wrote :

For comment #11, the board hangs after run "es2gears" & "glmark2-es2" tests.

Ricardo Salveti (rsalveti) wrote :
Download full text (3.1 KiB)

Tested with http://snapshots.linaro.org/precise/images/ubuntu-desktop/376/linaro-precise-ubuntu-desktop-20120826-376.tar.gz + http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/270/hwpack_linaro-lt-panda-x11-base_20120826-270_armhf_supported.tar.gz and it didn't hang the board as described by previous comments.

Here's the output:

$ glmark2-es2
PVR:(Warning): PVRSRVOpenDCDevice: Warning - 138 returned [95, /bridged_pvr_dc_glue.c]
=======================================================
    glmark2 2012.08
=======================================================
    OpenGL Information
    GL_VENDOR: Imagination Technologies
    GL_RENDERER: PowerVR SGX 540
    GL_VERSION: OpenGL ES 2.0 build 1.9@956766
=======================================================
[build] use-vbo=false: FPS: 62 FrameTime: 16.129 ms
[build] use-vbo=true: FPS: 71 FrameTime: 14.085 ms
[texture] texture-filter=nearest: FPS: 76 FrameTime: 13.158 ms
[texture] texture-filter=linear: FPS: 75 FrameTime: 13.333 ms
[texture] texture-filter=mipmap: FPS: 74 FrameTime: 13.514 ms
[shading] shading=gouraud: FPS: 63 FrameTime: 15.873 ms
[shading] shading=blinn-phong-inf: FPS: 66 FrameTime: 15.152 ms
[shading] shading=phong: FPS: 63 FrameTime: 15.873 ms
[bump] bump-render=high-poly: FPS: 46 FrameTime: 21.739 ms
[bump] bump-render=normals: FPS: 72 FrameTime: 13.889 ms
[bump] bump-render=height: FPS: 68 FrameTime: 14.706 ms
[effect2d] kernel=0,1,0;1,-4,1;0,1,0;: FPS: 35 FrameTime: 28.571 ms
[effect2d] kernel=1,1,1,1,1;1,1,1,1,1;1,1,1,1,1;: FPS: 15 FrameTime: 66.667 ms
[pulsar] light=false:quads=5:texture=false: FPS: 74 FrameTime: 13.514 ms
[desktop] blur-radius=5:effect=blur:passes=1:separable=true:windows=4: FPS: 2 FrameTime: 500.000 ms
[desktop] effect=shadow:windows=4: FPS: 53 FrameTime: 18.868 ms
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=map: FPS: 53 FrameTime: 18.868 ms
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=subdata: FPS: 74 FrameTime: 13.514 ms
[buffer] columns=200:interleave=true:update-dispersion=0.9:update-fraction=0.5:update-method=map: FPS: 76 FrameTime: 13.158 ms
[ideas] speed=duration: FPS: 35 FrameTime: 28.571 ms
[jellyfish] <default>: FPS: 40 FrameTime: 25.000 ms
[terrain] <default>: FPS: 2 FrameTime: 500.000 ms
[conditionals] fragment-steps=0:vertex-steps=0: FPS: 111 FrameTime: 9.009 ms
[conditionals] fragment-steps=5:vertex-steps=0: FPS: 73 FrameTime: 13.699 ms
[conditionals] fragment-steps=0:vertex-steps=5: FPS: 110 FrameTime: 9.091 ms
[function] fragment-complexity=low:fragment-steps=5: FPS: 92 FrameTime: 10.870 ms
[function] fragment-complexity=medium:fragment-steps=5: FPS: 62 FrameTime: 16.129 ms
[loop] fragment-loop=false:fragment-steps=5:vertex-steps=5: FPS: 91 FrameTime: 10.989 ms
[loop] fragment-steps=5:fragment-uniform=false:vertex-steps=5: FPS: 77 FrameTime: 12.987 ms
[loop] fragment-steps=5:fragment-uniform=true:vertex-steps=5: FPS: 59 FrameTime: 16.949 ms
=======================================================
                                  glmark2 Score: 62
=======================================================

Marking it as f...

Read more...

Changed in linaro-ubuntu:
status: New → Fix Committed
importance: Undecided → High
milestone: none → 12.08
Botao (botao-sun) wrote :

@Ricardo, "es2gears" & "glmark2-es2" work well on HDMI+Unity 2D mode. However, if log out and log in with "ubuntu" option to activate Unity 3D, the test would hang the board.

Botao (botao-sun) wrote :

Same behaviour observed as comment #14 on Linaro ubuntu pre-built image:

http://releases.linaro.org/12.08/.ubuntu/leb-panda/lt-panda-x11-base_20120826-270-ubuntu-desktop.img.gz

No output of "es2gears" & "glmark2-es2", board hangs, except mouse pointer can be moved.

@Ricardo, would you want me to raise a new bug to specify the behaviour on the HDMI + Unity 3D mode?

Amit Khare (amit-khare) wrote :

observed with panda 4430 ubuntu build
http://releases.linaro.org/12.08/ubuntu/leb-panda/lt-panda-x11-base_20120826-270-ubuntu-desktop.img.gz

works fine on 2D but with 3D glmark2-es2 hangs the board

Amit Khare (amit-khare) wrote :

observed with panda 4430 ubuntu build
http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/279/lt-panda-x11-base-precise_ubuntu-desktop_20120830-279.img.gz
works fine on 2D but with 3D glmark2-es2 and es2gears hangs the board

Botao (botao-sun) wrote :

For Panda 4460 board, observed on Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/279/lt-panda-x11-base-precise_ubuntu-desktop_20120830-279.img.gz

No output of "es2gears" & "glmark2-es2", board hangs, except mouse pointer can be moved. Since Unity 3D will be the fundamental feature on ubuntu platform, then we need to think about how to fix this issue.

Ricardo Salveti (rsalveti) wrote :

Please open a new bug explaining the issue happening when you run glmark2 with Unity 3d.

Changed in linaro-ubuntu:
status: Fix Committed → Fix Released
Botao (botao-sun) wrote :

@Ricardo, a new bug has been raised for Panda 4430 board on this issue:

https://bugs.launchpad.net/linaro-ubuntu/+bug/1050255

And this bug can be used for Panda 4460 since the phenomenon it describes is run "es2gears" & "glmark2-es2" test under the HDMI + Unity 3D mode (refer to comment #3).

description: updated
summary: - No output of "es2gears" & "glmark2-es2" on ubuntu Panda 4460 board.
+ Panda 4460 with HDMI + Unity 3D: No output on "es2gears" & "glmark2-es2"
+ test, system UI hangs.
Changed in linaro-ubuntu:
status: Fix Released → Confirmed
Botao (botao-sun) on 2012-09-20
description: updated
Fathi Boudra (fboudra) on 2013-03-29
Changed in linaro-ubuntu:
milestone: 12.08 → none
Botao (botao-sun) wrote :

For project "linaro-ubuntu", Linaro has switched from GUI based ubuntu image to solid command line console, and this "es2gears" & "glmark2-es2" test on HDMI + Unity 3D mode is no longer applicable.

Changed in linaro-ubuntu:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers