android Kernels compiled from 4.6-2011.12 toolchain fails to boot

Bug #903690 reported by vishal on 2011-12-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
New
High
Unassigned
Linaro GCC
Incomplete
Undecided
Unassigned

Bug Description

Origen kernel runs into a kernel panic when compiled from https://android-build.linaro.org/builds/~linaro-android/toolchain-4.6-2011.12/#build=5 .

staging-Panda build (https://android-build.linaro.org/builds/~linaro-android/staging-panda/#build=136) based on the same toolchain fails to boot on pandaboard

Fathi Boudra (fboudra) on 2011-12-13
Changed in linaro-android:
importance: Undecided → High
Michael Hope (michaelh1) wrote :

(Pulled in from the duplicate LP: #903692)

Hi Vishal. Could you treat this as if it was kernel bug and investigate further please? Reducing the fault to the function or assembly code where the problem happens, along with instructions to reproduce it would be great.

You might want to try building with -mno-unaligned-access to see if that works around the problem.

Changed in gcc-linaro:
status: New → Incomplete
vishal (vishalbhoj) wrote :

This is a duplicate of https://bugs.launchpad.net/linaro-android/+bug/903951 and the fix has been committed .

Changed in linaro-android:
status: New → Invalid
status: Invalid → Opinion
status: Opinion → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers