The kernel on staging-panda does not boot with the 11.12 released toolchain

Reported by Zach Pfeffer on 2011-12-13
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linaro Android
Critical
Bernhard Rosenkraenzer
Linaro GCC
Undecided
Unassigned
Zach Pfeffer (pfefferz) on 2011-12-13
Changed in linaro-android:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Bernhard Rosenkraenzer (berolinux)
milestone: none → 11.12

The only relevant difference between build 1 and build 5 is an update from linaro-gcc 11.11 to 11.12

Michael Hope (michaelh1) wrote :

Is this a duplicate of LP: #903690 and #903692? My comment on #903690 is:

Could you treat this as if it was kernel bug and investigate further please? Reducing the fault to the function or assembly code where the problem happens, along with instructions to reproduce it would be great.

You might want to try building with -mno-unaligned-access to see if that works around the problem.

Changed in gcc-linaro:
status: New → Incomplete

It might be caused by the same things as 903690/903692, but it seems to be a different issue.
903690 and 903692 cause a kernel panic, while 903951 causes the kernel to simply not boot, hanging immediately after saying
"Uncompressing Linux... done, booting the kernel."

Will try -mno-unaligned-access

-mno-unaligned-access works and is added to the build scripts, so marking it "fix committed" on the Android side for this release.
I wish there was a "Workaround committed" status...

Changed in linaro-android:
status: Confirmed → Fix Committed
Marc Dietrich (marvin24) wrote :

acording to the thread here:

http://comments.gmane.org/gmane.linux.ports.arm.kernel/117863

the fix is to enable -fno-conserve-stack instead (which I couldn't find upstream, only in

http://linux-arm.org/git?p=linux-2.6.git;a=commitdiff;h=292542276840f753fd0332097c51bc2edc70b132 )

Marc Dietrich (marvin24) wrote :

after googling a bit more, seems that upstream patch 8428e84d (ARM: 7150/1: Allow kernel unaligned accesses on ARMv6+ processors) may fix it. Due to missing compiler I cannot test it right now.

Tony Mansson (tony-mansson) wrote :

The workaround is deemed acceptable, since we will be working actively on unaligned access problems also in 12.01 and there is no risk the issue will be forgotten. Hence workaround is committed.

Changed in linaro-android:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers