Bluetooth does not work on Origen

Reported by Zach Pfeffer on 2011-09-26
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Medium
Unassigned
Linaro Ubuntu
High
Ricardo Salveti
linaro-landing-team-samsung
Fix Released
Medium
Sangwook Lee

Bug Description

On https://android-build.linaro.org/builds/~linaro-android/staging-origen-11.09-release/#build=2
Bluetooth doesn't work. When you enable it on the UI it just sends back an error.

Affects 11.09, 11.10 releases.

Zach Pfeffer (pfefferz) on 2011-09-26
Changed in linaro-android:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Zach Pfeffer (pfefferz)
description: updated

Bluetooth enablement is not complete for the Origen board. The LT is
currently working on it.

Angus

On Mon, Sep 26, 2011 at 12:34 PM, Launchpad Bug Tracker
<email address hidden> wrote:
> You have been subscribed to a public bug by Zach Pfeffer (pfefferz):
>
> On
>
> https://android-build.linaro.org/builds/~linaro-android/staging-
> origen-11.09-release/#build=2
>
> Bluetooth doesn't work
>
> ** Affects: linaro-android
>     Importance: Medium
>     Assignee: Zach Pfeffer (pfefferz)
>         Status: Confirmed
>
> ** Affects: linaro-landing-team-samsung
>     Importance: Undecided
>         Status: New
>
> --
> Bluetooth does not work on Origen 11.09 build 2
> https://bugs.launchpad.net/bugs/859886
> You received this bug notification because you are subscribed to the bug report.
>

--
Angus Ainslie <email address hidden>
Team Lead, Samsung Landing Team

Fathi Boudra (fboudra) on 2011-09-27
Changed in linaro-landing-team-samsung:
status: New → Confirmed
Changed in linaro-landing-team-samsung:
milestone: none → 2011.10
assignee: nobody → Sangwook Lee (sangwook)
importance: Undecided → Medium

Samsung LT made How Doc:
 - https://wiki.linaro.org/Resources/HowTo/SamsungBTInOrigen

We need to prepare two patches for Bluetooth in Origen
1) Platform specific
   released internally and loading into g.l.o

2) rfkill gpio specific
One patch is released to Wireless mainline mailing list:
- https://lkml.org/lkml/2011/9/26/240
and preparing one more patch now to be released

Sangwook Lee (sangwook) on 2011-10-18
Changed in linaro-landing-team-samsung:
status: Confirmed → Fix Released
Sangwook Lee (sangwook) wrote :

Bluetooth Driver is complete, Now it is time to update Android Platform source code.

Android Platform Source code:
please add the following:
-----------------------------------------------------------------------------------------------------------------------------------
Init.origen.rc:
service bccmd /system/bin/bccmd -t bcsp -d /dev/ttySAC0 psload -r /system/etc/bluetooth/origen.psr
    disable
    oneshot

service hciattach /system/bin/hciattach -s 921600 /dev/ttySAC0 bcsp 921600 flow
    disable
    oneshot

-------------------------------------------------------------------------------------------------------------------------

"bccmd" is located at /external/bluetooth/bluez/tools/bccmd.c of the current Androd platform source code.

Sangwook Lee (sangwook) wrote :

To compile bccmd.c file, it is needed to set "BOARD_HAVE_BLUETOOTH_CSR".

For details:
http://nv-tegra.nvidia.com/gitweb/?p=android/platform/external/bluetooth/bluez.git;a=log;h=refs/heads/rel-12r3

Sangwook Lee (sangwook) on 2011-10-18
Changed in linaro-landing-team-samsung:
status: Fix Released → Fix Committed
Sangwook Lee (sangwook) wrote :

external/bluetooth/bluez/tools/Android.mk
---------------------------------------------------------------------

 include $(BUILD_EXECUTABLE)

+# Tools useful only for CSR Bluetooth chips
+ifeq ($(BOARD_HAVE_BLUETOOTH_CSR),true)
 #
+# bccmd
+#
+
+include $(CLEAR_VARS)
+
+LOCAL_SRC_FILES:= \
+ bccmd.c \
+ csr.c \
+ csr_hci.c \
+ csr_bcsp.c \
+ csr_h4.c \
+ csr_3wire.c \
+ ubcsp.c
+
+LOCAL_C_INCLUDES:= \
+ $(LOCAL_PATH)/../lib/
+
+LOCAL_CFLAGS:= \
+ -DVERSION=\"3.36\" -fpermissive
+
+LOCAL_SHARED_LIBRARIES := \
+ libbluetooth
+
+LOCAL_MODULE_TAGS := optional
+LOCAL_MODULE:=bccmd
+
+include $(BUILD_EXECUTABLE)
+
+# End of BOARD_HAVE_BLUETOOTH_CSR
+endif
+
------------------------------------------------------

Botao Sun (botao-sun) on 2011-10-18
Changed in linaro-android:
status: Confirmed → In Progress
Sangwook Lee (sangwook) on 2011-10-18
Changed in linaro-landing-team-samsung:
status: Fix Committed → In Progress
Sangwook Lee (sangwook) wrote :

Apply patch (my idea) for Android Bluetooth in Origen

File: system/bluetooth/bluedroid/bluetooth.c of Android platform

    if (set_bluetooth_power(1) < 0) goto out;

+ LOGI("Starting bccmd daemon");
+ if (property_set("ctl.start", "bccmd") < 0) {
+ LOGE("Failed to start bccmd");
+ goto out;
+ }

    LOGI("Starting hciattach daemon");
    if (property_set("ctl.start", "hciattach") < 0) {
        LOGE("Failed to start hciattach");
        goto out;
    }

Note that the end stage of executing "bccmd" will return error,
but we have to ignore that.

Further Information:

Function init_rfill() in the above file will check out the following two files, which is currently supported by Linaro Kernel.
root@linaro-alip:/sys/class/rfkill# ls -al
drwxr-xr-x 2 root root 0 Jan 1 00:00 .
drwxr-xr-x 28 root root 0 Jan 1 00:00 ..
lrwxrwxrwx 1 root root 0 Jan 1 00:00 rfkill0 -> ../../devices/platform/rfkill_gpio/rfkill/rfkill0
lrwxrwxrwx 1 root root 0 Jan 1 00:05 rfkill1 -> ../../devices/platform/s5pv210-uart.0/tty/ttySAC0/hci0/rfkill1

Botao Sun (botao-sun) on 2011-10-19
Changed in linaro-android:
assignee: Zach Pfeffer (pfefferz) → Botao Sun (botao-sun)
Botao Sun (botao-sun) on 2011-10-19
Changed in linaro-android:
milestone: none → 11.11
Sangwook Lee (sangwook) wrote :

Scanning function/Discovery was verified in Ubuntu.
https://wiki.linaro.org/Resources/HowTo/SamsungBTInOrigen
Bluetooth rfkill-gpio driver is implemented in Linaro Kernel.

Android BT functionality will be verified later.

Changed in linaro-landing-team-samsung:
status: In Progress → Fix Committed
Sangwook Lee (sangwook) on 2011-10-20
Changed in linaro-landing-team-samsung:
status: Fix Committed → In Progress
Zach Pfeffer (pfefferz) on 2011-10-20
Changed in linaro-android:
importance: Medium → High
Changed in linaro-landing-team-samsung:
milestone: 2011.10 → 2011.11
Ricardo Salveti (rsalveti) wrote :

Also an issue with Ubuntu:
Hwpack: hwpack_linaro-lt-origen_20111022-0_armel_supported.tar.gz
Image: linaro-o-ubuntu-desktop-tar-20111023-0.tar.gz

Changed in linaro-ubuntu:
status: New → Confirmed
milestone: none → 11.10
tags: added: bluetooth origen
tags: added: linaro-ubuntu lt-origen
removed: origen
Fathi Boudra (fboudra) on 2011-11-11
Changed in linaro-ubuntu:
milestone: 11.10 → 11.11
summary: - Bluetooth does not work on Origen 11.09 build 2
+ Bluetooth does not work on Origen
description: updated
Changed in linaro-landing-team-samsung:
milestone: 2011.11 → 2011.12
Angus Ainslie (angus-akkea) wrote :

There is a dependency on an origen.psr file that has unknown licensing.

blocked waiting for information from Samsung

Changed in linaro-ubuntu:
importance: Undecided → Medium
assignee: nobody → Ricardo Salveti (rsalveti)
Ricardo Salveti (rsalveti) wrote :

Also happens with 11.11 RC on Ubuntu side.

Changed in linaro-ubuntu:
milestone: 11.11 → none
Zach Pfeffer (pfefferz) on 2011-11-25
Changed in linaro-android:
milestone: 11.11 → 11.12
Botao Sun (botao-sun) wrote :

After applied these 3 changes: 1024, 1031 & 1032, the "bluez" module has been added into manifest with 4.0.1 branch; the "bccmd" has been compiled successfully and transferred to the path "/system/bin".

However, there is no "Bluetooth" item in "Settings" menu, so I can't test it from UI in this condition.

On Fri, Dec 2, 2011 at 1:34 AM, Botao Sun <email address hidden> wrote:
> After applied these 3 changes: 1024, 1031 & 1032, the "bluez" module has
> been added into manifest with 4.0.1 branch; the "bccmd" has been
> compiled successfully and transferred to the path "/system/bin".
>
> However, there is no "Bluetooth" item in "Settings" menu, so I can't
> test it from UI in this condition.
>

Either the initilization cammands in init.origen.rc haven't been run
or something else needs to be done in userland to have the device
recognized.

> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/859886
>
> Title:
>  Bluetooth does not work on Origen
>
> Status in Linaro Android:
>  In Progress
> Status in Linaro Samsung Landing Team Project:
>  In Progress
> Status in Linaro Ubuntu Evaluation Builds:
>  Confirmed
>
> Bug description:
>  On https://android-build.linaro.org/builds/~linaro-android/staging-origen-11.09-release/#build=2
>  Bluetooth doesn't work. When you enable it on the UI it just sends back an error.
>
>  Affects 11.09, 11.10 releases.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/859886/+subscriptions
>

--
Angus Ainslie <email address hidden>
Team Lead, Samsung Landing Team

Botao Sun (botao-sun) wrote :

The return value of "hciconfig" is empty:

root@android:/system/modules # hciconfig
root@android:/system/modules #

Looks like the Bluetooth chip can't be recognized. After I run "hciconfig up", it shows:

Can't get device info: No such device.

Below is the code in "init.origen.rc" file which is related to the Bluetooth:

# For Samsung Origen Bluetooth Feature
service bccmd /system/bin/bccmd -t bcsp -d /dev/ttySAC0 psload -r /system/etc/bluetooth/origen.psr
    disabled
    oneshot

service hciattach /system/bin/hciattach -s 921600 /dev/ttySAC0 bcsp 921600 flow
    disabled
    oneshot

Angus Ainslie (angus-akkea) wrote :

On Dec 3, 2011 2:35 AM, "Botao Sun" <email address hidden> wrote:
>
> The return value of "hciconfig" is empty:
>
> root@android:/system/modules # hciconfig
> root@android:/system/modules #
>
> Looks like the Bluetooth chip can't be recognized. After I run
> "hciconfig up", it shows:
>
> Can't get device info: No such device.
>
> Below is the code in "init.origen.rc" file which is related to the
> Bluetooth:
>
> # For Samsung Origen Bluetooth Feature
> service bccmd /system/bin/bccmd -t bcsp -d /dev/ttySAC0 psload -r
/system/etc/bluetooth/origen.psr
> disabled
> oneshot
>

Does 'disabled' mean these commands aren't to be run ?

If these commands don't run the bluetooth chip won't get initialized

> service hciattach /system/bin/hciattach -s 921600 /dev/ttySAC0 bcsp
921600 flow
> disabled
> oneshot
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/859886
>
> Title:
> Bluetooth does not work on Origen
>
> Status in Linaro Android:
> In Progress
> Status in Linaro Samsung Landing Team Project:
> In Progress
> Status in Linaro Ubuntu Evaluation Builds:
> Confirmed
>
> Bug description:
> On
https://android-build.linaro.org/builds/~linaro-android/staging-origen-11.09-release/#build=2
> Bluetooth doesn't work. When you enable it on the UI it just sends back
an error.
>
> Affects 11.09, 11.10 releases.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/859886/+subscriptions

Botao Sun (botao-sun) wrote :

1. About "disabled" keyword:

This keyword means this service will not be executed during the boot process, it will be performed by the component at the time when need it. For example, WPA Supplicant service will be run after user clicks Wi-Fi from "Settings" menu to enable it.

Therefore, the bccmd and hciattach won't be run until someone clicked Bluetooth to enable it. But there is no Bluetooth item in "Settings" menu.

2. There is no "origen.psr" file:

The "origen.psr" doesn't exist in ICS, so this command won't be executed successfully - /system/bin/bccmd -t bcsp -d /dev/ttySAC0 psload -r /system/etc/bluetooth/origen.psr (I tried, the result is: Initialization timed out).

Should I create it by myself? If so, what contents should I add in?

3. I read this article https://wiki.linaro.org/Resources/HowTo/SamsungBTInOrigen, and according to the description, the Android platform requires "rfkill" to turn on / off the Bluetooth, but there is no "rfkill" in ICS.

Botao Sun (botao-sun) wrote :

The changes based on "origen-device.diff" and "origen-psr.patch" which Angus sent to me have been submitted and merged. However, I still got the error when I run the command manually:

1|root@android:/ # /system/bin/bccmd -t bcsp -d /dev/ttySAC0 psload -r /system/etc/firmware/bluetooth/origen.psr
Initialization timed out

1|root@android:/ # /system/bin/hciattach -s 921600 /dev/ttySAC0 bcsp 921600 flow
BCSP initialization timed out

1|root@android:/ # ls -l /dev/ttySAC0
crw------- root root 204, 64 2000-01-01 00:41 ttySAC0

There is no error, but only timed out. Need to investigate it.

Sangwook Lee (sangwook) wrote :

Before you running,
$ /system/bin/bccmd -t bcsp -d /dev/ttySAC0 psload -r

Please make sure that

1) Kernel log
You have to see from kernel booting message:
  1.405000] rfkill_gpio rfkill_gpio: origen-bt device registered.
which means that kernel already has rfkill gpio module.

2) Can "printf of bccmd cmd source" appear in Android command line ?

it shows as like

-----------------------------------------
root@linaro-alip:~# bccmd -t bcsp -d /dev/ttySAC0 psload -r origen.psr
Loading PSKEY_BDADDR ... done
Loading 0x01ea ... done
Loading PSKEY_RX_MR_SAMP_CONFIG ... done
Loading PSKEY_TX_OFFSET_HALF_MHZ ... done
Loading PSKEY_TEMPERATURE_VS_DELTA_TX_BB_MR_PAYLOAD ... done
Loading PSKEY_TEMPERATURE_VS_DELTA_TX_BB_MR_HEADER ... done
Loading PSKEY_TEMPERATURE_VS_DELTA_TX_BB ... done
Loading PSKEY_TEMPERATURE_VS_DELTA_INTERNAL_PA ... done
Loading 0x212c ... done
Loading 0x212d ... done
Loading 0x212e ... done
Loading 0x2139 ... done
Loading 0x213a ... done
Loading 0x213b ... done
--------------------------------------

3) Permission setting of ttySAC0:

crw-rw---- 1 root dialout 204, 64 1970-01-01 00:00 /dev/ttySAC0

Sangwook Lee (sangwook) wrote :

Please make sure that you have the following kernel booting message:
You have HCI BCSP protocol in kernel booting message. HCI BCSP is used by command "bccmd".

4)
     1.360000] Bluetooth: HCI UART driver ver 2.2
[ 1.365000] Bluetooth: HCI H4 protocol initialized
[ 1.370000] Bluetooth: HCI BCSP protocol initialized

Sangwook Lee (sangwook) wrote :

Sequence in summary:

1) Initialize Bluetooth device
$> bccmd -t bcsp -d /dev/ttySAC0 psload -r origen.psr

2) Connect Serial driver to CSR Bluetooth external chip as the speed of 921600
$> hciattach -s 921600 /dev/ttySAC0 bcsp 921600
Device setup comp[ 3100.020000]
Bluetooth: Out-of-order packet arrived, got 1 expected 0 <== Ignore this, it's fine

3) Up the Bluetooth stack
$> hciconfig hci0 up

4) Show current Bluetooth device
$> hciconfig -a

Ricardo Salveti (rsalveti) wrote :

With the Ubuntu LEB 11.12 RC image, the bluetooth is working as we now have the origen-bluetooth package that set it up correctly during boot.

Changed in linaro-ubuntu:
status: Confirmed → Fix Released
milestone: none → 11.12
importance: Medium → High
Zach Pfeffer (pfefferz) on 2011-12-21
Changed in linaro-android:
milestone: 11.12 → 12.01
Zach Pfeffer (pfefferz) on 2012-01-06
Changed in linaro-android:
importance: High → Medium
assignee: Botao Sun (botao-sun) → Zach Pfeffer (pfefferz)
Zach Pfeffer (pfefferz) on 2012-01-09
Changed in linaro-android:
assignee: Zach Pfeffer (pfefferz) → Amit Pundir (pundiramit)
milestone: 12.01 → none
milestone: none → 12.01
milestone: 12.01 → none
Amit Pundir (pundiramit) on 2012-01-19
Changed in linaro-android:
status: In Progress → Fix Committed
milestone: none → 12.01
Amit Pundir (pundiramit) wrote :
Changed in linaro-android:
status: Fix Committed → Fix Released
Zach Pfeffer (pfefferz) wrote :

Having issues on https://android-build.linaro.org/builds/~linaro-android/staging-origen-12.01-release/#build=2. It sees the BlueZ but I can't connect to it. Maybe something local.

Changed in linaro-android:
status: Fix Released → In Progress
Amit Pundir (pundiramit) wrote :

Damn. I made a typo in Android.mk http://review.android.git.linaro.org/#change,1437 because of which my "CSR" specific modifications did not compile.

Amit Pundir (pundiramit) wrote :

Verified on https://android-build.linaro.org/builds/~linaro-android/staging-origen/#build=161

Only OPP profile is supported at the moment.

Changed in linaro-android:
status: In Progress → Fix Released
milestone: 12.01 → 12.02
Changed in linaro-android:
status: Fix Released → Fix Committed
Zach Pfeffer (pfefferz) wrote :
Changed in linaro-android:
status: Fix Committed → Incomplete
Zach Pfeffer (pfefferz) on 2012-01-30
Changed in linaro-android:
importance: Medium → High
Sangwook Lee (sangwook) on 2012-02-02
Changed in linaro-landing-team-samsung:
status: In Progress → Fix Released
Zach Pfeffer (pfefferz) wrote :

Works onhttps://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc46-samsunglt-stable-blob-12.02-release/#build=1

Changed in linaro-android:
status: Incomplete → Fix Released
vishal (vishalbhoj) wrote :

BT does not work on
https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc46-samsunglt-stable-blob-12.03-release/#build=5
I get these errors:
Bluetooth: hci0 command tx timeout
Bluetooth: hci0 command tx timeout
Bluetooth: hci0 command tx timeout
Bluetooth: hci0 command tx timeout
Bluetooth: hci0 command tx timeout
Bluetooth: hci0 command tx timeout
Bluetooth: hci0 command tx timeout
Bluetooth: hci0 command tx timeout
Bluetooth: hci0 command tx timeout

Changed in linaro-android:
status: Fix Released → New
Sangwook Lee (sangwook) wrote :

@vishal

Did you run scanning command ? or Is it from initialisation ?
At first glance, it seems not to from booting up from Bluetooth.

If possible, please upload kernel message as well.

Botao Sun (botao-sun) wrote :

On build:

https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob-12.04-release/#build=2

This test case failed:

https://wiki.linaro.org/Platform/QA/TestCases/Android#bluetooth

Bluetooth can be launched successfully, but can't receive the files. Also, after clicked "OFF" to turn it off, it would pop up a window with message:

Unfortunately, the process com.android.phone has stopped.

There are some snapshot pictures in attachment.

Zach Pfeffer (pfefferz) on 2012-04-24
Changed in linaro-android:
milestone: 12.02 → 12.05
assignee: Amit Pundir (pundiramit) → Chengjie HE (chengjie-he)
importance: High → Medium
Zach Pfeffer (pfefferz) on 2012-05-01
Changed in linaro-android:
milestone: 12.05 → none
Botao Sun (botao-sun) wrote :

Bluetooth works well on Origen 12.05 Android Google Hangout release build:

https://android-build.linaro.org/builds/~linaro-android/origen-hangout-demo-12.05-release/#build=1

Botao Sun (botao-sun) wrote :

For Origen, on build:

https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob-12.05-release/#build=6

Bluetooth can pair devices but can't browse the file system & send file.

Botao Sun (botao-sun) wrote :

Observed on Origen Linaro Android build:

https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob/#build=63

Pair succeed, browse & file transfer failed.

Botao Sun (botao-sun) wrote :

Observed on Origen Linaro Android build:

https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob-12.06-release/#build=2

Pair succeed, browse & file transfer failed.

Botao Sun (botao-sun) wrote :

Observed on Origen Linaro Android build:

https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob/#build=78

Pair succeed, browse & file transfer failed.

Botao Sun (botao-sun) wrote :
Download full text (12.9 KiB)

For Samsung Origen board with Linaro Android build:

https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob/#build=82

Kernel panic when trying to send file from host to target:

[ 391.835000] Bluetooth: Out-of-order packet arrived, got 1 expected 0
[ 408.705000] Bluetooth: Error in BCSP hdr checksum
[ 408.960000] Bluetooth: Error in BCSP hdr checksum
[ 410.125000] Bluetooth: Error in BCSP hdr checksum
[ 446.635000] Unable to handle kernel paging request at virtual address 001004
[ 446.640000] pgd = c0004000
[ 446.645000] [00100104] *pgd=00000000
[ 446.645000] Internal error: Oops: 817 [#1] PREEMPT SMP ARM
[ 446.650000] Modules linked in: gator [last unloaded: ath6kl]
[ 446.660000] CPU: 0 Not tainted (3.4.0 #1)
[ 446.660000] PC is at l2cap_chan_destroy+0x3c/0x88
[ 446.665000] LR is at __raw_write_lock+0x38/0xa0
[ 446.670000] pc : [<c04d11b0>] lr : [<c051c2a4>] psr: 20010013
[ 446.670000] sp : c1a93d40 ip : 00100100 fp : c1a93d54
[ 446.685000] r10: dcd74800 r9 : c189b600 r8 : 00000004
[ 446.690000] r7 : dcd76c00 r6 : 0000000e r5 : 00000004 r4 : dcd76c00
[ 446.695000] r3 : 00200200 r2 : 00100100 r1 : 00200200 r0 : c07fa0ec
[ 446.700000] Flags: nzCv IRQs on FIQs on Mode SVC_32 ISA ARM Segment kel
[ 446.710000] Control: 10c5387d Table: 5db5404a DAC: 00000015
[ 446.715000]
[ 446.715000] PC: 0xc04d1130:
[ 446.720000] 1130 e28400d4 e58430c8 e58430cc ebed923f e3a02002 e3a03001 e5cc
[ 446.725000] 1150 e1a00004 e89da8f0 e3a04010 eaffffdb c0838fd8 c07fa0ec c06c
[ 446.735000] 1170 c04d1640 e1a0c00d e92dd818 e24cb004 e52de004 e8bd4000 e1a4
[ 446.745000] 1190 eb012c5d e59411cc e3a02c01 e594c1c8 e3a03c02 e3402010 e344
[ 446.750000] 11b0 e58c1004 e581c000 e58431cc e58421c8 eb012a12 e284300c f57f
[ 446.760000] 11d0 e2422001 e1831f92 e3310000 1afffffa f57ff05f e3520000 1894
[ 446.765000] 11f0 ebf06adf e89da818 c07fa0ec e1a0c00d e92dd9f8 e24cb004 e520
[ 446.775000] 1210 e3a03013 e5c03065 e5d1301d e5810004 e3530002 0a00001d e351
[ 446.785000]
[ 446.785000] LR: 0xc051c224:
[ 446.790000] c224 e89da800 e1a0c00d e92dd818 e24cb004 e52de004 e8bd4000 ebf0
[ 446.795000] c244 ebec492b e121f004 e89da818 e1a0c00d e92dd800 e24cb004 e520
[ 446.805000] c264 ebffffef e89da800 e1a0c00d e92dd878 e24cb004 e52de004 e8bd
[ 446.810000] c284 e1a04000 e3c23d7f e3a05001 e3c3603f e3a00001 ebecea28 e1a5
[ 446.820000] c2a4 e3500000 0a000002 e3a03000 e5843004 e89da878 e3a00001 ebe0
[ 446.830000] c2c4 e3130002 1a00000d e5943004 e3530000 e5943000 05845004 e353
[ 446.835000] c2e4 ...

Amit Khare (amit-khare) wrote :

observed on origen build
https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob-12.07-release/#build=1

Detects device but when try to pair gives error message "cant communicate with the device"

Amit Khare (amit-khare) wrote :

observed on origen build
https://android-build.linaro.org/builds/~linaro-android/origen-ics-gcc47-samsunglt-stable-blob/#build=99

Detects device but when try to pair gives error message "cant communicate with the device"

Fathi Boudra (fboudra) on 2013-06-07
Changed in linaro-android:
assignee: Chengjie HE (chengjie-he) → nobody
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers