Release a GDB 7.2 2011.05 tarball and verify it works with our platform

Bug #787078 reported by Zach Pfeffer on 2011-05-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Undecided
Jim Huang

Bug Description

1. Release a tarball.
2. Test the tarball.

Original email:

The Linaro Toolchain Working Group is pleased to announce the release
of Linaro GDB 7.2.

Linaro GDB 7.2 2011.05-0 is the sixth release in the 7.2 series. Based
off the latest GDB 7.2, it includes a number of ARM-focused bug fixes.

This release fixes:
 * LP: #615972 Neon registers missing in core files
 * LP: #615978 Failure to software single-step into signal handler
 * LP: #615996 gdb.cp/templates.exp failures

The source tarball is available at:
 https://launchpad.net/gdb-linaro/+milestone/7.2-2011.05-0

More information on Linaro GDB is available at:
 https://launchpad.net/gdb-linaro

-- Michael

Zach Pfeffer (pfefferz) on 2011-05-23
Changed in linaro-android:
assignee: nobody → Jim Huang (jserv)
status: New → Confirmed
Jim Huang (jserv) wrote :

If we use the vanilla one, we would encounter a dependency problem on x86:

$ ldd /tmp/android-toolchain-eabi/bin/arm-eabi-gdb
        libncurses.so.5 => not found
        libm.so.6 => /lib64/libm.so.6 (0x0000000040a40000)
        libexpat.so.1 => not found
        libc.so.6 => /lib64/libc.so.6 (0x0000000040cc3000)
        /lib64/ld-linux-x86-64.so.2 (0x0000000040000000)

That is because we didn't get libraries (libexpat) statically linked. We can refer to the hacks from Google's gdb-7.1.x .

Zach Pfeffer (pfefferz) wrote :

Okay. What's the action item then, port what we can or ask the toolchain WG to help?

Jim Huang (jserv) wrote :

Action: pick up static libexpat patch from gdb-7.1.x into gdb-linaro-7.2 and rebuild.

Zach Pfeffer (pfefferz) wrote :

Cool, are you working on that?

Jim Huang (jserv) wrote :
Changed in linaro-android:
status: Confirmed → Fix Released
Zach Pfeffer (pfefferz) wrote :

Need to find a place to distribute and document usage.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers