Snowball : SDCard partition not mounted

Bug #1017823 reported by Abhishek Paliwal on 2012-06-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
IglooCommunity
Low
Kejun ZHOU
Linaro Android
Fix Released
Critical
vishal

Bug Description

Description:
--------------
On Android build for Snowball:
https://android-build.linaro.org/builds/~linaro-android/snowball-ics-gcc46-igloo-stable-blob/#build=339

sd card partition is not mounted , same partition is created by l-a-m-c can be viewed on HOST machine after creating android image but not seen at Android level.

issue can be due to 3.4 kernel migration - builds is on 3.4 kernel.

Logs:
-------------------
On Snowball:
-------------
root@android:/ # df
Filesystem Size Used Free Blksize
/dev 384M 44K 384M 4096
/mnt/asec 384M 0K 384M 4096
/mnt/obb 384M 0K 384M 4096
/system 509M 354M 155M 4096
/cache 253M 15M 237M 1024
/data 508M 94M 414M 1024
/dev/shm 384M 0K 384M 4096
root@android:/ #

Impact:
---------
All SDcard related functionalities can't be checked due to this bug.
eg: Gallery/music/video playback etc.

Steps to reproduce:
------------------------
1. Bootup Snowball board with android image on SDcard.
2. On serial console enter type 'df' command
Issue: sdcard partition not available.

Hardware:
------------
Snowball v11
Serial console up.

summary: - SDCard partition not mounted
+ Snowball : SDCard partition not mounted
description: updated
Jayeeta Bandyopadhyay (jayeeta) wrote :

There is one work around to mount SD card manually by running the following commands from console

mount -t vfat /dev/block/mmcblk1p1 /mnt/sdcard
setprop EXTERNAL_STORAGE_STATE mounted
am broadcast -a android.intent.action.MEDIA_MOUNTED --ez read-only false -d file:///mnt/sdcard

vishal (vishalbhoj) wrote :

http://review.android.git.linaro.org/2364

The above commit should fix the issue

Changed in linaro-android:
assignee: nobody → vishal (vishalbhoj)
milestone: none → 12.07
Changed in igloocommunity:
importance: Undecided → Low
Zach Pfeffer (pfefferz) wrote :
Changed in linaro-android:
status: New → Fix Committed
Amit Khare (amit-khare) wrote :

It seems this issue still exists with snowball latest build
https://android-build.linaro.org/builds/~linaro-android/snowball-ics-gcc46-igloo-stable-blob-12.07-release/#build=1

127|root@android:/ # df
Filesystem Size Used Free Blksize
/dev 384M 44K 384M 4096
/mnt/asec 384M 0K 384M 4096
/mnt/obb 384M 0K 384M 4096
/system 509M 355M 154M 4096
/cache 253M 15M 237M 1024
/data 508M 162M 346M 1024
/dev/shm 384M 0K 384M 4096

vishal (vishalbhoj) wrote :

It seems to be still broken. So retargetting it to 12.08

Changed in linaro-android:
status: Fix Committed → In Progress
milestone: 12.07 → 12.08
Amit Khare (amit-khare) wrote :

I was testing some other test case when i found this for the same build. It seems its working, dont know why it dint showed up earlier. The board had rebooted before this so that can be the case.

127|root@android:/ # df
Filesystem Size Used Free Blksize
/dev 384M 44K 384M 4096
/mnt/asec 384M 0K 384M 4096
/mnt/obb 384M 0K 384M 4096
/system 509M 355M 154M 4096
/cache 253M 15M 237M 1024
/data 508M 162M 346M 1024
/dev/shm 384M 0K 384M 4096
/mnt/sdcard 6G 43M 6G 4096
/mnt/secure/asec 6G 43M 6G 4096

Amit Khare (amit-khare) wrote :

When playing a video from sd card through gallery app, there is sound from hdmi out but not from hardware audio

vishal (vishalbhoj) wrote :

I am closing this bug.I see that sdcard gets mounted .It is just that the android first boot takes a long time to completeon snowball and the user has to wait till the boot is completed before checking the sdcard .

Changed in linaro-android:
milestone: 12.08 → 12.07
status: In Progress → Fix Committed
Kejun ZHOU (kejun-zhou) on 2012-08-02
Changed in igloocommunity:
assignee: nobody → Kejun ZHOU (kejun-zhou)
Kejun ZHOU (kejun-zhou) on 2012-08-03
Changed in igloocommunity:
assignee: Kejun ZHOU (kejun-zhou) → nobody
Kejun ZHOU (kejun-zhou) on 2012-08-03
Changed in igloocommunity:
assignee: nobody → Kejun ZHOU (kejun-zhou)
status: New → Fix Released
Kejun ZHOU (kejun-zhou) wrote :

For this issue on JellyBean, please check the following gerrit
http://review.android.git.linaro.org/2544
http://review.android.git.linaro.org/2545

Alexander Sack (asac) wrote :

this either was not fixed or regressed: see bug 1034789 for the Jelly Bean build

vishal (vishalbhoj) on 2013-03-18
Changed in linaro-android:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers